Setting up Wifi on LEDE build on Omega 2+



  • Hey,

    Been a few months since I played with my Omega and maybe I have forgotten something. I flashed the latest LEDE image ( 17.01.4) to the 2+ and it broadcasts fine on radio0 but I cannot recall what device I need to call to make it connect to an AP as well.

    On the Onion build it is ra0

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    But there is no ra0 device in LEDE. In fact the only devices I see are these.

    cat /proc/net/dev
    Inter-| Receive | Transmit
    face |bytes packets errs drop fifo frame compressed multicast|bytes packets errs drop fifo colls carrier compressed
    eth0.1: 0 0 0 0 0 0 0 0 3240 20 0 0 0 0 0 0
    lo: 142072 2184 0 0 0 0 0 0 142072 2184 0 0 0 0 0 0
    wlan0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
    eth0: 0 0 0 0 0 0 0 0 321263 953 0 0 0 0 0 0
    br-wlan: 0 0 0 0 0 0 0 0 3240 20 0 0 0 0 0 0
    eth0.2: 0 0 0 0 0 0 0 0 311766 917 0 0 0 0 0 0

    So in theory wlan0 should be the device. but when I set it as that I get.

    wifi
    wlan0(): Interface type not supported
    'radio0' is disabled
    wlan0(): Interface type not supported
    'radio0' is disabled

    The wifi device is definitely found because it can be seen via iw.

    iw list
    Wiphy phy0
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    max # sched scan SSIDs: 0
    max # match sets: 0
    max # scan plans: 1
    max scan plan interval: -1
    max scan plan iterations: 0
    Retry short limit: 7
    Retry long limit: 4
    Coverage class: 0 (up to 0m)
    Available Antennas: TX 0 RX 0
    Supported interface modes:
    * IBSS
    * managed
    * AP
    * AP/VLAN
    * monitor
    * mesh point
    Band 1:
    Capabilities: 0x1fe
    HT20/HT40
    SM Power Save disabled
    RX Greenfield
    RX HT20 SGI
    RX HT40 SGI
    TX STBC
    RX STBC 1-stream
    Max AMSDU length: 3839 bytes
    No DSSS/CCK HT40
    Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
    Minimum RX AMPDU time spacing: 4 usec (0x05)
    HT TX/RX MCS rate indexes supported: 0-15
    Frequencies:
    * 2412 MHz [1] (20.0 dBm)
    * 2417 MHz [2] (20.0 dBm)
    * 2422 MHz [3] (20.0 dBm)
    * 2427 MHz [4] (20.0 dBm)
    * 2432 MHz [5] (20.0 dBm)
    * 2437 MHz [6] (20.0 dBm)
    * 2442 MHz [7] (20.0 dBm)
    * 2447 MHz [8] (20.0 dBm)
    * 2452 MHz [9] (20.0 dBm)
    * 2457 MHz [10] (20.0 dBm)
    * 2462 MHz [11] (20.0 dBm)
    * 2467 MHz [12] (20.0 dBm) (no IR)
    * 2472 MHz [13] (20.0 dBm) (no IR)
    * 2484 MHz [14] (20.0 dBm) (no IR)
    valid interface combinations:
    * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 4,
    total <= 4, #channels <= 1, STA/AP BI must match
    HT Capability overrides:
    * MCS: ff ff ff ff ff ff ff ff ff ff
    * maximum A-MSDU length
    * supported channel width
    * short GI for 40 MHz
    * max A-MPDU length exponent
    * min MPDU start spacing

    So what am I missing here? Do I need to specify the device type to something (ie 'ralink' in the default firmware) in which case what should it be?

    Any help appreciated.

    Thanks.



  • Install offical firmware:
    go to -> http://repo.onion.io/omega2/images/ download the latest firmware.
    follow -> https://docs.onion.io/omega2-docs/manual-firmware-installation.html
    Either install the firmware over a usb/sd-card or ethernet expansion.

    Additional information:
    LEDE wifi drivers doesn't work on the omega.



  • @Fabian-Nydegger-0

    Install offical firmware:

    the trouble with the official firmware and i have complained about this on numerous occasions is it does not track lede/openwrt properly. So the 2 things I want working on my omega are f2fs and tinc. Both of which cannot because the damn kernel version does not match up with any of the tools or packages.

    It is for that reason I am using LEDE directly because it is impossible to use the stock firmware with standard packages.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.