New OS Release!



  • @György-Farkas In the stable version of the Omega2 i could not access the Wi-Fi AP Settings on the web console so i was just thinking it was disables as it said nothing of the Wi-Fi AP in the start up guide. So i got very surprised when i was going to setup my second Omega2 and saw the the AP from the first one. The normal thing here would be to disable the AP until the user asked for it again. Now i have had a Omega2 running in my network for months with a default AP and password! It is like if D-link would send out routers with a predefined WiFi password. So if you can't disable the AP make sure the guide helps you change the password else it is just like running a open AP for everyone!



  • @Paul-Cousins Same exact thing happened. Can’t believe how accurate you stated.

    What worked for me was to make backup copies, then copied the original config files from /rom/ to /etc/

    cp -rf /rom/etc/config/ /etc/config/
    cp -rf /rom/etc/dnsmasq.conf /etc/
    cp -rf /rom/etc/rc.local /etc/

    This sets back working system.



  • Any news on this? http://community.onion.io/topic/2246/cannot-satisfy-dependencies-for-kmod-usb-net-rndis
    It is still not possible to install rndis :(


  • administrators

    For anyone experiencing issues with WiFi after upgrading, it's likely that your Omega still has the configuration and wifi programs from the previous firmware, but is now running the new driver (which is not compatible with the old configs).
    If you're in this situation, I would recommend to back-up anything you don't want to lose from the Omega to a USB and perform a factory reset. The same effect can be achieved with @michael-bourque 's method above

    More WiFi Fixes

    Also, we've been investigating some of the open issues with WiFi and have made more fixes.

    Here's the updated list:

    • WPA2
      • AES works
      • AES+TKIP works
      • TKIP works - connects within ~20 seconds as of b182
    • WPA (out-dated and should not be used)
      • AES works - connects within ~20 seconds as of b182
      • AES+TKIP works - connects within ~20 seconds as of b182
      • TKIP works
    • WEP (out-dated and should not be used)
      • Shared Key Authentication works
      • Open System Authentication does not work
    • Open Networks (not secure and should not be used)
      • Works as of b178

    Kernel Module Installation

    It is now possible to install additional kernel modules on your Omega but the following conditions must be met:

    • Your Omega must be on the very latest available firmware
      • If you're on b181 and b182 is available, the installation will not work
    • The kernel modules must be from the Onion Package Repo (no kernel modules from the LEDE/OpenWRT package repos can be installed)

    If there are kernel modules you would like to use that are not in our package repo, please let us know and we'll do our best to include them in a timely fashion.



  • @michael-bourque thanks for that! :) I left the device alone for a couple of weeks and then updated to b183 - it is now stable and connecting to wifi on it's own like it should. I am not going to use it on my production devices yet though - still need to put it through it's paces but I think all will be ok going forward!



  • Still not working on mine

    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.2.0 b186
     -----------------------------------------------------
    root@Omega-954C:/# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: [  158.218846] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  158.247982] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  158.392033] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  158.428506] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) DTLap
    2) VM715599-2G
    3) BTHub5-NZX5
    4) BTWifi-with-FON
    5) BTWifi-X
    
    Selection: 1
    Network: DTLap
    Encryption type: psk2
    Enter password: ------------
    
    > Restarting wifimanager for changes to take effect
    root@Omega-954C:/# [  202.387422] br-wlan: port 1(ra0) entered disabled state
    [  202.405863] device ra0 left promiscuous mode
    [  202.410317] br-wlan: port 1(ra0) entered disabled state
    [  202.445062] IPv6: ADDRCONF(NETDEV_UP): br-wlan: link is not ready
    [  205.587298] device ra0 entered promiscuous mode
    [  205.592048] br-wlan: port 1(ra0) entered forwarding state
    [  205.597659] br-wlan: port 1(ra0) entered forwarding state
    [  205.604563] IPv6: ADDRCONF(NETDEV_CHANGE): br-wlan: link becomes ready
    [  207.593494] br-wlan: port 1(ra0) entered forwarding state
    [  213.206477] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  213.257154] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  213.297049] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  213.333887] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  213.371294] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  268.221646] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  268.290390] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  268.324915] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  268.366434] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  268.404523] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  323.221315] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  323.268246] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  323.301804] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  323.338575] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  323.378340] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  378.211357] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  378.276980] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  378.314991] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  378.355244] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  378.392214] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  433.225179] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  433.291803] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  433.331354] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  433.370975] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    [  433.414573] APPeerProbeReqAction():shiang! PeerProbeReqSanity failed!
    
    

  • administrators

    @austin-Sandford can you run wifisetup -debug and post the output?



  • This post is deleted!


  • Managed to connect to my Mikrotik AP with the b186 !! Hurrah !!

    Just changed the Channel Band in CAPsMan to 2Ghz-g/n and that's it!!. It WORKED!!! 
    
    Ofc with the previous versions I played with this but it didn't work.


  • The new OS release has Kernel crashes when trying to do things with Audio. I cannot seem to run through these steps without a crash:
    https://onion.io/2bt-omega-i2s-audio/


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.