Set up access to two wireless networks



  • Searched but could not find how this is done. Finally got my Omega 2 to find my wireless network. Now if I want to move it to another network, is it a simple duplication of the
    config wifi-iface
    config wifi-config

    A pointer to where this info is would be appreciated, thx, sam



  • @sam-walton You can do this fairly easy on Command Line.
    Please read in the official Onion Omega2 Documentation
    Connecting To WiFi Networks Using wifisetup

    Omega2+ FW: v0.2.0 b178 ... v0.2.0 b186

    Connect to the first network using the wifisetup command.
    Check the result:

    root@Omega-99A5:~# cat /etc/config/wireless
    ...
    
    config wifi-iface 'sta'
    	option device 'radio0'
    	option mode 'sta'
    	option ifname 'apcli0'
    	option encryption 'psk2'
    	option network 'wwan'
    	option disabled '0'
    	option key 'the_first_network's_Password'
    	option ssid 'the_first_network's_SSID'
    
    config wifi-config
    	option key 'the_first_network's_Password'
    	option ssid 'the_first_network's_SSID'
    	option encryption 'psk2'
    

    Connect to the second network using the wifisetup command.
    Check the result:

    root@Omega-99A5:~# cat /etc/config/wireless
    ...
    
    config wifi-iface 'sta'
    	option device 'radio0'
    	option mode 'sta'
    	option ifname 'apcli0'
    	option encryption 'psk2'
    	option network 'wwan'
    	option disabled '0'
    	option key 'the_second_network's_Password'
    	option ssid 'the_second_network's_SSID'
    
    config wifi-config
    	option key 'the_first_network's_Password'
    	option ssid 'the_first_network's_SSID'
    	option encryption 'psk2'
    
    config wifi-config
    	option key 'the_second_network's_Password'
    	option ssid 'the_second_network's_SSID'
    	option encryption 'psk2'
    

    From now on the Omega’s network manager will attempt to connect one of these networks. The first network has higher priority.

    More info: wifisetup -h

    (Another idea: edit the /etc/config/wireless file manually ;-)

    Good luck!



  • Yes, thank you for the prompt response. The info was contained in the link you provided at the end. Perhaps others will find this in their searches more quickly than I, sam


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.