[Solved]Reboot causes USB overlay to disappear?



  • This post is deleted!


  • This is surprising - I too have done the pivot-overlay stuff and have no problem with power off then on nor with running reboot. I assume that you leave the USB drive plugged in over the reboot (sorry if this seems obvious).
    Perhaps you could post a copy of your /etc/config/fstab so we can see if there are any issues.

    The only problem I have had with loosing the pivot-overlay is after doing an oupgrade which does lose it and requires redoing the whole pivot-overlay process as well as re-installing any opkg packages.

    To deal with this, I have setup scripts under /root (which is preserved because I have /root/ named in /etc/sysupgrade.conf) - these scripts perform the pivot-overlay and re-install the opkg packages.

    I understand from other posts that the Omega people are working on changes for a future release that will deal with this



  • Hm. I got similar problem but in my case happened after upgrade.



  • @Rudy-Trujillo After reboot, are you able to detect the /dev/sda device?

    @Milan-Vuckovic Upgrading will erase the configuration file on the Omega, which is why the overlay doesn't work anymore.



  • This post is deleted!


  • @Rudy-Trujillo Would you be able to try the overlay with another USB drive? I just want to see if it's an issue with the USB drive itself or some other issue.



  • This post is deleted!


  • This post is deleted!


  • Hi @Rudy-Trujillo, don't worry. Let's just do our best to figure out the cause of this issue so we can resolve it together.

    Cheers!



  • @Rudy-Trujillo It's all a bit messy at the moment with some extraneous stuff in it. I will try to tidy it up and will post it here when I have done so.



  • @Rudy-Trujillo As promised, details of what I do and example files.
    I basically follow these steps after my pivot-overlay gets "lost" after an oupgrde.

    1. I use this file : pivot-overlay-setup to recreate the overlay on the USB.
      Note that you will need to edit this file if your USB partition is not /dev/sda1
      Note also you will need to do a chmod +x pivot-overlay-setup to make this file executable.
      Then just execute it.
    2. Step 1also recreates /etc/config/fstab and this will need editing as follows:
      Change the lines like:
      • config 'mount'
        option target '/mnt/sda1'
        option uuid 'd0f6c5d4-89ea-453f-8d96-f9d87781424d'
        option enabled '0'
        So they look like:
      • config 'mount'
        option target '/overlay'
        option uuid 'd0f6c5d4-89ea-453f-8d96-f9d87781424d'
        option enabled '1'

    Your option uuid line will be different -specific to your particular USB partition
    After updating your /etc/config/fstab file you will needto reboot your Omega - I normally just power off and power on again

    1. I keep (and maintain) a file like : opkg-restore - this basically just does an opkg update followed by the packages I want installed - you will need to edit this file for the specific packages you want.
      You will again need to do a chmod +x opkg-restore on this file before executing it.


  • This post is deleted!


  • @Rudy-Trujillo From what you posted: with the USB plugged in, it only shows /dev/sda (i.e. the whole USB device),there is no /dev/sda1 (which would represent the partition on the USB hence you will need to format the partition using mkfs.ext4
    However, the command you show for running this is incorrect:



  • @Rudy-Trujillo @Kit-Bishop is right. I didn't see this before, but the first picture you showed might be wrong:

    What_over_should_look_like_df_hT.png

    It says it has mounted /dev/sda as /overlay, whereas it should be one of the partitions under that drive, i.e. /dev/sda1.

    You should try to use a partitioning software such as fdisk or gparted to first create a new partition on your USB drive, and then issuing mkfs.ext4 on the newly created partition. That should be able to solve your problem.

    Please let me know if you have any other questions.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.