Number of clients connected to wifi ap



  • I am trying to find the number of clients connected to my onion ap.

    According to openWrt this should be possible with iwinfo and iw.

    However I get the following:
    root@Omega-F142:~# iwinfo ra0 assoclist
    No information available

    root@Omega-F142:~# iw dev ra0 station dump
    nl80211 not found.

    I am using latest kernel release:
    *root@Omega-F142:~# oupgrade -v

    Device Firmware Version: 0.3.2 b232*

    It is a clean install, more system info below.

    Any suggestions?

    Regards
    Kim

    root@Omega-F142:~# iwinfo ra0 info
    ra0 ESSID: "Omega-F142"
    Access Point: 40:A3:6B:C2:F1:42
    Mode: Client Channel: 11 (unknown)
    Tx-Power: unknown Link Quality: unknown/100
    Signal: unknown Noise: unknown
    Bit Rate: 150.0 MBit/s
    Encryption: unknown
    Type: wext HW Mode(s): unknown
    Hardware: unknown [Generic WEXT]
    TX power offset: unknown
    Frequency offset: unknown
    Supports VAPs: no PHY name: ra0

    root@Omega-F142:~# wifisetup debug
    Collected WiFi and network debug information in /tmp/wifidebug.log file

    ================ WIFI DEBUG LOG ================
    == Wed Nov 20 14:23:38 GMT 2019 ==

    ================ ifconfig ================
    apcli0 Link encap:Ethernet HWaddr 40:A3:6B:C2:F1:44
    inet6 addr: fe80::42a3:6bff:fec2:f144/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    br-wlan Link encap:Ethernet HWaddr 40:A3:6B:C2:F1:42
    inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
    inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
    inet6 addr: fe80::42a3:6bff:fec2:f142/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:359 errors:0 dropped:0 overruns:0 frame:0
    TX packets:362 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:22906 (22.3 KiB) TX bytes:25696 (25.0 KiB)

    eth0 Link encap:Ethernet HWaddr 40:A3:6B:C2:F1:43
    inet addr:192.168.0.106 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::42a3:6bff:fec2:f143/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3742 errors:0 dropped:0 overruns:0 frame:0
    TX packets:792 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:429817 (419.7 KiB) TX bytes:104600 (102.1 KiB)
    Interrupt:5

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:16 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1573 (1.5 KiB) TX bytes:1573 (1.5 KiB)

    ra0 Link encap:Ethernet HWaddr 40:A3:6B:C2:F1:42
    inet6 addr: fe80::42a3:6bff:fec2:f142/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:735 errors:0 dropped:0 overruns:0 frame:0
    TX packets:336 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:44868 (43.8 KiB) TX bytes:16648 (16.2 KiB)
    Interrupt:6

    ================ iwconfig ================
    ra0 RTWIFI SoftAP ESSID:"Omega-F142"
    br-wlan no wireless extensions.

    lo no wireless extensions.

    eth0 no wireless extensions.

          Mode:Managed  Channel=11  Access Point: 40:A3:6B:C2:F1:42   
          Bit Rate=150 Mb/s   
    

    apcli0 RTWIFI SoftAP ESSID:""
    Mode:Managed Channel=11 Access Point: Not-Associated
    Bit Rate:150 Mb/s

    ================ uci show wireless ================
    wireless.radio0=wifi-device
    wireless.radio0.type='ralink'
    wireless.radio0.variant='mt7628'
    wireless.radio0.country='US'
    wireless.radio0.hwmode='11g'
    wireless.radio0.htmode='HT40'
    wireless.radio0.channel='auto'
    wireless.radio0.disabled='0'
    wireless.radio0.device_mode='apsta'
    wireless.radio0.op_mode='preference'
    wireless.ap=wifi-iface
    wireless.ap.device='radio0'
    wireless.ap.mode='ap'
    wireless.ap.network='wlan'
    wireless.ap.ifname='ra0'
    wireless.ap.encryption='psk2'
    wireless.ap.key='12345678'
    wireless.ap.disabled='0'
    wireless.ap.ssid='Omega-F142'
    wireless.sta=wifi-iface
    wireless.sta.device='radio0'
    wireless.sta.mode='sta'
    wireless.sta.ifname='apcli0'
    wireless.sta.encryption='psk2'
    wireless.sta.ssid='YourSsidHere'
    wireless.sta.key='YourPasswordHere'
    wireless.sta.network='wwan'
    wireless.sta.disabled='1'
    wireless.sta.led='omega2p:blue:wifi'



  • The more area an access point covers the more variety there will be in the client connection qualities.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.