USB MIDI



  • Hi,

    I've been struggling for some time to set usb midi on onion omega. I know this is probably one of the least likely things for which people would use onion, but I want it nevertheless :)

    I've installed all alsa related packages, including utils-seq, and when running "aconnect -l -i" to list all midi input devices, I get "/dev/snd/seq no such file". I see that all available alsa modules are loaded (all alsa related kmod packages are installed as far as opkg is concerned), including midi related ones.

    I have observed that when I have usb midi devices plugged in, and I run alsamixer - midi devices show up in selection menu for mixer.

    Has anyone tried using usb midi on omega?

    Is there any official way of recompiling kernel - I've tried official onion omega openwrt buildroot instructions, and I get kernel 4.1, but I see that omega runs 3.18. I don't want to hack much (yet) if there is easier (the right) way to do this.

    I think maybe we are missing some oss legacy modules which would make this work, but I am not sure, that's why I would like to try and compile those modules.

    For now, most important thing for me is that I get aconnect to work, as I want to use omega it as usb-midi router (and later maybe add serial midi or even midi over ethernet/wifi).

    Thanks in advance,
    Djordje



  • I'd love to know if there is an easy way to do this also. I thankyou very much for you post as it saved me hours of going down a rabbit hole that I likely don't have the chops to solve. What I'd love though is to be able to create a hardware interface of my own making with the onion connected to something like sampletank and have lots of fun with it. As sample tank has a learn mode the only think it would need to do is send the right signal and it would be very versatile.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.