Bug with WiFi AP setup using WEP



  • Yes, although I know that WEP isn't the most secure of settings, I want to set up one of the Omegas on my network to act as an access point using WEP security so that I can connect a PocketPC (HP iPAQ hx2495 - something of a relic, but so am I).

    In the Console using the settings app (and after clicking on Wi-Fi AP Settings) I can select WEP for security, enter a password (for example, 123456abcdef), and click on Configure AP. Everything seems to work normally, but if I leave Wi-Fi AP Settings (for example, by clicking on General Settings) and then return to the Wi-Fi AP Settings, my AP Password field changes to 1.

    If I SSH into the Omega at the address assigned by my router, I see that the WiFi settings (in /etc/config/wireless) contains:

    config wifi-iface
    option device 'radio0'
    option network 'wlan'
    option mode 'ap'
    option ssid 'Omega-483F'
    option encryption 'wep'
    option key '1'
    option key1 '123456abcdef'

    If I change the value of option key to '2', the AP Password field changes from 1 to 2. I don't really understand the intricacies of WEP, but it seems to me that this is a bug in the Console's Wi-Fi AP Settings section. I don't know if this has been documented elsewhere, so I thought I should mention it here.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.