@TNT While it might be slightly risky, if you use:

opkg --force-depends install <packagename>

it will do the install despite the repo mismatches.

I suspect this is generally OK so long as there are no ABI changes.