Turns out pillow requires zlib and jpeg. You need to install zlib-dev "opkg install zlib-dev". I was unable to find jpeg. I assume there's a way to do that but I haven't ventured far enough into this to be able to try that. You can get around the jpeg requirement by disabling it in the installation arguments.

pip3 install --upgrade pillow --global-option="build_ext" --global-option="--disable-jpeg"