You need to edit the file /etc/config/wireless
Under config wifi-iface sta
set option disabled '0' to option disabled '1'

reboot your omega2+ and it will not try to scan or connect to any WiFi.