If I change /etc/config/network like this:
...
config interface 'ext_chan1'
option type 'bridge'
option proto 'dhcp'
option ifname 'apcli0'

then all works as expected.