wifi client mode is broken in new wifi-warp-core driver



  • Hello. In the new wifi-warp-core driver, the client mode is broken. At the same time, an AP mode is works without censures.

    /etc/config/wireless
    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'RU'
    option hwmode '11n'
    option htmode 'HT20'
    option channel 'auto'
    option disabled '0'
    option op_mode 'preference'
    option device_mode 'apsta'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'wlan'
    option ifname 'ra0'
    option encryption 'psk2'
    option key '1234004321'
    option disabled '1'
    option ssid 'Omega-0000'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option network 'ext_chan1'
    option disabled '0'
    option encryption 'psk2'
    option key '1234004321'
    option ssid 'megazoidr1'

    config wifi-config
    option key '1234004321'
    option ssid 'megazoidr1'
    option encryption 'psk2'

    /etc/config/network
    ...
    config interface 'ext_chan1'
    option proto 'dhcp'
    option ifname 'apcli0'

    We have a loop:
    Thu Jul 26 01:07:26 2018 kern.info ap_client: network 0: 11 megazoidr1 e4:95:6e:41:d0:a5 WPA1PSKWPA2PSK (AES) -56
    Thu Jul 26 01:07:26 2018 kern.info ap_client: network 1: 3 adron_home 00:0c:42:51:be:0b WPA1PSKWPA2PSK (TKIPAES)6
    Thu Jul 26 01:07:26 2018 kern.info ap_client: network 2: 3 ESP_3CE55F 5e:cf:7f:3c:e5:5f NONE () -72
    Thu Jul 26 01:07:26 2018 kern.info ap_client: network 3: 10 mam-tom 64:d1:54:24:99:2f WPA1PSKWPA2PSK (TKIPAES) -1
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: Network device 'apcli0' link is down
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: Interface 'ext_chan1' has link connectivity loss
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: ext_chan1 (1706): udhcpc: read error: Network is down, reopening st
    Thu Jul 26 01:07:27 2018 kern.info ap_client: Found configured network, trying to associate (essid: megazoidr1, b)
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: ext_chan1 (1706): udhcpc: sending discover
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: ext_chan1 (1706): udhcpc: sendto: Network is down
    Thu Jul 26 01:07:27 2018 daemon.notice netifd: ext_chan1 (1706): udhcpc: received SIGTERM
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014]
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014] _ _____ ___ ___ _________ ___ ____
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014] | | /| / / _ | / _ / _ \ / / __ / _ / / V1.0
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014] | |/ |/ / __ |/ , / / / // // / , / /
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014] |
    /|
    /
    / |
    /
    /|
    // _/_//|/___/
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014] Onion Enhanced MT7688 WiFi Driver
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.468014]
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.542996] DMA Scheduler Mode=0(LMAC)
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.546875] efuse_probe: efuse = 10000012
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.550994] 1. Phy Mode = 14
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.719550] 2. Phy Mode = 14
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.722525] 3. Phy Mode = 14
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.725984] WTBL Segment 1 info:
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.729353] MemBaseAddr/FID:0x28000/0
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.733240] EntrySize/Cnt:32/128
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.736737] WTBL Segment 2 info:
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.740099] MemBaseAddr/FID:0x40000/0
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.743985] EntrySize/Cnt:64/128
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.747447] WTBL Segment 3 info:
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.750821] MemBaseAddr/FID:0x42000/64
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.754794] EntrySize/Cnt:64/128
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.758253] WTBL Segment 4 info:
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.761614] MemBaseAddr/FID:0x44000/128
    Thu Jul 26 01:07:28 2018 kern.warn kernel: [ 933.765691] EntrySize/Cnt:32/128
    Thu Jul 26 01:07:33 2018 daemon.notice netifd: Network device 'apcli0' link is up
    Thu Jul 26 01:07:33 2018 daemon.notice netifd: Interface 'ext_chan1' has link connectivity
    Thu Jul 26 01:07:33 2018 daemon.notice netifd: Interface 'ext_chan1' is setting up now
    Thu Jul 26 01:07:33 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:33 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: started, v1.25.1
    Thu Jul 26 01:07:33 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: sending discover
    Thu Jul 26 01:07:34 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:35 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:36 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:36 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: sending discover
    Thu Jul 26 01:07:37 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:38 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:39 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:39 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: sending discover
    Thu Jul 26 01:07:40 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:41 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:42 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:43 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:44 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:45 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:46 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:47 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:48 2018 kern.info ap_client: Interface 'apcli0' associate - timed out
    Thu Jul 26 01:07:56 2018 kern.info ap_client: 'apcli0' assoc: no, mac: 00:00:00:00:00:00
    Thu Jul 26 01:07:56 2018 kern.info ap_client: Scanning for networks...
    Thu Jul 26 01:07:58 2018 kern.info ap_client: network 0: 11 megazoidr1 e4:95:6e:41:d0:a5 WPA1PSKWPA2PSK (AES) -54
    Thu Jul 26 01:07:58 2018 kern.info ap_client: network 1: 3 adron_home 00:0c:42:51:be:0b WPA1PSKWPA2PSK (TKIPAES)6
    Thu Jul 26 01:07:58 2018 kern.info ap_client: network 2: 3 ESP_3CE55F 5e:cf:7f:3c:e5:5f NONE () -71
    Thu Jul 26 01:07:58 2018 kern.info ap_client: network 3: 10 mam-tom 64:d1:54:24:99:2f WPA1PSKWPA2PSK (TKIPAES) -4
    Thu Jul 26 01:07:59 2018 daemon.notice netifd: Network device 'apcli0' link is down
    Thu Jul 26 01:07:59 2018 daemon.notice netifd: Interface 'ext_chan1' has link connectivity loss
    Thu Jul 26 01:07:59 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: read error: Network is down, reopening st
    Thu Jul 26 01:07:59 2018 kern.info ap_client: Found configured network, trying to associate (essid: megazoidr1, b)
    Thu Jul 26 01:07:59 2018 daemon.notice netifd: ext_chan1 (1887): udhcpc: received SIGTERM



  • If I change /etc/config/network like this:
    ...
    config interface 'ext_chan1'
    option type 'bridge'
    option proto 'dhcp'
    option ifname 'apcli0'

    then all works as expected.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.