Ruby fails on require net/http

  • I tried to write simple program to post results using PUT from omega the other day and put together short REST client with net/http. I have updated to latest firmware (Ω-ware: 0.1.4 b330)
    Ruby version is: ruby 2.2.4p230 (2015-12-16 revision 53155) [mips-linux-gnu]
    Installed ruby modules:

    opkg list ruby*
    ruby - 2.2.4-1
    ruby-datetime - 2.2.4-1
    ruby-digest - 2.2.4-1
    ruby-enc - 2.2.4-1
    ruby-filelib - 2.2.4-1
    ruby-json - 2.2.4-1
    ruby-misc - 2.2.4-1
    ruby-multithread - 2.2.4-1
    ruby-net - 2.2.4-1
    ruby-socket - 2.2.4-1
    ruby-uri - 2.2.4-1

    When I try to execute super simple ruby file test_net_http.rb with contents

    require 'net/http'
    puts "fails load"

    I get require loader error:

    /usr/lib/ruby/2.2/net/http.rb:1550:in `require': failed to load encoding (Windows-31J) (LoadError)
    	from /usr/lib/ruby/2.2/net/http.rb:1550:in `<top (required)>'
    	from ./test_net_http.rb:1:in `require'
    	from ./test_net_http.rb:1:in `<main>'

    I googled around but haven't found anything useful. I even tried to force encoding of /usr/lib/ruby/2.2/net/http.rb by adding # encoding: ASCII-8BIT and specifying default encoding with -EASCCII-8BIT

    Anyone else experiencing this ?

  • Is there a way to make this more visible to Onion team ? I think failing to require net/http is pretty serious problem for device that declares to have ruby support.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.