Omega1 wifi cannot connect to my AP



  • Hi all,
    I'm a bit lost with my Omega1 and wifi setup.

    I have it connected through USB using 'screen' and I can follow up what's going on.
    My ethernet board is working flawlessly and I can connect through my router to the Internet.
    However, the wifi cannot make it connect to my wireless router.

    The Access Point setup is always on and it works, so I think the hardware part is ok.
    No matter if I try to use Web UI or the command line with all the possible configuration and restarts, it simply doesn't work.

    When I scan the wifi networks, I get this strange error:
    root@Omega-289E:/# wifisetup
    Onion Omega Wifi Setup

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: 1
    Scanning for wifi networks...

    ERROR: Scan failed, try again

    ERROR: specified ssid not in the database
    root@Omega-289E:/# [ 450.650000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
    [ 450.910000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

    My firmware is b330, updated from ethernet. I also performed a factory reset but no way, it doesn't connect to my AP.

    Here's my /etc/config/network:

    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
    
    #config globals 'globals'
    #   option ula_prefix 'fd28:1f13:5b38::/48'
    
    #config interface 'lan'
    #   option ifname 'eth0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    
    #config interface 'wan'
    #   option ifname 'eth0'
    #   option proto 'dhcp'
    
    #config interface 'wan6'
    #   option ifname '@wan'
    #   option proto 'dhcpv6'
    
    #config switch
    #   option name 'switch0'
    #   option reset '1'
    #   option enable_vlan '1'
    
    #config switch_vlan
    #   option device 'switch0'
    #   option vlan '1'
    #   option ports '0 1 3'
    
    config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
    
    config interface 'wlan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
    
    
    #config interface 'wlan'
    #   option ifname 'wlan0-1 wlan0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    
    config interface 'wan' 
       option ifname 'eth0' 
       option proto 'dhcp'   
       option hostname 'OnionOmega'
    

    and this is my /etc/config/wireless:

    config wifi-device 'radio0'
            option type 'mac80211'
            option hwmode '11g'
            option path 'platform/ar933x_wmac'
            option htmode 'HT20'
            option disabled '0'
            option channel '9'
            option txpower '30'
            option country 'US'
    
    config wifi-iface
            option device 'radio0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'none'
            option ssid 'Omega-289E'
            option disabled '0'
    
    config wifi-iface
            option device 'radio0'
            option ssid 'bubboli_router'
            option encryption 'psk2'
            option network 'wwan'
            option mode 'sta'
            option key '***************'
            option disabled '0'
    

    Any help would be greatly appreciated!!

    Thanks,
    Claudio



  • Odd..

    The inly thing I can see different to mine is the ordering of the, "config wifi-iface" and that there is no, "option disabled '0'"

    Here is mine:
    config wifi-iface
    option device 'radio0'
    option mode 'sta'
    option network 'wwan'
    option ssid 'Broadband'
    option encryption 'psk2'
    option key '**********'



  • I guess you could try checking the SSID of your router just to make sure and check that the router is allowing new MAC addresses onto it's LAN (probably is) but you can set security in some routers to only trust certain MAC addresses.

    And have a look at the channel that the router is transmitting on - your omega is set to channel 9.



  • @TheLion said in Omega1 wifi cannot connect to my AP:

    And have a look at the channel that the router is transmitting on - your omega is set to channel 9.

    True channel higher than 9 will not work. I also had a while to find this out ... change from auto to a fix channel below 9, on the router solved my problem.

    However, did someone try to change the Chanel on Omegas side higher than 9 with success?



  • Ahh, good to hear you solved the problem. Yes, I have had success on channel 11 before but it wasn't the latest update of firmware. The channels have to match though.



  • Just to add to that... I haven't tried changing the channel on the latest firmware, so I suspect that it still works :-)


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.