Anyone was able to install SAMBA Client (CIFS)?



  • Hi,

    I'm trying to install Samba Client to connect to my CIFS server. Using this HOWTO:
    https://wiki.openwrt.org/doc/howto/cifs.client

    Keep receiving the following error:

    opkg install kmod-fs-cifs
    Installing kmod-fs-cifs (3.18.20-1) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-fs-cifs_3.18.20-1_ar71xx.ipk.
    Multiple packages (kmod-nls-base and kmod-nls-base) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-arc4 and kmod-crypto-arc4) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-hash and kmod-crypto-hash) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-hash and kmod-crypto-hash) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-hash and kmod-crypto-hash) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-hash and kmod-crypto-hash) providing same name marked HOLD or PREFER. Using latest.
    Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
    Collected errors:
     * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-cifs:
     *      kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) 
     *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *     kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *     kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *     kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66)
     *     kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *
     * opkg_install_cmd: Cannot install package kmod-fs-cifs.
    

    Any Ideas?



  • @Eric-P I was going through the various Onion Community posts to see if I had missed anything.
    I noticed that no-one had replied to this post :-(
    You may have now got passed this issue or know what the problem is but just in case you (or anyone else) doesn't know:

    • Several of the packages in the repository were build for an earlier version of the Omega kernel and so you get these errors (I have had identical errors for other packages).
      I understand that the Omega guys will be producing updated versions of the packages at some time but have a lot of work on at the moment

    Apologies if I'm telling you something you already know



  • @Kit-Bishop Thanks for replying and no need to apologies, help are always welcome in a community. I concluded the same answer that those packages will need to be recompile. In meantime, I also try install NFS but it didn't work for the same reason.



  • I get error:
    Collected errors:

    • opkg_install_cmd: Cannot install package kmod-fs-cifs.

Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.