Omega2+ fails to connect to wifi



  • Hi,

    I try to connect to my home WiFi, after several tries it just hangs like this in the end... Password is correct. I tried that IP collision solution as well, just to make sure that's not the issue.

    Restarting wifimanager for changes to take effect
    root@Omega-B625:/etc/init.d# [ 1704.400692] br-wlan: port 2(ra0) entered disabled state
    [ 1704.865964] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 1707.351020] ch2 bssid=2c:95:7f:1e:52:97
    [ 1707.355072] ch6 bssid=10:fe:ed:4e:b0:c8
    [ 1707.359047] =====================================================
    [ 1707.365264] Channel 1 : Dirty = 32, False CCA = 0, Busy Time = 633, Skip Channel = FALSE
    [ 1707.373485] Channel 2 : Dirty = 100, False CCA = 0, Busy Time = 671, Skip Channel = FALSE
    [ 1707.381792] Channel 3 : Dirty = 56, False CCA = 0, Busy Time = 1230, Skip Channel = FALSE
    [ 1707.390082] Channel 4 : Dirty = 56, False CCA = 0, Busy Time = 260, Skip Channel = FALSE
    [ 1707.398305] Channel 5 : Dirty = 56, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1707.406351] Channel 6 : Dirty = 90, False CCA = 0, Busy Time = 1308, Skip Channel = FALSE
    [ 1707.414658] Channel 7 : Dirty = 32, False CCA = 0, Busy Time = 2, Skip Channel = FALSE
    [ 1707.422701] Channel 8 : Dirty = 28, False CCA = 0, Busy Time = 2, Skip Channel = FALSE
    [ 1707.430727] Channel 9 : Dirty = 24, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1707.438770] Channel 10 : Dirty = 20, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1707.446981] Channel 11 : Dirty = 0, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1707.455032] =====================================================
    [ 1707.461228] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 11
    [ 1707.470040] Min Dirty = 0
    [ 1707.472711] ExChannel = 0 , 0
    [ 1707.475716] BW = 20
    [ 1707.507257] br-wlan: port 2(ra0) entered forwarding state
    [ 1707.512857] br-wlan: port 2(ra0) entered forwarding state
    [ 1709.511025] br-wlan: port 2(ra0) entered forwarding state
    [ 1726.804531] br-wlan: port 2(ra0) entered disabled state
    [ 1727.269452] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 1729.761026] ch2 bssid=2c:95:7f:1e:52:97
    [ 1729.765026] ch11 bssid=c0:7c:d1:af:6d:89
    [ 1729.769089] =====================================================
    [ 1729.775300] Channel 1 : Dirty = 32, False CCA = 0, Busy Time = 1295, Skip Channel = FALSE
    [ 1729.783608] Channel 2 : Dirty = 80, False CCA = 0, Busy Time = 1253, Skip Channel = FALSE
    [ 1729.791917] Channel 3 : Dirty = 32, False CCA = 0, Busy Time = 1219, Skip Channel = FALSE
    [ 1729.800217] Channel 4 : Dirty = 28, False CCA = 0, Busy Time = 11, Skip Channel = FALSE
    [ 1729.808355] Channel 5 : Dirty = 24, False CCA = 0, Busy Time = 15, Skip Channel = FALSE
    [ 1729.816486] Channel 6 : Dirty = 20, False CCA = 0, Busy Time = 663, Skip Channel = FALSE
    [ 1729.824704] Channel 7 : Dirty = 20, False CCA = 0, Busy Time = 10, Skip Channel = FALSE
    [ 1729.832836] Channel 8 : Dirty = 24, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1729.840861] Channel 9 : Dirty = 28, False CCA = 0, Busy Time = 625, Skip Channel = FALSE
    [ 1729.849096] Channel 10 : Dirty = 32, False CCA = 0, Busy Time = 1, Skip Channel = FALSE
    [ 1729.857231] Channel 11 : Dirty = 70, False CCA = 0, Busy Time = 1148, Skip Channel = FALSE
    [ 1729.865622] =====================================================
    [ 1729.871829] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 6
    [ 1729.880554] Min Dirty = 20
    [ 1729.883322] ExChannel = 0 , 0
    [ 1729.886329] BW = 20
    [ 1729.917855] br-wlan: port 2(ra0) entered forwarding state
    [ 1729.923445] br-wlan: port 2(ra0) entered forwarding state
    [ 1731.921012] br-wlan: port 2(ra0) entered forwarding state
    [ 1748.340293] br-wlan: port 2(ra0) entered disabled state
    [ 1749.402632] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 1751.891025] ch2 bssid=2c:95:7f:1e:52:97
    [ 1751.895026] ch11 bssid=c0:7c:d1:af:6d:89
    [ 1751.899088] =====================================================
    [ 1751.905297] Channel 1 : Dirty = 32, False CCA = 0, Busy Time = 1233, Skip Channel = FALSE
    [ 1751.913608] Channel 2 : Dirty = 80, False CCA = 0, Busy Time = 669, Skip Channel = FALSE
    [ 1751.921832] Channel 3 : Dirty = 32, False CCA = 0, Busy Time = 715, Skip Channel = FALSE
    [ 1751.930033] Channel 4 : Dirty = 28, False CCA = 0, Busy Time = 1875, Skip Channel = FALSE
    [ 1751.938341] Channel 5 : Dirty = 24, False CCA = 0, Busy Time = 1342, Skip Channel = FALSE
    [ 1751.946648] Channel 6 : Dirty = 20, False CCA = 0, Busy Time = 3646, Skip Channel = FALSE
    [ 1751.954955] Channel 7 : Dirty = 20, False CCA = 0, Busy Time = 94, Skip Channel = FALSE
    [ 1751.963087] Channel 8 : Dirty = 24, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1751.971212] Channel 9 : Dirty = 28, False CCA = 0, Busy Time = 0, Skip Channel = FALSE
    [ 1751.979243] Channel 10 : Dirty = 32, False CCA = 0, Busy Time = 2, Skip Channel = FALSE
    [ 1751.987382] Channel 11 : Dirty = 70, False CCA = 0, Busy Time = 584, Skip Channel = FALSE
    [ 1751.995684] =====================================================
    [ 1752.001880] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 6
    [ 1752.010647] Min Dirty = 20
    [ 1752.013411] ExChannel = 0 , 0
    [ 1752.016417] BW = 20
    [ 1752.047976] br-wlan: port 2(ra0) entered forwarding state
    [ 1752.053581] br-wlan: port 2(ra0) entered forwarding state
    [ 1754.051012] br-wlan: port 2(ra0) entered forwarding state

    GUI interface via AP also just spins that circle and says it cannot connect to wifi, try again...

    so.. yeah, any suggestions?



  • You are not alone. I have the same problem! Unable to figure out wifi connect
    I am on Windows 10. I have the Omega2+ on a mini-dock. I have the same problem with each of my two Omega2+. Have tried serial command line as well as the browser method.
    EDIT: So far I was able to get wifi going on one of the Omega2+ following this guide (even though I don't see how I could have had collision):
    https://docs.onion.io/omega2-docs/fix-ip-addr-collisions.html#fix-ip-addr-collisions



  • @Brian-Robbins Hey Brian, and anyone else having this issue.

    I made it work and believe it was this that made it happen:

    edit wireless configuration:
    vi /etc/config/wireless

    change option ApCliEncrypType 'AES'
    to option ApCliEncrypType 'psk2'

    restart wireless
    /etc/init.d/wireless restart

    Then I did automatic wifisetup, to me it looked that it hangs again, but after I tried to oupgrade it worked



  • Hello all.

    I face exactly the same problem. I tried your suggestions but no luck.
    I can only connect to Onion's AP but Onion cannot connect to my router, nor my mobile phone's hotspot (even with no password). If only anyone might suggest another solution.



  • Hi
    I also have problem to establish wifi connection to my office Mikrotik router. ApClie is not going up.
    But same time, on this same settings Onion2 links to Airlive AP and get IP address from Mikrotik router.
    I tried a lot of settings on Mikrotik, but nothig. ESP and notebooks connect to this router without problem.
    Airlive has WPA2 Mixed encryption.
    I tried change ApCliEncrypType to psk2 but it not successful still.
    Any ideas where is a problem? Anybody has description of wireless config parameters and options?



  • Hello everyone,
    I also have that problem.I had already updated to the newest framwork but still couldn't connect to my router.
    Anyone could help ?Thanks.


  • administrators

    @Kostas-David , @Marcin-Nosek , @zc-Zhang

    If you are using a non-US router that uses channels 12-14, please follow the instructions by Rick Hogervorst and Larry Pinney here: http://community.onion.io/topic/1138/connecting-the-omega2-to-wifi-channels-12-to-14-for-non-us-users/4

    If this does not work, please post screen captures or terminal output when running wifisetup and scanning for available networks. If pasting terminal output, enclose it in a Code Block as shown in this guide: https://confluence.atlassian.com/bitbucketserver/markdown-syntax-guide-776639995.html#Markdownsyntaxguide-Codeblocks

    Please also post the output of running uci show wireless (remove your network SSIDs and passwords first!) and uci show network. Enclose these outputs in Code Blocks as shown earlier.

    Thanks,
    Gabe



  • My Omega2+ still cannot connect my to Mikrotik Router
    firmware version: 0.1.7 b140

    wifisetup scan

    root@Omega-4877:~# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) Guest_1195
    2) YEWEIAP2
    3) YWSMART
    4) YWGUEST
    

    wifisetup list

    root@Omega-4877:~# wifisetup list
    {
    
            "results": [
     {
    
            "ssid": "YEWEIAP2",
            "encryption": "WPA2PSK",
            "password": "PASSWORD"
    }
    ]
    }
    

    uci show wireless

    root@Omega-4877:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='CN'
    wireless.ra0.countryregion='1'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ApCliSsid='YEWEIAP2'
    wireless.@wifi-iface[0].ApCliPassWord='PASSWORD'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-iface[0].ssid='Omega-4877'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='YEWEIAP2'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='PASSWORD''
    root@Omega-4877:~#
    

    uci show network

    root@Omega-4877:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0.2'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    root@Omega-4877:~#
    

    /etc/config/wireless

    root@Omega-4877:~# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'CN'
            option countryregion '1'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliEncrypType 'AES'
            option ApCliSsid 'YEWEIAP2'
            option ApCliPassWord 'PASSWORD'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEnable '0'
            option ssid 'Omega-4877'
    
    config wifi-config
            option ssid 'YEWEIAP2'
            option encryption 'WPA2PSK'
            option key 'PASSWORD'
    
    root@Omega-4877:~#
    


  • Hello!
    I have same issue with connecting Omega2+ to my Mikrotik router. I'm from Russia, so I'm not using channels 12, 13 and so on.
    FW Version 0.1.7 b140
    Here is the output from Omega2:

    wifisetup scan

    root@Omega-B8B3:/# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) Home
    2) Why-Fi
    3) TP_New
    4) MGTS_GPON_9615
    5) MY_dlink_wi-fi
    6) 2kom-234
    7) Tenda_067638
    

    wifisetup list

    oot@Omega-B8B3:/# wifisetup list
    {
    
            "results": [
     {
    
            "ssid": "Why-Fi",
            "encryption": "WPA2PSK",
            "password": "PASSWORD"
    }
    ]
    }
    

    uci show wireless

    root@Omega-B8B3:/# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='RU'
    wireless.ra0.countryregion='1'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-B8B3'
    wireless.@wifi-iface[0].ApCliSsid='Why-Fi'
    wireless.@wifi-iface[0].ApCliPassWord='PASSWORD'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='Why-Fi'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='PASSWORD'
    

    uci show network

    root@Omega-B8B3:/# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    

    cat /etc/config/wireless

    root@Omega-B8B3:/# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'RU'
            option countryregion '1'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ssid 'Omega-B8B3'
            option ApCliSsid 'Why-Fi'
            option ApCliPassWord 'PASSWORD'
            option ApCliEnable '0'
    
    config wifi-config
            option ssid 'Why-Fi'
            option encryption 'WPA2PSK'
            option key 'PASSWORD'
    


  • Hi, I too have this problem. Brand new Omega2+ out of the box; unable to connect to Microtik CRS109-8G-1S-2HnD router wifi 2GHz b/g/n 20/40MHz HT Above, channel 3+7 (mixed-mode).

    I used my ethernet attachment and a network bridge to update it- the behavior is still present in 0.1.7 b139

    root@Omega-76EB:~# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    --snip--
    4) nnnn
    --snip--
    Selection: 4
    Network: nnnn
    Authentication type: WPA2PSK
    Enter password: REDACTED
    
    > Restarting wifimanager for changes to take effect
    root@Omega-76EB:~#
    
    
    root@Omega-76EB:~# wifisetup list
    { "results": [ { "ssid": "nnnn", "encryption": "WPA2PSK", "password": "REDACTED" } ] }
    
    
    root@Omega-76EB:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].ssid='Omega-76EB'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ApCliSsid='nnnn'
    wireless.@wifi-iface[0].ApCliPassWord='REDACTED'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='whargarbl'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='REDACTED'
    
    
    root@Omega-76EB:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0.2'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    
    
    oot@Omega-76EB:~# cat /etc/config/wireless
    
    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option ssid 'Omega-76EB'
    	option key '12345678'
    	option ApCliAuthMode 'WPA2PSK'
    	option ApCliEncrypType 'AES'
    	option ApCliSsid 'nnnn'
    	option ApCliPassWord 'REDACTED'
    	option ApCliEnable '0'
    
    config wifi-config
    	option ssid 'nnnn'
    	option encryption 'WPA2PSK'
    	option key 'REDACTED'
    
    


  • Bumping. Same issue with

    Device Firmware Version: 0.1.7 b139



  • @Zogg-Baubas , try the newer image file:
    http://repo.onion.io/omega2/images/
    Check out in manual how to update manually in terminal.



  • Same issue for me as well.

    Omega2+
    Exp dock

    Device Firmware Version: 0.1.7 b140

    root@Omega-C5A3:~# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) foo
    2) bar
    3) baz
    
    Selection: 3
    Network: baz
    Authentication type: WPA2PSK
    Enter password: redacted
    
    > Restarting wifimanager for changes to take effect
    root@Omega-C5A3:~# 
    
    root@Omega-C5A3:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    
    root@Omega-C5A3:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-C5A3'
    wireless.@wifi-iface[0].ApCliSsid='baz'
    wireless.@wifi-iface[0].ApCliPassWord='redacted'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='baz'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='redacted'
    


  • @Luciano-S. Manual sysupgrade does not work:

    root@Omega-6D3B:/# sysupgrade -v --force /omega2p-v0.1.7-b140.bin 
    Saving config files...
    etc/config/dhcp
    etc/config/dropbear
    etc/config/firewall
    etc/config/mountd
    etc/config/network
    etc/config/onion
    etc/config/rpcd
    etc/config/system
    etc/config/ubootenv
    etc/config/uhttpd
    etc/config/wireless
    etc/dropbear/dropbear_rsa_host_key
    etc/fw_env.config
    etc/group
    etc/hosts
    etc/inittab
    etc/opkg/keys/1afebb2008639538
    etc/opkg/keys/2ea9a9bc60cbc099
    etc/opkg/keys/60366ca0eb621637
    etc/opkg/keys/6405feca1ff7d881
    etc/opkg/keys/72a57f2191b211e0
    etc/opkg/keys/7afde20b15076f21
    etc/opkg/keys/9ef4694208102c43
    etc/opkg/keys/b5043e70f9a75cde
    etc/opkg/keys/dace9d4df16896bf
    etc/opkg/keys/dd6de0d06bbd3d85
    etc/passwd
    etc/profile
    etc/rc.local
    etc/shadow
    etc/shells
    etc/sysctl.conf
    etc/sysctl.d/local.conf
    root/.config/htop/htoprc
    killall: watchdog: no process killed
    Sending TERM to remaining processes ... onion-helper udhcpc dnsmasq mountd ntpd ubusd askfirst logd rpcd netifd odhcpd uhttpd device-client avahi-daemon 
    Sending KILL to remaining processes ... askfirst 
    Switching to ramdisk...
    Performing system upgrade...
    Could not get image magic
    Image check failed.
    Upgrade completed
    Rebooting system...
    umount: can't unmount /dev/pts: Resource busy
    umount: can't unmount /dev: Resource busy
    

    And the Omega boots into the old image:

    @arte ➜  Zemeplytis rvm:(system)  ssh root@Omega-6D3B.local
    root@omega-6d3b.local's password: 
    
    
    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.1.7 b139
     -----------------------------------------------------
    

  • administrators

    @Zogg-Baubas yikes! why the --force flag??



  • @Lazar-Demin said in Omega2+ fails to connect to wifi:

    @Zogg-Baubas yikes! why the --force flag??

    Hey, Administrators, when will you resolve the wifi connectivity issues that we're talking about on this thread?



  • @Lazar-Demin said in Omega2+ fails to connect to wifi:

    @Zogg-Baubas yikes! why the --force flag??

    Because without it I'v got the same result. Figured, as this particular Omega was useless in this state, it couldn't get worse even if bricked. In the end '--force' didnt achieve anything that unforced version didnt.



  • @Zogg-Baubas It seems that we have to find the solution by ourselves, the Admins do not help at all.
    Have you tried the new version of firmware?



  • @Zogg-Baubas I already instructed you in http://community.onion.io/topic/1178/wifi-connection-problem-with-omega2/21 how to flash the image correctly.



  • @Kostas-David - I tried omega2p-v0.1.8-b145.bin and still no luck getting the wi-fi working yet. I'm using a Mikrotik router and I've never had any issues with other devices.



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.