Omega2+ fails to connect to wifi



  • @Alex-Thow I tried your config.. In my case, it doesn't work no matter what router i use ( i have 10 various routers, and i had the patience to test them all.. two times in a row ) .

    So can you please elaborate a bit on your setup ?



  • I have found the issue with the web setup and the real reason why no one seems to be able to connect the device to any wireless network. What i did, in steps, so anyone can reproduce .
    1 - Reset the device to factory defaults ( VERY IMPORTANT if you tested and failed to setup wireless before ).

    2 - immediately after successful boot, connect to the WIFI AP that Omega2+ sets up, but DO NOT connect to the web setup.

    3 - log-in to SSH or serial console, and edit /etc/config/wireless ( vi /etc/config/wireless ).

    4 - Remove the line 'option country 'US' . If you will read the OPENWRT documentation, you will see that this setting is NOT mandatory, but it has an adverse effect for anyone that has the router set to any NON-US country. Apparently, the devs from Onion live under the impression that there is only US in this world.....
    Save the file ..

    5 - reboot the device, connect to the wireless AP set by the device, and run the web setup. For me it was successful , but i will gladly help anyone, as the admins from Onion seem to be clueless ...



  • @Scott-Horsley I can confirm this working on my mikrotik router, after 48+ hours of frustration and head-banging against the monitor . Great job !!



  • @Michal-Rok Okay, you are a genius!

    That is working, however, still unsure why setting it after connection changes anything.

    Even more so, it appears that without setting mode sta it doesn't even appear to attempt to connect with the router.

    Would really love to know what the mode flags do to the ralink device!

    Using rc.local is of course the key to getting this working after the fact but I feel dirty leaving it as a proper solution.

    Thanks to anybody and everybody that put effort in here, I think we have a (albeit, not perfect) working solution.

    Can anybody else confirm this works on other MT units out in the wild?

    I'm doing this on a 2011UAS-2HnD but I believe it should work on any unit of them.



  • @Mikaël-PIRIO Thanks for all your efforts. After a day of frustration, I found your post. Following your advice, I was finally able to connect to my home wifi.



  • @Alex-Thow Yay - finally - worked for me. thanks.



  • @Michal-Rok
    I have spent hours on the "Omega2+ fails to connect to Wifi" issue (like many people ...)

    Starting from a fresh Omega2+ (with factory resetting if needed and without using the set up wizard), I have followed your http://community.onion.io/post/13769 post and added the following lines at the end of the /etc/config/wireless file :

    config wifi-config
    option ssid 'xxxxxxxx'
    option encryption 'WPAPSK'
    option key 'xxxxxxx'

    I have also replaced WPA1PSK by WPAPSK (twice in the config file) and removed the 'option country 'US' line (http://community.onion.io/post/13801).

    After rebooting the Omega2+, I have checked that the date and internet access are now correct :

    root@Omega-2771:~# date;ia
    Sun Sep 3 14:35:42 GMT 2017
    apcli0 Link encap:Ethernet HWaddr 42:A3:6B:01:27:71
    inet addr:192.168.0.9 Bcast:192.168.0.255 Mask:255.255.255.0

    Thank you @Michal-Rok and @Ganescu-Theodor for postings your recipes.

    I also thank the people of http://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/ for their posts which also helped me in elaborating my own recipe.

    I hope that that my post will be helpful for people having this kind of issue.

    PS : I agree with @Ganescu-Theodor when he writes "This is bad engineering to say the least, and disrespect for the people who bought this device"(http://community.onion.io/post/13794)

    And now I am going to manually install the console.



  • I had to upgrade from 0.1.5 (b130) to 0.1.10 (b160) since uci get system.@led[0].sysfs gave onion:amber:system (wrong answer) instead of the expected answer : omega2p:amber:system.

    What I wrote in my previous post (http://community.onion.io/post/14346) remains valid since the config files (/etc/config/wireless and /etc/rc.local) have been kept unchanged during sys upgrade.



  • @Gerald-Schalek Hi, I've got the same issue with WPA2PSK/AES WiFi router with the password Zyx12abcd%
    It doesn't work on both Omega2 and Omega2+ with the latest firmware. Did you use some workaround to setup the password in /etc/config/wireless (i.e. some quotes or smth like :-) )?



  • By removing country and changing mode to sta in the wireless config and following @michal-Rok i could connect to my MT rb2011, however could not connect to the internet! In frustration i turned my laptop into a hotspot and connected/upgraded etc with few issues.
    I have upgraded to 0.1.10 B160 however that has not helped connection to MT. I too have wasted hours on this and will 'pause' in the hopes the Onion team will actually look into this and come up with a permanent solution.
    Concur with the sentiment about poor engineering/support when a product like this will attract users with MT routers. I'm not an expert on openwrt however would have thought there's a simple solution!



  • 6 months after I posted problem in this thread and its still not resolved. I have my Onion Omega 2+ with latest firmware 0.1.10b160 and LED is still blinking, web console shows directory listing of ".." and "/lib", wifimanager still takze 100% of CPU, Omega is overheating as hell and I can't connect it to any Wi-Fi (secured or android hotspot unsecured). I tried every dirty trick in this thread (sta mode, deleting country, factory reset).

    If I try to configure it from SSH after first reset all data are back (wifi settings etc), poweroff and reboot commands are doing nothing ...

    Any ideas? What is the money-back policy for IndieGOGO campaign? Because right now it is useless piece of hardware, every stupid ESP clone around is far more user friendly than this thing :(

    @administrators Hm?



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.