Omega2+ won't connect to wifi (in France)



  • Hi All,

    I just receive my omega 2+ this morning and I'm trying to configure the wifi connection... Without success.

    I tried via web interface. Connection failed.

    I tried via serial and no success too...

    here is my firmware version : 0.1.7 b140

    And my wifi configuration :

    /# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.disabled='0'
    wireless.ra0.country='FR'
    wireless.ra0.countryregion='1'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='***'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ApCliSsid='***'
    wireless.@wifi-iface[0].ApCliPassWord='***'
    wireless.@wifi-iface[0].ApCliEnable='1'
    wireless.@wifi-iface[0].ssid='Omega-****'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='***'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='***'
    

    I tried to modify countryregion to other value than 0 (I'm not in US but in France).

    I can't figure how to solve this problem...

    I can give you more informations if needed !

    Thanks a lot,



  • @Joris-Mulliez , Us and France my have different regulations about the use of the wifi channel range. I had the problem here in Brazil 2.

    Try to configure your routers wifi channel manually or look that you not get ID higher than ID9. After this the omega should appear in your wifi.



  • @Luciano-S. Thanks for your reply !

    Whate do you mean by

    look that you not get ID higher than ID9

    ?

    If possible i want to try to not modify my network installation, and just adjust omega confguration :)

    I'm sorry I'm not good in network notions...

    thanks again !



  • @Joris-Mulliez Change wireless.ra0.channel='auto' to specific channel and that should fix it, like e.g. if your WiFi was on channel 11, change that line to use channel 11. It worked for me as I have my WiFi on channel 13. 'auto' for some reason didn't work.



  • Hi @WereCatf, thanks for your help !

    I made a factory reset (explain here : https://community.onion.io/topic/1154/omega-2-usb-firmware-install-after-brick/1 )
    Just to be sure :)

    I run again wifisetup, and modify manually /etc/config/wireless for modify channel.
    I tried 11, 13, no effect...

    Here is a "network restart" :

    /# /etc/init.d/network restart
    [  769.665649] br-wlan: port 2(ra0) entered disabled state
    [  769.671115] br-wlan: port 1(eth0.1) entered disabled state
    [  769.699884] device eth0.1 left promiscuous mode
    [  769.704499] device eth0 left promiscuous mode
    [  769.709030] br-wlan: port 1(eth0.1) entered disabled state
    [  769.722974] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
    [  769.741515] device ra0 left promiscuous mode
    [  769.745970] br-wlan: port 2(ra0) entered disabled state
    [  769.945781] !!! APCLI LINK DOWN - IF(apcli0)!!!
    root@Omega-***:/# [  773.843244] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  774.551106] device eth0.1 entered promiscuous mode
    [  774.555986] device eth0 entered promiscuous mode
    [  774.567756] br-wlan: port 1(eth0.1) entered forwarding state
    [  774.573632] br-wlan: port 1(eth0.1) entered forwarding state
    [  776.569279] br-wlan: port 1(eth0.1) entered forwarding state
    [  778.102151] device ra0 entered promiscuous mode
    [  778.106842] br-wlan: port 2(ra0) entered forwarding state
    [  778.112415] br-wlan: port 2(ra0) entered forwarding state
    [  780.109210] br-wlan: port 2(ra0) entered forwarding state
    [  780.173337] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    
    

    And here my fresh /etc/config/wireless :

    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel '13'
            option txpower '100'
            option ht '20'
            option country 'FR'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliEnable '1'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ssid 'Omega-***'
            option ApCliSsid 'mynetwork'
            option ApCliPassWord 'mypass'
    
    config wifi-config
            option ssid 'mynetwork'
            option encryption 'WPA2PSK'
            option key 'mypass'
    
    

    I looked at my router configuration and see that the "channel" option was at "auto" (possibles values : 1-13)
    I don't know how to google this problem :/
    For example is "FR" a correct and recognized value for country entry ?

    Thanks a lot,



  • @Joris-Mulliez Yes, "FR" is correct. And only you can know the right channel, I have no way of seeing your router or guessing what channel it's using.



  • @WereCatf My Router is configured at "auto".

    I wanted to not change my router configuration, I think it is the device (the omega2) who have to adapt its configuration...
    But if Omega 2 can't work with a router in "auto" channel configuration I can modify my router configuration :)

    I just try now, and it's not a success... :(

    Here is my last config :

    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel '10'
            option txpower '100'
            option ht '20'
            option country 'FR'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliEnable '1'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ApCliSsid 'mynetwork'
            option ApCliPassWord 'mypass'
            option ssid 'Omega-****'
    
    config wifi-config
            option ssid 'mynetwork'
            option encryption 'WPA2PSK'
            option key 'mypass'
    

    I'm really confusing... I can get all the informations you want, but I don't know how to search the problem by my self...

    Thanks a lot for your help,



  • I just realize one thing, My router has a particular address : 192.168.1.254
    So I certainly have to force the broadcast address in the wifi configuration.
    But how can I force that in /etc/config/wireless ?

    is there an exhaustive documentation for this file ?

    Thanks !



  • Alleluia !

    It seems to work partially for now !

    I modify the file /etc/config/network
    to add in wlan section :

    option gateway '192.168.1.254'
    

    But it seems that my configuration is erased after network restart...
    I can't find it anymore in my network file... oO

    What is the Hell...



  • J'ai exactement le même soucis que toi (et ai aussi posté un sujet sur le forum)! Depuis que tu as fais ça ton Omega se connecte à ton wifi ? Ou pas encore? :)



  • @Tom-Escolano yes my wifi connection work for now! I'll give you the commands if You want (not at home)



  • @Joris-Mulliez I finally reset my Omega just to be sure. But now I'm stuck on the setup Wizard when it comes to connecting to a wifi network... What comcommand did you used to make it work? :)



  • i think i may have the same problem as you..
    no problem to connect to AP, but then it's for connecting to my wifi that i get issue.
    I'll try what you've done as I'm from France too.
    If you have more details, of course i'm interested too ;)



  • Hi,

    I tried several tips before it works.

    First you can check if change the omega IP can help : https://docs.onion.io/omega2-docs/fix-ip-addr-collisions.html#fix-ip-addr-collisions
    If not, you can try to fix the wifi channel : example in this thread.

    but for me the problem was the gateway. My provider is "ovh telecom" and the router of ovh has a particular IP : 192.168.1.254
    I realize that when I try "ifconfig" on my omega and see the gateway to 192.168.1.255.

    I don't know how the omega try to guess at which address will be the router...

    So the only change for me was :

    uci set network.wlan.gateway=192.168.1.254
    uci commit network
    /etc/init.d/network restart
    

    The other default configuration are fine in my case.

    For your problem try to analyse ifconfig result, and compare with "all" your router configurations (not only key, pass, encryption method).

    I hope that it will help,



  • Damn....

    I upgraded to 0.1.8 b145.... and I can't make it work anymore :(
    I don't change my router settings... So I guess the new image has some changes in the wifi/network... ?

    Here is my "network" :

    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wlan.gateway='192.168.1.254'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    

    And here is my "wireless" :

    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.disabled='0'
    wireless.ra0.country='FR'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliEnable='1'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-****'
    wireless.@wifi-iface[0].ApCliSsid='mynetwork'
    wireless.@wifi-iface[0].ApCliPassWord='mykey'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='mynetwork'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='mykey'
    

    And here is the result of "ifconfig" :

    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:B3:9D  
              inet6 addr: fe80::40a3:6bff:fe00:b39d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:779 errors:0 dropped:0 overruns:0 frame:0
              TX packets:314 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:110848 (108.2 KiB)  TX bytes:61242 (59.8 KiB)
    
    br-wlan   Link encap:Ethernet  HWaddr 40:A3:6B:C0:B3:9F  
              inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
              inet6 addr: fe80::42a3:6bff:fec0:b39f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:15703 (15.3 KiB)
    
    eth0      Link encap:Ethernet  HWaddr 40:A3:6B:C0:B3:9F  
              inet6 addr: fe80::42a3:6bff:fec0:b39f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1247 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:361081 (352.6 KiB)
              Interrupt:5 
    
    eth0.1    Link encap:Ethernet  HWaddr 40:A3:6B:C0:B3:9F  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:11381 (11.1 KiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:4130 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4130 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:251582 (245.6 KiB)  TX bytes:251582 (245.6 KiB)
    
    ra0       Link encap:Ethernet  HWaddr 40:A3:6B:C0:B3:9D  
              inet6 addr: fe80::42a3:6bff:fec0:b39d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:6 
    

    I think it's a bit strange that I have an IPV6 rather than an IPV4 ?
    And I can't find anywhere my special router gateway (192.168.1.254) even if the network config show it...

    Any help would be appreciate :)

    Thanks,



  • i have same issue on mikrotik router and airties router. it seems just connecting on my s7edge's hotspot. i've tried everything in this thread and links but nothing changed.
    have anyone has real fix?
    i also tried to change country to us on my router but seems nothing change too.

    edit1: i also tried fw 0.1.5 to 0.1.8 and result same



  • @mehmet-bozkurt Have you tried this?



  • Hmmm.... I can't understand... My connection is working again...
    But I havn't change anything (I wasn't in front of my computer).
    And the connection worked all the time on other devices (phone, computer, etc..)

    This WiFi connection is very unpredictable and it's very difficult to debug the problems...



  • And here is my new "ifconfig'" part :

    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:B3:9D  
              inet addr:192.168.1.123  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::40a3:6bff:fe00:b39d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:24537 errors:0 dropped:0 overruns:0 frame:0
              TX packets:20376 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:3536119 (3.3 MiB)  TX bytes:1490265 (1.4 MiB)
    

    I can't see my router IP, but it work... strange...


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.