Apache fails, wiki needs update



  • Hello. Installed apache and php.

    Apache installed but when I try to access a webpage on the Omega,

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at you@example.com to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request.

    /var/log/error_log shows


    [Tue Jan 10 20:55:10.361474 2017] [http:error] [pid 137444435696:tid 1992351000] [client 10.0.1.4:63046] AH02429: Response header name 'Content-Length' contains invalid characters, aborting request


    What does the error mean? Google is no help. This is a fresh install

    Why does it refer to 10.0.1.4 when my Omega is 10.0.1.6?

    Also Onion's LAMP wiki mentions installing php5 but only php7 is now available. I suggest revising the wiki to refer only to php, and create symbolic links for opkg "php" packages to whatever latest php is



  • @David-Price, just read the message ... misconfiguration and 400 error because of a missing 404 document.

    Please link to the Tutorial and show us your configuration of the Web server.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.