Omega2+ amber light keeps blinking



  • I followed the setup step by step, and at the end it said that the firmware and console were installed correctly. Then it said that the device would reboot, but my device was the special case where it just turned off afterwards. So I toggled the power switch and the amber light turns on. Then after about 10 seconds the light starts to blink, and does not turn solid. I have been letting it go for about 10 minutes now and the light is still flashing. The device is warm to the touch but not hot.

    I have the Omega 2+ and I am using the expansion dock to power it. I have tried using a micro-usb that is powered from the wall and I have tried using a cable from my computer.

    I am still able to connect to the access point while it is in this state and I am able to go through the setup options and it shows that all of the things have been setup correctly.

    I am not sure what to do. Any help would be appreciated, thanks!



  • Do a serial connection ... there you get a boot log ... and it would be good to see that ...



  • @Luciano-S. So I did a serial connection. When I start the device this is what I get. At the end it opens the command line.

       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    flash manufacture id: c2, device id 20 19
    find flash: MX25L25635E
    *** Warning - bad CRC, using default environment
    
    ============================================
    Onion Omega2 UBoot Version: 4.3.0.3
    --------------------------------------------
    ASIC 7628_MP (Port5<->None)
    DRAM component: 1024 Mbits DDR, width 16
    DRAM bus: 16 bit
    Total memory: 128 MBytes
    Flash component: SPI Flash
    Date:Oct 18 2016  Time:17:29:05
    ============================================
    icache: sets:512, ways:4, linesz:32 ,total:65536
    dcache: sets:256, ways:4, linesz:32 ,total:32768
    CPU freq = 575 MHZ
    Estimated memory size = 128 Mbytes
    Resetting MT7628 PHY.
    Initializing MT7688 GPIO system.
    
    
    **************************************
    * Hold Reset button for more options *
    **************************************
    
    
    
    Boot Linux from Flash NO RESET PRESSED.
    ## Booting image at bc050000 ...
       Image Name:   MIPS LEDE Linux-4.4.39
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    1345031 Bytes =  1.3 MB
       Load Address: 80000000
       Entry Point:  80000000
       Verifying Checksum ... OK
       Uncompressing Kernel Image ... OK
    No initrd
    ## Transferring control to Linux (at address 80000000) ...
    ## Giving linux memsize in MB, 128
    
    Starting kernel ...
    
    [    0.000000] Linux version 4.4.39 (root@86c2fbc8be2e) (gcc version 5.4.0 (LEDE GCC 5.4.0 r2701-c5ca304) ) #0 Thu Dec 29 17:07:01 2016
    [    0.000000] Board has DDR2
    [    0.000000] Analog PMU set to hw control
    [    0.000000] Digital PMU set to hw control
    [    0.000000] SoC Type: MediaTek MT7688 ver:1 eco:2
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
    [    0.000000] MIPS: machine is Onion Omega2+
    [    0.000000] Determined physical RAM map:
    [    0.000000]  memory: 08000000 @ 00000000 (usable)
    [    0.000000] Initrd not found or empty - disabling initrd
    [    0.000000] Zone ranges:
    [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Movable zone start for each node
    [    0.000000] Early memory node ranges
    [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
    [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
    [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
    [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
    [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    [    0.000000] Writing ErrCtl register=0006e30f
    [    0.000000] Readback ErrCtl register=0006e30f
    [    0.000000] Memory: 125488K/131072K available (3102K kernel code, 141K rwdata, 752K rodata, 156K init, 196K bss, 5584K reserved, 0K cma-reserved)
    [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    [    0.000000] NR_IRQS:256
    [    0.000000] intc: using register map from devicetree
    [    0.000000] CPU Clock: 580MHz
    [    0.000000] clocksource_probe: no matching clocksources found
    [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
    [    0.000010] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
    [    0.007521] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
    [    0.070039] pid_max: default: 32768 minimum: 301
    [    0.074640] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.080980] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.094382] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
    [    0.104039] pinctrl core: initialized pinctrl subsystem
    [    0.109770] NET: Registered protocol family 16
    [    0.133986] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.139547] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.144963] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.151479] i2c-mt7621 10000900.i2c: clock 100KHz, re-start not support
    [    0.159213] clocksource: Switched to clocksource MIPS
    [    0.165651] NET: Registered protocol family 2
    [    0.170764] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.177458] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.183641] TCP: Hash tables configured (established 1024 bind 1024)
    [    0.189841] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [    0.195442] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [    0.201816] NET: Registered protocol family 1
    [    0.211986] futex hash table entries: 256 (order: -1, 3072 bytes)
    [    0.217918] Crashlog allocated RAM at address 0x3f00000
    [    0.238066] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [    0.243724] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [    0.255939] io scheduler noop registered
    [    0.259744] io scheduler deadline registered (default)
    [    0.265551] rt2880-pinmux pinctrl: pin io18 already requested by pinctrl; cannot claim for 10005000.pwm
    [    0.274631] rt2880-pinmux pinctrl: pin-18 (10005000.pwm) status -22
    [    0.280642] rt2880-pinmux pinctrl: could not request pin 18 (io18) from group pwm0  on device rt2880-pinmux
    [    0.290044] mtk-pwm 10005000.pwm: Error applying setting, reverse things back
    [    0.297414] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
    [    0.304986] console [ttyS0] disabled
    [    0.308419] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
    [    0.317197] console [ttyS0] enabled
    [    0.317197] console [ttyS0] enabled
    [    0.324191] bootconsole [early0] disabled
    [    0.324191] bootconsole [early0] disabled
    [    0.332851] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
    [    0.342380] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
    [    0.352915] spi-mt7621 10000b00.spi: sys_freq: 193333333
    [    0.362977] m25p80 spi32766.0: using chunked io (size=31)
    [    0.368475] m25p80 spi32766.0: mx25l25635e (32768 Kbytes)
    [    0.374043] 4 ofpart partitions found on MTD device spi32766.0
    [    0.379971] Creating 4 MTD partitions on "spi32766.0":
    [    0.385187] 0x000000000000-0x000000030000 : "u-boot"
    [    0.392016] 0x000000030000-0x000000040000 : "u-boot-env"
    [    0.399281] 0x000000040000-0x000000050000 : "factory"
    [    0.406240] 0x000000050000-0x000002000000 : "firmware"
    [    0.453928] 2 uimage-fw partitions found on MTD device firmware
    [    0.459978] 0x000000050000-0x000000198647 : "kernel"
    [    0.466687] 0x000000198647-0x000002000000 : "rootfs"
    [    0.473608] mtd: device 5 (rootfs) set to be root filesystem
    [    0.479484] 1 squashfs-split partitions found on MTD device rootfs
    [    0.485759] 0x0000006e0000-0x000002000000 : "rootfs_data"
    [    0.502811] rt3050-esw 10110000.esw: link changed 0x00
    [    0.510543] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
    [    0.519127] i2c /dev entries driver
    [    0.523329] mt7621_wdt 10000120.watchdog: Initialized
    [    0.528668] MTK MSDC device init.
    [    0.569353] mtk-sd: MediaTek MT6575 MSDC Driver
    [    0.575385] NET: Registered protocol family 10
    [    0.583993] NET: Registered protocol family 17
    [    0.588597] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
    [    0.601456] 8021q: 802.1Q VLAN Support v1.8
    [    0.607986] mtk-linkit bootstrap: Version  :
    [    0.612492] mtk-linkit bootstrap: Revision :
    [    0.621515] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
    [    0.629602] Freeing unused kernel memory: 156K (803e9000 - 80410000)
    [    1.652529] init: Console is alive
    [    1.656199] init: - watchdog -
    [    4.084613] usbcore: registered new interface driver usbfs
    [    4.090365] usbcore: registered new interface driver hub
    [    4.095868] usbcore: registered new device driver usb
    [    4.107064] exFAT: Version 1.2.9
    [    4.148068] SCSI subsystem initialized
    [    4.158442] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    4.166751] ehci-platform: EHCI generic platform driver
    [    4.182463] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
    [    4.189281] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
    [    4.194610] ehci-platform 101c0000.ehci: EHCI Host Controller
    [    4.200489] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
    [    4.208633] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
    [    4.229256] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
    [    4.236758] hub 1-0:1.0: USB hub found
    [    4.241000] hub 1-0:1.0: 1 port detected
    [    4.249730] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    [    4.257572] ohci-platform: OHCI generic platform driver
    [    4.263227] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
    [    4.270202] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
    [    4.278311] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
    [    4.344401] hub 2-0:1.0: USB hub found
    [    4.348647] hub 2-0:1.0: 1 port detected
    [    4.357654] sdhci: Secure Digital Host Controller Interface driver
    [    4.364008] sdhci: Copyright(c) Pierre Ossman
    [    4.370103] sdhci-pltfm: SDHCI platform and OF driver helper
    [    4.380300] usbcore: registered new interface driver usb-storage
    [    4.396858] init: - preinit -
    [    5.170039] rt3050-esw 10110000.esw: link changed 0x00
    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug[    5.373323] random: procd: uninitialized urandom read (4 bytes read, 9 bits of entropy available)
     level
    [    8.709605] jffs2: notice: (393) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    [    8.727182] mount_root: overlay filesystem has not been fully initialized yet
    [    8.812892] mount_root: switching to jffs2 overlay
    - config restore -
    [    9.439313] urandom-seed: Seed file not found (/etc/urandom.seed)
    [    9.548925] procd: - early -
    [    9.552794] procd: - watchdog -
    [   10.276319] procd: - ubus -
    [   10.329780] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.339453] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.348622] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.358275] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.367487] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.376874] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.386240] random: ubusd: uninitialized urandom read (4 bytes read, 17 bits of entropy available)
    [   10.395877] procd: - init -
    Please press Enter to activate this console.
    [   10.834903] ntfs: driver 2.1.32 [Flags: R/O MODULE].
    [   10.901031] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [   10.924213] Ralink/MTK WiFi EEPROM API Build for MT7620.
    [   10.966908] WRTnode AP Driver version: 4.1.0.0
    [   11.049693] Linux video capture interface: v2.00
    [   11.084088] hidraw: raw HID events driver (C) Jiri Kosina
    [   11.128463] Bluetooth: Core ver 2.21
    [   11.132288] NET: Registered protocol family 31
    [   11.136796] Bluetooth: HCI device and connection manager initialized
    [   11.143273] Bluetooth: HCI socket layer initialized
    [   11.148224] Bluetooth: L2CAP socket layer initialized
    [   11.153412] Bluetooth: SCO socket layer initialized
    [   11.160875] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   11.166276] Bluetooth: BNEP filters: protocol multicast
    [   11.171658] Bluetooth: BNEP socket layer initialized
    [   11.183286] usbcore: registered new interface driver btusb
    [   11.192836] usbcore: registered new interface driver cdc_acm
    [   11.198588] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
    [   11.210575] Bluetooth: HCI UART driver ver 2.3
    [   11.215098] Bluetooth: HCI UART protocol H4 registered
    [   11.220360] Bluetooth: HCI UART protocol BCSP registered
    [   11.230012] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [   11.236041] Bluetooth: HIDP socket layer initialized
    [   11.244099] ip_tables: (C) 2000-2006 Netfilter Core Team
    [   11.264800] nf_conntrack version 0.5.0 (1963 buckets, 7852 max)
    [   11.294667] Bluetooth: RFCOMM TTY layer initialized
    [   11.299711] Bluetooth: RFCOMM socket layer initialized
    [   11.304947] Bluetooth: RFCOMM ver 1.11
    [   11.316479] spidev spi32766.1: buggy DT: spidev listed directly in DT
    [   11.323095] ------------[ cut here ]------------
    [   11.327789] WARNING: CPU: 0 PID: 475 at drivers/spi/spidev.c:720 0x8716e33c()
    [   11.335039] Modules linked in: spidev(+) snd_usbmidi_lib slhc rfcomm nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables hidp hid_generic hci_uart crc_ccitt cdc_acm btusb btintel bnep bluetooth snd_soc_simple_card snd_soc_ralink_i2s snd_soc_wm8960 videobuf2_vmalloc videobuf2_memops videobuf2_core hid v4l2_common videodev evdev snd_soc_core ralink_gdma virt_dma mt76x8 ralink_eeprom_api ledtrig_oneshot ledtrig_morse ledtrig_heartbeat ledtrig_gpio ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables msdos snd_pcm_dmaengine snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd input_core soundcore vfat fat ntfs autofs4 nls_utf8 nls_iso8859_1 nls_cp437 regmap_i2c dma_shared_buffer ecb cmac usb_storage sdhci_pltfm sdhci leds_gpio ohci_platform ohci_hcd ledtrig_transient ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache exfat usbcore nls_base usb_common crc16 cryptomgr aead crypto_null crc32c_generic crypto_hash
    [   11.438834] CPU: 0 PID: 475 Comm: kmodloader Not tainted 4.4.39 #0
    [   11.445117] Stack : 80380308 00000000 00000001 803d0000 87da5680 803ccd83 80361c74 000001db
              80413434 0000000b 0000001a 024000c0 80065e1c 8004aa3c 80367170 803d0000
              00000003 0000000b 80365574 8761db4c 80065e1c 800489a8 00000000 00000000
              00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
              00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
              ...
    [   11.481284] Call Trace:
    [   11.483823] [<80065e1c>] module_sect_show+0x0/0x18
    [   11.488691] [<8004aa3c>] vprintk_default+0x24/0x30
    [   11.493581] [<80065e1c>] module_sect_show+0x0/0x18
    [   11.498440] [<800489a8>] printk+0x2c/0x38
    [   11.502529] [<800250b8>] warn_slowpath_common+0xa0/0xd0
    [   11.507839] [<8014955c>] dump_stack+0x14/0x28
    [   11.512274] [<8001453c>] show_stack+0x50/0x84
    [   11.516691] [<800250b8>] warn_slowpath_common+0xa0/0xd0
    [   11.522007] [<8716e33c>] 0x8716e33c
    [   11.525544] [<87170000>] 0x87170000
    [   11.529095] [<80025170>] warn_slowpath_null+0x18/0x24
    [   11.534258] [<8020ce50>] of_match_node+0x20/0x44
    [   11.538953] [<87170000>] 0x87170000
    [   11.542502] [<8716e33c>] 0x8716e33c
    [   11.546053] [<801bb978>] devm_kfree+0x20/0x44
    [   11.550520] [<801dcb10>] spi_drv_probe+0x3c/0x84
    [   11.555213] [<801b84a8>] driver_probe_device+0x120/0x288
    [   11.560637] [<80089d04>] kstrdup+0x44/0x8c
    [   11.564808] [<801dca10>] spi_match_device+0x38/0xa8
    [   11.569792] [<801b868c>] __driver_attach+0x7c/0xb4
    [   11.574670] [<801b68b0>] next_device+0x10/0x30
    [   11.579184] [<801b8610>] __driver_attach+0x0/0xb4
    [   11.583977] [<801b696c>] bus_for_each_dev+0x9c/0xac
    [   11.588938] [<80303cd4>] klist_add_tail+0x24/0x50
    [   11.593723] [<87170000>] 0x87170000
    [   11.597266] [<801b6740>] bus_get+0x2c/0x50
    [   11.601457] [<801b7ba0>] bus_add_driver+0xec/0x20c
    [   11.606324] [<800ac880>] exact_match+0x0/0x8
    [   11.610673] [<800acd88>] exact_lock+0x0/0x24
    [   11.615004] [<87170000>] 0x87170000
    [   11.618539] [<87170000>] 0x87170000
    [   11.622094] [<801b8da4>] driver_register+0xa8/0xf8
    [   11.626958] [<877df000>] init_module+0x0/0xdc [spidev]
    [   11.632194] [<87170000>] 0x87170000
    [   11.635738] [<87170000>] 0x87170000
    [   11.639294] [<87170000>] 0x87170000
    [   11.642838] [<877df098>] init_module+0x98/0xdc [spidev]
    [   11.648142] [<80155128>] kasprintf+0x1c/0x28
    [   11.652505] [<80045394>] __wake_up+0x24/0x48
    [   11.656838] [<877df000>] init_module+0x0/0xdc [spidev]
    [   11.662084] [<8000d590>] do_one_initcall+0x1e8/0x214
    [   11.667132] [<80045394>] __wake_up+0x24/0x48
    [   11.671484] [<877df000>] init_module+0x0/0xdc [spidev]
    [   11.676713] [<8003404c>] call_usermodehelper_exec+0x144/0x160
    [   11.682574] [<80033b3c>] call_usermodehelper_setup+0x38/0xa8
    [   11.688341] [<80065e1c>] module_sect_show+0x0/0x18
    [   11.693239] [<8006703c>] do_init_module+0x74/0x1cc
    [   11.698110] [<8009d834>] __vunmap+0xf0/0x114
    [   11.702481] [<800688d0>] load_module+0x16c0/0x1b68
    [   11.707345] [<80066408>] unknown_module_param_cb+0x0/0xac
    [   11.712844] [<8009dd28>] __vmalloc_node+0x34/0x40
    [   11.717637] [<80068e0c>] SyS_init_module+0x94/0x180
    [   11.722599] [<80068ea8>] SyS_init_module+0x130/0x180
    [   11.727663] [<8000655c>] syscall_common+0x30/0x54
    [   11.732459] [<80008958>] __bzero+0xbc/0x164
    [   11.736700]
    [   11.738211] ---[ end trace f333f8895d519cad ]---
    [   11.750197] usbcore: registered new interface driver ums-alauda
    [   11.759179] usbcore: registered new interface driver ums-cypress
    [   11.768350] usbcore: registered new interface driver ums-datafab
    [   11.777223] usbcore: registered new interface driver ums-freecom
    [   11.786337] usbcore: registered new interface driver ums-isd200
    [   11.795443] usbcore: registered new interface driver ums-jumpshot
    [   11.804495] usbcore: registered new interface driver ums-karma
    [   11.814151] usbcore: registered new interface driver ums-sddr09
    [   11.823250] usbcore: registered new interface driver ums-sddr55
    [   11.832626] usbcore: registered new interface driver ums-usbat
    [   11.844658] usbcore: registered new interface driver usbhid
    [   11.850388] usbhid: USB HID core driver
    [   11.857944] usbcore: registered new interface driver usblp
    [   11.871709] usbcore: registered new interface driver usbserial
    [   11.877744] usbcore: registered new interface driver usbserial_generic
    [   11.884562] usbserial: USB Serial support registered for generic
    [   11.902744] Driver for 1-wire Dallas network protocol.
    [   11.928975] xt_time: kernel timezone is -0000
    [   11.935758] usbcore: registered new interface driver ch341
    [   11.941513] usbserial: USB Serial support registered for ch341-uart
    [   11.950380] usbcore: registered new interface driver cp210x
    [   11.956157] usbserial: USB Serial support registered for cp210x
    [   11.965688] usbcore: registered new interface driver ftdi_sio
    [   11.971746] usbserial: USB Serial support registered for FTDI USB Serial Device
    [   11.993523] usbcore: registered new interface driver pl2303
    [   11.999398] usbserial: USB Serial support registered for pl2303
    [   12.010740] PPP generic driver version 2.4.2
    [   12.018278] NET: Registered protocol family 24
    [   12.036415] usbcore: registered new interface driver snd-usb-audio
    [   12.053333] usbcore: registered new interface driver uvcvideo
    [   12.059171] USB Video Class driver (1.1.1)
    [   12.320786] random: jshn: uninitialized urandom read (4 bytes read, 20 bits of entropy available)
    [   12.405359] random: jshn: uninitialized urandom read (4 bytes read, 20 bits of entropy available)
    [   18.882660] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [   22.169251]  ch1 bssid=f4:4e:05:3a:52:d1
    [   22.173296]  ch1 bssid=14:91:82:b9:6e:c7
    [   22.177276]  ch1 bssid=00:26:5a:f5:07:75
    [   22.181289]  ch1 bssid=f4:4e:05:3a:52:d0
    [   22.185269]  ch1 bssid=06:26:5a:f5:07:75
    [   22.189268]  ch1 bssid=16:91:82:b9:6e:c7
    [   22.193247]  ch2 bssid=dc:3a:5e:4c:9b:9f
    [   22.197226]  ch2 bssid=08:86:3b:2c:40:56
    [   22.201229]  ch2 bssid=ec:8e:b5:b8:00:2c
    [   22.205210]  ch4 bssid=dc:ef:09:ed:ed:b5
    [   22.209188]  ch6 bssid=fc:5b:39:03:e1:30
    [   22.213185]  ch6 bssid=fc:5b:39:03:e1:31
    [   22.217163]  ch9 bssid=18:a6:f7:02:2d:ba
    [   22.221160]  ch11 bssid=f4:4e:05:7e:a3:41
    [   22.225263]  ch11 bssid=60:e3:27:46:60:1c
    [   22.229369]  ch11 bssid=f4:4e:05:7e:a3:40
    [   22.233438]  ch11 bssid=04:a1:51:ad:1b:1e
    [   22.237506] =====================================================
    [   22.243707] Channel 1 : Dirty = 580, False CCA = 0, Busy Time = 6080, Skip Channel = FALSE
    [   22.252097] Channel 2 : Dirty = 490, False CCA = 0, Busy Time = 7700, Skip Channel = FALSE
    [   22.260494] Channel 3 : Dirty = 344, False CCA = 0, Busy Time = 11445, Skip Channel = FALSE
    [   22.268991] Channel 4 : Dirty = 354, False CCA = 0, Busy Time = 5667, Skip Channel = FALSE
    [   22.277394] Channel 5 : Dirty = 308, False CCA = 0, Busy Time = 3097, Skip Channel = FALSE
    [   22.285789] Channel 6 : Dirty = 272, False CCA = 0, Busy Time = 830, Skip Channel = FALSE
    [   22.294097] Channel 7 : Dirty = 196, False CCA = 0, Busy Time = 258, Skip Channel = FALSE
    [   22.302398] Channel 8 : Dirty = 204, False CCA = 0, Busy Time = 371, Skip Channel = FALSE
    [   22.310707] Channel 9 : Dirty = 230, False CCA = 0, Busy Time = 1974, Skip Channel = FALSE
    [   22.319085] Channel 10 : Dirty = 200, False CCA = 0, Busy Time = 864, Skip Channel = FALSE
    [   22.327479] Channel 11 : Dirty = 328, False CCA = 0, Busy Time = 2813, Skip Channel = FALSE
    [   22.335958] =====================================================
    [   22.342147] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 7
    [   22.350889] Min Dirty = 196
    [   22.353721] ExChannel = 0 , 0
    [   22.356726] BW        = 20
    [   22.531132] device eth0.1 entered promiscuous mode
    [   22.536012] device eth0 entered promiscuous mode
    [   22.560102] br-wlan: port 1(eth0.1) entered forwarding state
    [   22.565908] br-wlan: port 1(eth0.1) entered forwarding state
    [   24.559437] br-wlan: port 1(eth0.1) entered forwarding state
    [   27.865229] device ra0 entered promiscuous mode
    [   28.265431] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [   30.769239]  ch1 bssid=00:26:5a:f5:07:75
    [   30.773276]  ch1 bssid=06:26:5a:f5:07:75
    [   30.777280]  ch1 bssid=f4:4e:05:3a:52:d1
    [   30.781297]  ch1 bssid=14:91:82:b9:6e:c7
    [   30.785277]  ch1 bssid=f4:4e:05:3a:52:d0
    [   30.789281]  ch1 bssid=16:91:82:b9:6e:c7
    [   30.793261]  ch2 bssid=ec:8e:b5:b8:00:2c
    [   30.797239]  ch2 bssid=94:10:3e:70:ee:e3
    [   30.801237]  ch2 bssid=dc:3a:5e:4c:9b:9f
    [   30.805218]  ch2 bssid=08:86:3b:2c:40:56
    [   30.809195]  ch2 bssid=94:10:3e:70:ee:e0
    [   30.813192]  ch4 bssid=dc:ef:09:ed:ed:b5
    [   30.817171]  ch6 bssid=a0:8c:fd:6d:7e:34
    [   30.821168]  ch6 bssid=fc:5b:39:03:e1:31
    [   30.825147]  ch6 bssid=fc:5b:39:03:e1:30
    [   30.829125]  ch6 bssid=00:24:b2:14:85:9b
    [   30.833128]  ch11 bssid=f4:4e:05:7e:a3:40
    [   30.837198]  ch11 bssid=04:a1:51:ad:1b:1e
    [   30.841276]  ch11 bssid=f4:4e:05:7e:a3:41
    [   30.845344]  ch11 bssid=60:e3:27:46:60:1c
    [   30.849420] =====================================================
    [   30.855606] Channel 1 : Dirty = 644, False CCA = 0, Busy Time = 6687, Skip Channel = FALSE
    [   30.864001] Channel 2 : Dirty = 670, False CCA = 0, Busy Time = 4934, Skip Channel = FALSE
    [   30.872391] Channel 3 : Dirty = 456, False CCA = 0, Busy Time = 4389, Skip Channel = FALSE
    [   30.880788] Channel 4 : Dirty = 466, False CCA = 0, Busy Time = 10390, Skip Channel = FALSE
    [   30.889272] Channel 5 : Dirty = 400, False CCA = 0, Busy Time = 1453, Skip Channel = FALSE
    [   30.897652] Channel 6 : Dirty = 428, False CCA = 0, Busy Time = 3758, Skip Channel = FALSE
    [   30.906047] Channel 7 : Dirty = 232, False CCA = 0, Busy Time = 493, Skip Channel = FALSE
    [   30.914356] Channel 8 : Dirty = 228, False CCA = 0, Busy Time = 439, Skip Channel = FALSE
    [   30.922658] Channel 9 : Dirty = 208, False CCA = 0, Busy Time = 324, Skip Channel = FALSE
    [   30.930966] Channel 10 : Dirty = 208, False CCA = 0, Busy Time = 779, Skip Channel = FALSE
    [   30.939367] Channel 11 : Dirty = 300, False CCA = 0, Busy Time = 1993, Skip Channel = FALSE
    [   30.947830] =====================================================
    [   30.954022] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 9
    [   30.962765] Min Dirty = 208
    [   30.965595] ExChannel = 0 , 0
    [   30.968599] BW        = 20
    [   31.000109] br-wlan: port 2(ra0) entered forwarding state
    [   31.005629] br-wlan: port 2(ra0) entered forwarding state
    [   32.999248] br-wlan: port 2(ra0) entered forwarding state
    [   40.017765] !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!
    [   51.633532] random: nonblocking pool is initialized
    
    
    
    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.1.7 b139
     -----------------------------------------------------
    root@Omega-6A2F:/#
    


  • @Matthew-Strenk Looks fine to me, I don't see any issue.



  • @WereCatf so why does the light never change to a solid color? It also does not show that it is online in the console.



  • @Matthew-Strenk

    On rare occasions the LED may not stop blinking after booting, but it's safe to try connecting via serial or SSH. Your terminal output indicates it booted correctly.

    If you're worried about the LED, try power cycling it and seeing if it still persists. It shouldn't affect normal operation though.

    Re: Cloud: please see this post for more details. https://community.onion.io/topic/1144/can-t-register-device-on-cloud/23

    (I edited your post to format the terminal output for easier reading. When posting commands or terminal output, please format it as a code block in this guide.)

    Gabe



  • I noticed the Omega2+ LED blinking when I ran the poweroff or reboot command through SSH. It stopped blinking, and performed the operation after I exited SSH. Perhaps you are experiencing a software untested case that forgot to switch back the LED state? Knowing exactly how to reproduce this issue would help the developers address it.



  • I too have two Omega 2+ which don't flash their led when booting. I tried setting one up with the wizard, and everything seemed to work up to the last wizard page and the led turning off. So I simply power cycled the power dock and now the led flashed all the time. I couldn't access the console because I only got the wizard again. So I installed the console manually and now the console works. But the led still flashes all the time. Don't know if the reboot and shut down in the console did anything but I tried both and the led still flashes. Can anything be done about the led? It's irritating.



  • But now I see that the console doesn't work correctly anymore. It seems that I can log in, but the apps aren't displayed on the page.



  • I have the same issue as Anders. The led never blinked in the beginning but I was able to go through the wizard and when it completed, the led turned off. I restarted as suggested and now the led never stops blinking. I can't access it unless I'm on the omega wifi but in that case, I just get the wizard again. I tried going through the wizard and everything was saved and looked ok. The last page of the wizard said it was successfully set up and please wait while the console is installed. Nothing changes after waiting. The led still blinks forever. Any ideas?



  • I used the instructions found here: https://docs.onion.io/omega2-docs/installing-the-console.html and used SSH to install the console. Now it's working... so far.

    The LED still blinks forever though.

    UPDATE: After a restart or two, now I get the same thing as Anders. The console comes up and I log in but no apps are displayed. And after another restart, it just get an index of /console/ showing ../ and lib/. If I use ssh to reinstall console it shows again, temporarily.



  • Yes, seems to me the console is somehow destroyed when the Omega is shut down. Also, restart and power off commands doesn't seem to do anything on my 2+. Both on command line and in the console.



  • @Anders-Öster I'm also seeing the filesystem destroyed on power off and an infinite blink. My 2+ was one of those that didn't blink on first power-on and gets stuck powered off when it's doing a firmware update. This is still an issue as of b150. poweroff and reboot do nothing even when run directly from the /sbin folder where they live. I haven't tried using an SD card in there yet but that shouldn't really be the problem.

    I did have luck changing the LED using this command from elsewhere on these forums: echo default-on > /sys/class/leds/omega2p:amber:system/trigger
    I have also been re-installing the console on boot through SSH. First running oupgrade --latest then opkg update and reinstalling web stuff with console-install-tool.
    I've also been having issues getting it to connect to any AP other than my android hotspot so I've had 2 SSH sessions open with one running logread -f to keep a screen as a running log. @Peter-Hatina just uploaded a new set of instructions changing from AP mode to STA mode that might solve it so I'll have to check that out next.

    @Lazar-Demin would it help if we got you some logs? I don't have a serial port reader, so I've been relying on the internal logging. Is there any hope of getting a build with a more verbose logfile?



  • I dont know if this applies to anyone else.

    I brought my Omega2+ with the Power Dock (with 3.7v 1200mah battery, which ran for 4:27:38) into work, where I am not able to connect it with the wifi. I was on it, messing around in the ssh terminal from my iPad using vSSH app (works awesomely!). The light was blinking constantly all day.

    I got home, where it connected back up to my wifi, and I connected from different devices, including my ipad again, and the light was constantly on.

    The only difference was that I was not connected to an external wifi at work like I am at home. I dont know if this applies to anyone else, it was just something I noticed with mine.



  • Where is the "Bad CRC, using default environment" coming from? My O2+ shows the same thing and caused me a bit of worry...



  • @Art-Milburn said in Omega2+ amber light keeps blinking:

    Where is the "Bad CRC, using default environment" coming from? My O2+ shows the same thing and caused me a bit of worry...

    U-Boot is designed to allow interactive modifications of settings, and saving them in a reserved section of the flash, so that you can change the system startup behavior without recompiling the code, but instead by setting and saving various environment variables.

    At least Mediatek (MT7688 chip maker) has this effectively disabled in their U-Boot tree, essentially only using the compiled-in settings, so the message is largely irrelevant. Likely Omega 2 is similar but I haven't looked at it in detail.

    Crudely speaking, if the system boots and works as expected, you can ignore that message...



  • @Chris-Stratton said in Omega2+ amber light keeps blinking:

    At least Mediatek (MT7688 chip maker) has this effectively disabled in their U-Boot tree, essentially only using the compiled-in settings, so the message is largely irrelevant. Likely Omega 2 is similar but I haven't looked at it in detail.

    Not just largely, but it's wholly irrelevant. The U-boot environment - partition is just empty, it's not used, and besides, the kernel has been compiled so as to ignore any bootargs U-boot might toss at it anyways.

    Just to nitpick a little and to say yeah, you're correct. :)



  • I fixed the problem that I was having where the device would not go into the console or show up in the cloud. But I am still having the problem with the blinking LED. Although everything else is working so I guess this isn't that big of a deal.

    For anyone who is wondering, I fixed the connectivity issues by connecting the device through serial. Then I downloaded the latest version of the firmware and installed with the option of factory reset. Then I went into the setup config, went through the steps and now it is working! If anyone has any questions let me know.




Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.