[SOLVED] Omega can't connect to WiFi

  • well, i tried to update the firmware... didn't work :(


  • any suggestions, @Boken-Lin ? :)

  • administrators

    @Nito-Weber it looks like the Omega doesn't have access to the internet, can you try running wifisetup -checkconnection and post the output?

  • @Nito-Weber Or can you try to do ping google.com to see if you can connect to the google servers?

  • I had a similar hiccup, but managed to work though it.

    I setup the Omega with just a USB charger to power the Omega, and my Chromebook to connect to it via wireless. First I connected to the Omegs'a WiFi network. After logging in and entering the details for my wireless network I clicked the connect button. It said that it had failed to connect. I had a suspicion that it did connect (I typed the password correct) and was sitting on the network. I loaded up Fing on my Android phone and did a network scan. Any network scanner will do though. I found a new device named Omega-ABCD on my network.

    My Chromebook had already reconnected to my previous network, so I typed in the IP address of the Omega I found during the network scan. Once typing in the IP in my browser (Chrome, it's a Chromebook), I was presented with the Omega's login page. I logged in again, and was slightly surprised to be asked for the WiFi password again. Not a big deal, as I entered the wireless network's password again and clicked connect. This time it proceeded to the next page and began to update the Omega.

    Once the update page's status read "Done". I visited the IP of the Omega again. Note, I didn't press F5 to refresh. I just visited the root address of the IP/URL Your IP address will most definitely be different than mine is. You'll have to do a network scan to find the Onion on your network.

    I'm was then able to login to the Onion Console., update settings, visit terminal, etc..

  • Thank you very much for all the kind tips @Lazar-Demin @Boken-Lin and @Mike :) !

    Unfortunately none of them worked BUT i have an idea about the cause now: i live in a student dormitory and normally we need a code/password for every device to access the network (not the wifi). however in my room there is no code needed normally (seems to be a friendly bug there) so i can connect every device to the house's network through my own wifi. since the onion connects to the wifi but then aborts because it won't find a connection to any server i think i need to type in that network password too. but where? I hope you will understand this confusing way of network security here :D

  • @Nito-Weber This wiki might be helpful to you: https://wiki.onion.io/Tutorials/Connecting-Omega-to-Wifi-Hotspot-that-Requres-Login. Please let me know if this helps!

  • When I received my Omega I could not connect it to my WiFi network. However I could with my Android phone see Omega-1D1D as a hotspot access point so I connected to it , noted the IP address then used the browser on my Android to connect (can't remember if I had to login) then it offered the setup wizard and updated the firmware. Sorry can not remember the full sequence but a bit hassled at the time trying to get it to go. My private WiFi network was on 10.0.x.x once the wizard had finished and I had added my network Omega was given a new IP in the 10.x.x.x range and now connects OK every time.

  • Thank you for your help @Anthony-Wakefield and @Boken-Lin !

    I tried the wiki and thought it might work but it didn't... Just to get it right: I log in to the omega AP and then browse whereever to get a site to log in to the network THROUGH the omega? at least, that is what i tried now and it didn't really work. I get an IP adress but there's still no network/internet connection.

    I tried @Anthony-Wakefield 's version both with Android and iOS but i cannot access the IP through the phone's browser. "This website isn't available"...

  • upload-6dafabc8-21d6-4f56-bba8-01c533573201

    that's how far i got with the wiki...

  • @Nito-Weber Ah, you need to edit that file. With the command you entered, you were trying to execute the file as a program. Try vi /etc/config/wireless or nano /etc/config/wireless. Although you'll need to install nano first.

  • i added a line there but how do i save things? @Boken-Lin

  • @Nito-Weber Press ESC and then type :wq, press ENTER.

  • @Boken-Lin well.... i managed to save but i think i need a default version of /etc/config/wireless now becausethe omega won't connect to any wifi (not even my iPhone hotspot).


    does this help you? i'm sorry i produce one problem after another but i'm a total beginner! I didn't know how the VI editor works. now i do but i would like to restore the default version of/etc/config/wireless

  • @Nito-Weber This is the default:

    config wifi-device 'radio0'
            option type 'mac80211'
            option hwmode '11g'
            option path 'platform/ar933x_wmac'
            option htmode 'HT20'
            option disabled '0'
            option channel '9'
            option txpower '30'
            option country 'US'
    config wifi-iface
            option device 'radio0'
            option network 'wlan'
            option mode 'ap'
            option ssid 'Omega-0104'
            option encryption 'psk2'
            option key 'onioneer'
    config wifi-iface
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option ssid 'Router'
            option encryption 'psk2'
            option key 'P@ssw0rd'

  • @Boken-Lin I accidently deleted the very first line yesterday. so i checked the default version and mine is the same now (except from the network settings in the end). but as soon as i try to connect to my wifi it says:

    Connecting to Shire network using intf 1...
    'radio0' is disabled
    'radio0' is disabled
    Checking wwan device status...
    wwan is not up!!
    Checking internet connection...
    ERROR: request timeout, internet connection not successful
    Disabling network on iface 1 ...

    Doesn't seem to be right but i don't see any difference between the default and my version.

    So my question is:

    • What is intf 1 or intf 2?
    • why isn't wwan up any more?
    • how can i fix this?

    Thanks in advance :)

  • @Nito-Weber Perhaps you have changed some settings in /etc/config/network

    Here's the default content of that file:

    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''
    #config globals 'globals'
    #   option ula_prefix 'fd28:1f13:5b38::/48'
    #config interface 'lan'
    #   option ifname 'eth0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr ''
    #   option netmask ''
    #   option ip6assign '60'
    #config interface 'wan'
    #   option ifname 'eth0'
    #   option proto 'dhcp'
    #config interface 'wan6'
    #   option ifname '@wan'
    #   option proto 'dhcpv6'
    #config switch
    #   option name 'switch0'
    #   option reset '1'
    #   option enable_vlan '1'
    #config switch_vlan
    #   option device 'switch0'
    #   option vlan '1'
    #   option ports '0 1 3'
    config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
    config interface 'wlan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
    #config interface 'wlan'
    #   option ifname 'wlan0-1 wlan0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr ''
    #   option netmask ''
    #   option ip6assign '60'

    Can you copy and paste that in to /etc/config/network and execute /etc/init.d/network restart to reload the configuration? Please let me know if that helps.

  • I just got my omega today (looks great so far) but i can't connect to wifi in the house, i've tried scanning and manually adding it but no joy with either, heres what i get:Capture.PNG

    Any help would be great!

  • @Eoin-O'Dowd Can you add the following block to /etc/config/wireless:

    config wifi-iface
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option encryption 'psk2'
            option ssid '<Network Name>'
            option key '<Password>'

    You may need to change encryption to wep or psk for WEP encryption and WPA1, respectively. After you are done, just save the file and run:


    This should restart your wifi service with the new configuration.

    Please let me know if this helps.

  • No, not working either, still the same! any other ideas?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.