Problem configuring WiFi



  • Hello everyone,

    I finally received my Onion2+ and so far I'm pretty happy with it (in fact I will probably order some more via Indiegogo). But today I retried to configure my WiFi and network settings, basically so the Onion2+ becomes a simple WiFi-Client in my network, without creating its own AP. I read through the LEDE and OpenWRT documentation regarding networking and wireless and I think I should habe a working configuration but I always end up with the following error messages:

    ra0(cfg033579): Invalid mode
    ra0(cfg033579): Invalid mode
    Interface doesn't accept private ioctl...
    set (8BE2): Network is down
    ra0(ralink): enable failed
    

    My networking config is now as follows:

    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wifi'
            option proto 'dhcp'
            option hostname 'omega2p'
    

    And here is my wireless config

    config wifi-device  ra0
            option type     ralink
            option mode     9
            option channel  auto
            option txpower 100
            option ht       20
            option country US
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wifi'
            option mode 'sta'
            option ssid 'Internet-Of-Shit'
            option encryption 'psk2'
            option key 'some-password'
    

    I hope anyone can point me into the right direction where my error is.

    Thanks in advance



  • Are you living in US ? If not you have to change the Chanel-Settings ... Your router might use Chanel higher 9 (US-default=Chanel 1-9). Easiest way to check is, if you have access to your router, change to a fix chanel between 1+9.

    There exists the possibility to edit on the omega config file direct ... i will do this for me ... because mine (Router) is also higher than 9 ... if someone links to the request who shows how to change the config file on Omega i will be grateful ... otherwise i will try to find it out ... small detail ... i still use Omega1.



  • Hi,

    as I'm stuck at the exact same point. I'd like to know if you found a solution for this problem?

    BR,
    Mirko.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.