Can't connect to wifi - driving me insane.



  • Hi,

    I've posted before about issues connecting to wifi, but in the interest of my sanity I feel I need to start my own thread on this. There's a lot of noise and similar issues and various fixes and so far nothing I have tried has helped.

    I am running the latest firmware, 0.1.9 b149, and all I want to do is to be able to connect my Omega2+ to my network via wifi. Currently this is only possible via the ethernet expansion, since the only thing I can get the Omega2+ to connect to is an unencrypted cellular hotspot; anything encrypted (even WPA2 with AES) and it just refuses to join.

    APs available are...
    ra0       get_site_survey:
    Ch  SSID                             BSSID               Security               Signal(%)W-Mode  ExtCH  NT
    4   myssid                        4e:5e:0c:a5:9d:c9   WPA1PSKWPA2PSK/AES     76       11b/g/n ABOVE  In
    

    And my /etc/config/wireless:

    root@Omega-76EB:~# cat /etc/config/wireless
    
    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ssid 'Omega-76EB'
    	option ApCliAuthMode 'WPA2PSK'
    	option ApCliEncrypType 'AES'
    	option ApCliSsid 'myssid'
    	option ApCliPassWord 'alphabeticpassword'
    	option ApCliEnable '1'
    
    config wifi-config
    	option ssid 'myssid'
    	option encryption 'WPA2PSK'
    	option key 'alphabeticpassword'
    

    I have tried various 'fixes' listed throughout the forums and gotten nowhere... so I'm starting over. Maybe I'm missing something.



  • @Jessica-Litwin said in Omega2+ fails to connect to wifi:

    Hi, I too have this problem. Brand new Omega2+ out of the box; unable to connect to Microtik CRS109-8G-1S-2HnD router wifi 2GHz b/g/n 20/40MHz HT Above, channel 3+7 (mixed-mode).

    I used my ethernet attachment and a network bridge to update it- the behavior is still present in 0.1.7 b139

    I just linked to your other request-answer, seams to be important to know your router2.
    Was reading, that other persons had proplems with Microtik 2. And the other answer was with a other firmware.



  • Ah yes thank you. I am now running 0.1.9 b149 with the same issue.



  • Not sure if a Mikrotik router and the Omega2+ doesn't play well together as I also haven't been able to get the Omega2+ to connect to my WiFi yet. My router is a Mikrotik hAP RB962.



  • Did someone of you Microtik users already do a systematic check of possibilities?

    I mean, create a virtual wifi network beside the existing, just let access mac addresses from omega (to make it more secure, if you stop publish the address on pics & logs).

    Then test without encryption & pw and go up all the steps ... maybe somehow you will be able to connect, just not found the right protocol/encryption settings jet?!



  • @Luciano-S. I'm not sure this is a problem limited to Mikrotik users because I can't even get the Omega2 to join to my cellphone's wifi hotspot unless I run it as an open wifi hotspot, which is only really acceptable for testing purposes.



  • I have similar problems. I am suspecting that this might have something to do with the WPA2 key. Would you mind telling me, how long your key is, and if it does contain any special characters, or only digits and letters?



  • I've also had no end of complications getting my wireless to work.

    Connecting to my mobile (Nexus 6P) works perfectly with a password, but my Mikrotik (CRS125 + 2011) units just don't play ball.
    I've tried turning the security on for every protocol and nothing seems to help.

    I can access the unit itself on it's own AP address which allows SSH access and then I've changed settings, including setting the country code, setting AES, etc.

    I haven't tried allowing purely MAC only with no password yet, will try that when I get home and see how it goes.

    Very frustrating indeed.



  • Just as a point of interest, I've upgraded the unit to the latest firmware (1.9) as of yesterday and it still produces the same result.



  • Are you using any special characters in your router password?



  • @Moritz-Stueckler 15 characters, [a-z] only.



  • Try this code (Python) and see what signal strength you get. Assuming you have Python installed.

    import json
    import os
    from time import sleep as sleep
    
    #Enter your own SSID you wish to track here.
    myssid = 'YourSSID'
    
    while True:
    	os.system("ubus call onion wifi-scan \"{\'device\':\'ra0\'}\" > wifis.json")
    	with open('./wifis.json','r') as wifis:
    		wifilist = json.load(wifis)
    	for i in wifilist['results']:
    		if i['ssid'] == myssid:
    			output = i['ssid']+': '+i['signalStrength']
    			print(output)
    	sleep(2)
    

    I receive the following when I run it on my home network.

    root@RedDragon:/Shared/scripts# python wiscan.py
    MySSID: 52
    MySSID: 55
    MySSID: 52
    MySSID: 55
    


  • I've done some testing with the only other wifi device I have: a wifi hotspot on a Samsung Galaxy J7. The results are distressing. I am connected via my mac to the serial console to do this test.

    Test 0: a working example using no encryption, which is literally the only way I can make it work:

    root@Omega-76EB:/# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-76EB'
            option ApCliSsid 'ma3a'
            option ApCliEnable '1'
    
    
    root@Omega-76EB:/# wifi
    [  602.092577] br-wlan: port 2(ra0) entered disabled state
    [  604.932461] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  607.378514]  ch4 bssid=4c:5e:0c:a5:9d:c9
    [  607.382514]  ch4 bssid=4e:5e:0c:a5:9d:c9
    [  607.386493]  ch4 bssid=fc:3f:db:e0:7c:9d
    [  607.390503]  ch6 bssid=ec:1a:59:2f:33:0c
    [  607.394483]  ch11 bssid=14:ed:bb:ae:06:c2
    [  607.398570]  ch11 bssid=a0:cb:fd:e6:05:d4
    [  607.402632] =====================================================
    [  607.408830] Channel 1 : Dirty = 72, False CCA = 0, Busy Time = 5309, Skip Channel = FALSE
    [  607.417121] Channel 2 : Dirty = 104, False CCA = 0, Busy Time = 18298, Skip Channel = FALSE
    [  607.425615] Channel 3 : Dirty = 120, False CCA = 0, Busy Time = 4822, Skip Channel = FALSE
    [  607.434020] Channel 4 : Dirty = 258, False CCA = 0, Busy Time = 4725, Skip Channel = FALSE
    [  607.442415] Channel 5 : Dirty = 128, False CCA = 0, Busy Time = 6423, Skip Channel = FALSE
    [  607.450809] Channel 6 : Dirty = 164, False CCA = 0, Busy Time = 4858, Skip Channel = FALSE
    [  607.459203] Channel 7 : Dirty = 144, False CCA = 0, Busy Time = 3109, Skip Channel = FALSE
    [  607.467581] Channel 8 : Dirty = 136, False CCA = 0, Busy Time = 2203, Skip Channel = FALSE
    [  607.475975] Channel 9 : Dirty = 80, False CCA = 0, Busy Time = 3525, Skip Channel = FALSE
    [  607.484281] Channel 10 : Dirty = 84, False CCA = 0, Busy Time = 3475, Skip Channel = FALSE
    [  607.492676] Channel 11 : Dirty = 160, False CCA = 0, Busy Time = 3693, Skip Channel = FALSE
    [  607.501151] =====================================================
    [  607.507331] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  607.516070] Min Dirty = 72
    [  607.518826] ExChannel = 0 , 0
    [  607.521832] BW        = 20
    [  607.859245] br-wlan: port 2(ra0) entered forwarding state
    [  607.864758] br-wlan: port 2(ra0) entered forwarding state
    [  609.858484] br-wlan: port 2(ra0) entered forwarding state
    setting apcli
    [  614.543000] !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!
    

    Hey, I have internet. Let's test:

    root@Omega-76EB:/# oupgrade
    > Device Firmware Version: 0.1.9 b149
    > Checking latest version online...
    > Repo Firmware Version: 0.1.9 b149
    > Comparing version numbers
    > Device firmware is up to date!
    

    It works! So I clear out the stuff in the /etc/config/network related to my AP and start from this:

    root@Omega-76EB:/# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-76EB'
            option ApCliEnable '1'
    

    Now I use 'wifi-setup' to configure:

    root@Omega-76EB:/# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) foo
    2) bar
    3) DIRECT-9C-HP ENVY 7640 series
    4) aviary
    5) ATT5evH34Z
    6) ma3a
    
    Selection: 6
    Network: ma3a
    Authentication type: NONE
    
    > Restarting wifimanager for changes to take effect
    

    Here's what wifisetup did:

    root@Omega-76EB:/# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-76EB'
            option ApCliEnable '1'
    
    config wifi-config
            option ssid 'ma3a'
            option encryption 'NONE'
    

    Wifi doesn't work. What is the purpose of the wifi-config section if it doesn't actually make it work?
    If I add back ApCliSsid 'ma3a', I can connect to my open hotspot.

    root@Omega-76EB:/# wifi
    [ 2092.302361] br-wlan: port 2(ra0) entered disabled state
    [ 2095.943286] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 2098.399172]  ch4 bssid=fa:8f:ca:82:e6:b0
    [ 2098.403170]  ch4 bssid=4c:5e:0c:a5:9d:c9
    [ 2098.407151]  ch4 bssid=4e:5e:0c:a5:9d:c9
    [ 2098.411160]  ch4 bssid=fc:3f:db:e0:7c:9d
    [ 2098.415143]  ch6 bssid=ec:1a:59:2f:33:0c
    [ 2098.419140]  ch11 bssid=a0:cb:fd:e6:05:d4
    [ 2098.423211]  ch11 bssid=14:ed:bb:ae:06:c2
    [ 2098.427272] =====================================================
    [ 2098.433470] Channel 1 : Dirty = 96, False CCA = 0, Busy Time = 8690, Skip Channel = FALSE
    [ 2098.441770] Channel 2 : Dirty = 132, False CCA = 0, Busy Time = 17458, Skip Channel = FALSE
    [ 2098.450272] Channel 3 : Dirty = 152, False CCA = 0, Busy Time = 30105, Skip Channel = FALSE
    [ 2098.458796] Channel 4 : Dirty = 338, False CCA = 0, Busy Time = 31654, Skip Channel = FALSE
    [ 2098.467284] Channel 5 : Dirty = 160, False CCA = 0, Busy Time = 23102, Skip Channel = FALSE
    [ 2098.475766] Channel 6 : Dirty = 192, False CCA = 0, Busy Time = 4840, Skip Channel = FALSE
    [ 2098.484165] Channel 7 : Dirty = 168, False CCA = 0, Busy Time = 4927, Skip Channel = FALSE
    [ 2098.492560] Channel 8 : Dirty = 156, False CCA = 0, Busy Time = 14866, Skip Channel = FALSE
    [ 2098.501036] Channel 9 : Dirty = 80, False CCA = 0, Busy Time = 3522, Skip Channel = FALSE
    [ 2098.509340] Channel 10 : Dirty = 84, False CCA = 0, Busy Time = 3505, Skip Channel = FALSE
    [ 2098.517718] Channel 11 : Dirty = 160, False CCA = 0, Busy Time = 4942, Skip Channel = FALSE
    [ 2098.526192] =====================================================
    [ 2098.532384] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 9
    [ 2098.541118] Min Dirty = 80
    [ 2098.543861] ExChannel = 0 , 0
    [ 2098.546865] BW        = 20
    [ 2099.050186] br-wlan: port 2(ra0) entered forwarding state
    [ 2099.055724] br-wlan: port 2(ra0) entered forwarding state
    [ 2101.049001] br-wlan: port 2(ra0) entered forwarding state
    setting apcli
    root@Omega-76EB:/# [ 2106.504778] !!! APCLI LINK UP - IF(apcli0) AuthMode(0)=OPEN, WepStatus(1)=NONE!
    

    Test 1: Same wifi hotspot, with WPA2 PSK enabled with password 'onioneer':

    root@Omega-76EB:/# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) foo
    2) bar
    3) DIRECT-9C-HP ENVY 7640 series
    4) aviary
    5) ma3a
    6) ATT5evH34Z
    
    Selection: 5
    Network: ma3a
    Authentication type: WPA2PSK
    Enter password: onioneer
    
    > Restarting wifimanager for changes to take effect
    root@Omega-76EB:/#
    
    
    root@Omega-76EB:/# [ 2301.775800] br-wlan: port 2(ra0) entered disabled state
    [ 2303.481382] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 2305.937279]  ch4 bssid=fa:8f:ca:82:e6:b0
    [ 2305.941352]  ch4 bssid=4c:5e:0c:a5:9d:c9
    [ 2305.945333]  ch4 bssid=4e:5e:0c:a5:9d:c9
    [ 2305.949344]  ch4 bssid=fc:3f:db:e0:7c:9d
    [ 2305.953324]  ch6 bssid=a0:cb:fd:e6:05:d4
    [ 2305.957321]  ch6 bssid=ec:1a:59:2f:33:0c
    [ 2305.961295] =====================================================
    [ 2305.967493] Channel 1 : Dirty = 96, False CCA = 0, Busy Time = 5501, Skip Channel = FALSE
    [ 2305.975784] Channel 2 : Dirty = 152, False CCA = 0, Busy Time = 4922, Skip Channel = FALSE
    [ 2305.984176] Channel 3 : Dirty = 176, False CCA = 0, Busy Time = 4949, Skip Channel = FALSE
    [ 2305.992572] Channel 4 : Dirty = 366, False CCA = 0, Busy Time = 6759, Skip Channel = FALSE
    [ 2306.000979] Channel 5 : Dirty = 192, False CCA = 0, Busy Time = 6697, Skip Channel = FALSE
    [ 2306.009374] Channel 6 : Dirty = 282, False CCA = 0, Busy Time = 7005, Skip Channel = FALSE
    [ 2306.017768] Channel 7 : Dirty = 160, False CCA = 0, Busy Time = 5408, Skip Channel = FALSE
    [ 2306.026146] Channel 8 : Dirty = 136, False CCA = 0, Busy Time = 5476, Skip Channel = FALSE
    [ 2306.034539] Channel 9 : Dirty = 48, False CCA = 0, Busy Time = 5635, Skip Channel = FALSE
    [ 2306.042845] Channel 10 : Dirty = 40, False CCA = 0, Busy Time = 9320, Skip Channel = FALSE
    [ 2306.051234] Channel 11 : Dirty = 0, False CCA = 0, Busy Time = 11808, Skip Channel = FALSE
    [ 2306.059622] =====================================================
    [ 2306.065802] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 11
    [ 2306.074630] Min Dirty = 0
    [ 2306.077292] ExChannel = 0 , 0
    [ 2306.080297] BW        = 20
    [ 2306.587848] br-wlan: port 2(ra0) entered forwarding state
    [ 2306.593363] br-wlan: port 2(ra0) entered forwarding state
    [ 2308.587124] br-wlan: port 2(ra0) entered forwarding state
    [ 2341.249786] br-wlan: port 2(ra0) entered disabled state
    
    [ 2344.979038] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 2347.434903]  ch4 bssid=fa:8f:ca:82:e6:b0
    [ 2347.438901]  ch4 bssid=4c:5e:0c:a5:9d:c9
    [ 2347.442882]  ch4 bssid=4e:5e:0c:a5:9d:c9
    [ 2347.446891]  ch4 bssid=fc:3f:db:e0:7c:9d
    [ 2347.450874]  ch6 bssid=a0:cb:fd:e6:05:d4
    [ 2347.454869]  ch6 bssid=ec:1a:59:2f:33:0c
    [ 2347.458850]  ch11 bssid=14:ed:bb:ae:06:c2
    [ 2347.462912] =====================================================
    [ 2347.469110] Channel 1 : Dirty = 96, False CCA = 0, Busy Time = 7008, Skip Channel = FALSE
    [ 2347.477416] Channel 2 : Dirty = 152, False CCA = 0, Busy Time = 5304, Skip Channel = FALSE
    [ 2347.485810] Channel 3 : Dirty = 176, False CCA = 0, Busy Time = 5908, Skip Channel = FALSE
    [ 2347.494188] Channel 4 : Dirty = 366, False CCA = 0, Busy Time = 5759, Skip Channel = FALSE
    [ 2347.502600] Channel 5 : Dirty = 192, False CCA = 0, Busy Time = 6998, Skip Channel = FALSE
    [ 2347.510989] Channel 6 : Dirty = 282, False CCA = 0, Busy Time = 6481, Skip Channel = FALSE
    [ 2347.519383] Channel 7 : Dirty = 180, False CCA = 0, Busy Time = 4578, Skip Channel = FALSE
    [ 2347.527777] Channel 8 : Dirty = 160, False CCA = 0, Busy Time = 5486, Skip Channel = FALSE
    [ 2347.536170] Channel 9 : Dirty = 76, False CCA = 0, Busy Time = 4558, Skip Channel = FALSE
    [ 2347.544517] Channel 10 : Dirty = 72, False CCA = 0, Busy Time = 5259, Skip Channel = FALSE
    [ 2347.552915] Channel 11 : Dirty = 70, False CCA = 0, Busy Time = 5693, Skip Channel = FALSE
    [ 2347.561297] =====================================================
    [ 2347.567490] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 11
    [ 2347.576318] Min Dirty = 70
    [ 2347.579061] ExChannel = 0 , 0
    [ 2347.582066] BW        = 20
    [ 2348.095648] br-wlan: port 2(ra0) entered forwarding state
    [ 2348.101164] br-wlan: port 2(ra0) entered forwarding state
    [ 2350.094773] br-wlan: port 2(ra0) entered forwarding state
    
    root@Omega-76EB:/# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    

    So we're not connected. Let's check the config:

    root@Omega-76EB:/# cat /etc/config/wireless
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-76EB'
            option ApCliSsid 'ma3a'
            option ApCliPassWord 'onioneer'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEnable '0'
    
    config wifi-config
            option ssid 'ma3a'
            option encryption 'WPA2PSK'
            option key 'onioneer'
    

    It set ApCliEnable to 0.. but... wait? It added all the ApCli options, which it didn't do before with the open wifi network?
    Let's see what happens now:

    root@Omega-76EB:/# wifi
    [ 2436.278165] br-wlan: port 2(ra0) entered disabled state
    [ 2437.680479] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [ 2440.129597]  ch4 bssid=fa:8f:ca:82:e6:b0
    [ 2440.133597]  ch4 bssid=4c:5e:0c:a5:9d:c9
    [ 2440.137576]  ch4 bssid=4e:5e:0c:a5:9d:c9
    [ 2440.141588]  ch4 bssid=fc:3f:db:e0:7c:9d
    [ 2440.145569]  ch6 bssid=ec:1a:59:2f:33:0c
    [ 2440.149570]  ch6 bssid=a0:cb:fd:e6:05:d4
    [ 2440.153544] =====================================================
    [ 2440.159743] Channel 1 : Dirty = 96, False CCA = 0, Busy Time = 6267, Skip Channel = FALSE
    [ 2440.168034] Channel 2 : Dirty = 152, False CCA = 0, Busy Time = 4228, Skip Channel = FALSE
    [ 2440.176427] Channel 3 : Dirty = 176, False CCA = 0, Busy Time = 5831, Skip Channel = FALSE
    [ 2440.184821] Channel 4 : Dirty = 366, False CCA = 0, Busy Time = 6312, Skip Channel = FALSE
    [ 2440.193215] Channel 5 : Dirty = 192, False CCA = 0, Busy Time = 7106, Skip Channel = FALSE
    [ 2440.201624] Channel 6 : Dirty = 282, False CCA = 0, Busy Time = 12547, Skip Channel = FALSE
    [ 2440.210109] Channel 7 : Dirty = 160, False CCA = 0, Busy Time = 8690, Skip Channel = FALSE
    [ 2440.218487] Channel 8 : Dirty = 136, False CCA = 0, Busy Time = 5071, Skip Channel = FALSE
    [ 2440.226882] Channel 9 : Dirty = 48, False CCA = 0, Busy Time = 4535, Skip Channel = FALSE
    [ 2440.235189] Channel 10 : Dirty = 40, False CCA = 0, Busy Time = 7257, Skip Channel = FALSE
    [ 2440.243587] Channel 11 : Dirty = 0, False CCA = 0, Busy Time = 5416, Skip Channel = FALSE
    [ 2440.251885] =====================================================
    [ 2440.258062] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 11
    [ 2440.266890] Min Dirty = 0
    [ 2440.269553] ExChannel = 0 , 0
    [ 2440.272558] BW        = 20
    [ 2440.781649] br-wlan: port 2(ra0) entered forwarding state
    [ 2440.787205] br-wlan: port 2(ra0) entered forwarding state
    [ 2442.779429] br-wlan: port 2(ra0) entered forwarding state
    setting apcli
    root@Omega-76EB:/#
    
    
    root@Omega-76EB:/# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    

    Gutter ball!

    Is anyone from Onion watching this thread? I want to help diagnose this problem but all we have so far in this thread is conjecture.



  • I feel your pain. I'm in a similar situation.

    Onion will connect to:
    Apple Airport Extreme with no security

    Onion won't connect to:
    Apple Airport Extreme with any kind of security
    Cox-supplied home wifi router with WPA
    Commercial-grade wifi at work with security
    Commercial-grade wifi at work with no security
    Random Netgear router I have laying around

    Every time someone brings up this problem, the answer is always more questions: "Does the SSID have any special characters? Are you using any special characters in the password?"

    How about this for an answer: It doesn't matter! If my laptop can connect to a wifi signal, I expect the Onion to connect to the signal, too. Clearly one is correctly following the specifications (the laptop) and one is not (the Onion).

    I can only hope this is going to be fixed in the next firmware release, like the SD Card fiasco. Though even that isn't 100% yet.

    And while they're at it, how about fixing this terrible forum software? Until just this week it would crash Safari on even a very powerful Mac. It's still not possible to reply to messages on an iPhone because the textarea is larger than the screen. I know Chrome is all the rage among the nerds these days, but you know what else is pretty cool? Usability. Cross-browser compatibility. Testing.

    If I built a web site like this at work, I'd be fired.



  • @WayneL said in Can't connect to wifi - driving me insane.:

    And while they're at it, how about fixing this terrible forum software? Until just this week it would crash Safari on even a very powerful Mac. It's still not possible to reply to messages on an iPhone because the textarea is larger than the screen. I know Chrome is all the rage among the nerds these days, but you know what else is pretty cool? Usability. Cross-browser compatibility. Testing.
    If I built a web site like this at work, I'd be fired.

    This is a tool from nodebb if you do research there you might could do in the "water cooler" category a new request and maybe help that we get a better configuration to use it also with a mobile device.

    Btw. we as clients to have the choice, look for better products and companies or hep them to get better ;-)



  • On the bright side, some of us can connect.
    I have had no issues connecting my Omega2+ to my AES encrypted WiFi network that uses an ASUS RT-AC66U running asuswrt-Merlin 380.63.
    My WPA Pre-Shared key is 8 characters, all alpha.

    What router firmware and version are you running, please?



  • @Martin-Wiedmeyer I'm glad yours works. Mine doesn't. It's hard not to be a little irritated with the fact that I kickstarted a fancy paperweight. That said, I want to help diagnose whatever has gone wrong so that it can be fixed and can be used.



  • @dr_jkl You may want to answer my questions.
    What router firmware and version are you running, please?
    Have you done any packet captures to see where the authentication negotiation fails?



  • @Martin-Wiedmeyer Further up the thread has the info; Microtik CRS109-8G-1S-2HnD - it's running the latest firmware. I hadn't thought of the packet capture because I'm not sure anything is actually negotiating, but let me try it and see.



  • @Martin-Wiedmeyer As far as I am able to tell, it doesn't even try associating. I am going to investigate further when everyone else goes to sleep :)


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.