TFT screen via SPI not working



  • Hi,
    I have a Omega 2+ running the latest firmware and am using it with an Expansion Dock. I wanted to see if I could connect an Adafruit TFT screen via SPI. I tried following the SPI instructions in the wiki but couldn't make it work. Here are the details:

    Pin connections:
    TFT -> Expansion Dock (Omega2+)
    3-5V on TFT -> 5V pin
    GND on TFT -> GND
    CLK on TFT -> Pin7 on dock
    MISO -> Pin 9 on Dock
    MOSI -> Pin 8 on dock
    CS -> Pin 6 on dock
    Backlite pin connected to GND

    When I tried running:

    root@Omega-ABCD:/dev# spi-tool -b 32766 -d 1 write 0x12 0x42
    SPI Write to addr 0x12: 0x42
    > ERROR: could not open sysfs device '/dev/spidev1.32766'
    root@Omega-ABCD:/dev# ls /dev/spidev1.32766
    > ls: /dev/spidev1.32766: No such file or directory

    root@Omega-ABCD:/dev# ls spidev32766.1
    > spidev32766.1

    It seems that the -b and -d arguments were swapped in the spi-tool, so I tried by swapping them in the command.

    root@Omega-ABCD:/dev# spi-tool -b 1 -d 32766 write 0x12 0x42
    SPI Write to addr 0x12: 0x42

    Here, the write succeeded without any error, but nothing showed up on my TFT screen.

    I have two questions:

    1. Is there a bug where the spi-tool has it's arguments swapped because such a directory doesn't exist?
    2. Has anybody been able to connect such a display to Omega2+? Any suggestions about how to proceed from here?

    Any help would be really appreciated as I'm a beginner in this space.

    Device Firmware Version: 0.1.9 b149
    Checking latest version online...
    Repo Firmware Version: 0.1.9 b149
    Comparing version numbers
    Device firmware is up to date!



  • @at there are bugs in the SPI support - I suggest looking at this forum thread for background:

    https://community.onion.io/topic/1560/spi-pins-for-the-omega2/30

    The summary answer is: you probably should try @WereCatf 's firmware image.

    (However, I expect spi-tool write 0x12 0x42 to correctly send 0x12 0x42 to the device, so it might be something else)


Log in to reply