Omega2: can't connect to wifi after setup. How to debug?



  • Omega2+. I can set it up in the web or cmdline, but after it reboots, it still isn't on my wifi network. (I've checked the dhcp list and used nmap to look for port 22). Here's some of the details I've found while looking around. What's next? I'm using the breadboard dock, I assume this dock doesn't provide serial output, I don't see it on my osx/macos USB list (system_profiler SPUSBDataType).

       Ω-ware: 0.1.5 b130
    
    # wifisetup list
    { "results": [ { "ssid": "xxxx", "encryption": "WPA2PSK", "password": "yyyy" } ] }
    
    # uci show
    [...]
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='(default)'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-wwww'
    wireless.@wifi-iface[0].ApCliSsid='xxxxxxxx'
    wireless.@wifi-iface[0].ApCliPassWord='yyyyyyyy'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='xxxxxxxx'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='yyyyyyyy'


  • Nothing? I'd like to be able to use all my Onion hardware.



  • Does you SSID by chance have a hyphen - in the name or an overly long name? Those 2 things have been discussed here recently to having it not connect to wifi.

    Also, what is you network.config 'uci show network' listed as? Does your wifi support DHCP or fixed IP's? If it's not setup for DHCP it won't get an IP address even though it see's it. Lots to try and test but not sure what you've already tried.



  • @Ted-Timmons

    According to your uci show

    wireless.@wifi-iface[0].ApCliEnable='0'
    You simply disabled Omega's Wifi client.

    What about Omega's Wifi AP?
    wireless.ra0.disabled='1' means the AP (more exactly the whole Wifi system) is disabled
    wireless.ra0.disabled='0' means the AP is enabled

    You can debug and / or correct this with a serial terminal (for example via a 3.3V logic level serial to USB adapter).



  • @Ted-Timmons
    A Factory Restore should bring back the default AP
    if your Omega's Wifi is misconfigured only
    if only the Wifi is misconfigured. ( Maybe it's much clearer.:thinking: )



  • @Richard-Berg said in Omega2: can't connect to wifi after setup. How to debug?:

    Does you SSID by chance have a hyphen - in the name or an overly long name? Those 2 things have been discussed here recently to having it not connect to wifi.

    hyphen, yes. Is there a fix/workaround? (besides renaming my network)



  • @György-Farkas said in Omega2: can't connect to wifi after setup. How to debug?:

    @Ted-Timmons

    According to your uci show

    wireless.@wifi-iface[0].ApCliEnable='0'
    You simply disabled Omega's Wifi client.

    What about Omega's Wifi AP?
    wireless.ra0.disabled='1' means the AP (more exactly the whole Wifi system) is disabled
    wireless.ra0.disabled='0' means the AP is enabled

    I did a factory restore, disabled=0, at least now. Presumably it's been that way because I can't connect to it over serial/USB anyhow.

    As I said, I did a factory restore, then did a setup to a network without a hyphen. I notice the wireless.@wifi-iface[0].Ap* entries are added by wifisetup; it also creates the wireless.@wifi-config[0]* entries. Those don't connect, though- I've tried rebooting and checking both ifconfig and route to see.

    Finally, I tried adding device ra0 to the wifi-config, it didn't make a difference.

    # wifisetup info
    { "success": false }
    
    # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    
    # uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0.2'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    
    # uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-4242'
    wireless.@wifi-iface[0].ApCliSsid='networkname'
    wireless.@wifi-iface[0].ApCliPassWord='networkname'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='networkname'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='networkpass'
    
    


  • Next step: changed wifi-iface.ApCliEnable to 1. No change.

    set the debug flag in wifisetup, reran. Output:

    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "networkname"
    wwan network is set up... false,
    ran out of configured networks... no station available
    Wifi manager finished
    


  • Created a network with a hidden SSID, no auth. Manually configured it in config/wireless. No dice. What's notable is zero packets are received with any of these failures:

    eth0.2    Link encap:Ethernet  HWaddr 40:A3:6B:C0:42:42
              inet6 addr: fe80::42a3:6bff:fec0:4242/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:13848 (13.5 KiB)
    

    My router is on channel 1, fwiw.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.