First start. Strange behavior. DOA?



  • The fact that case (1) showed up means you have a marginal power supply.
    You need to have a power supply that can truly deliver 250mA and handle transient/surge demand well.
    (Don't read just the simple spec. That's where people got fooled.)
    Under this situation, anything can happen...

    ccs_hello



  • That doesn't quite explain why using the recommended lm1117 and even higher rated regulators (with and without caps) didn't boot the Omega correctly.
    Only after I connected the serial converter to the Omega it booted correctly and I could finish the setup.

    After that i had to remove the serial converter to get it past "[ 16.965024] EEPROM:Read from [factory] offset 0x0,length 0x400."
    and get the AP back.

    Now all is working fine with the same power supply I used before it all worked.



  • In state (2) / case (2), how did the USB-serial converter connects to Omega 2+?
    Is it three-wire (Rx, Tc, and Gnd) or 4-wire (Rx, Tx, Gnd, and Vcc)?

    Also pls show in details how your lm1117 based circuitry supplies power to the Omega2+ board.
    (Wire gauge, wire length, filtering capacitors adjacency to the regulator IC, board layout/fly-wiring, etc.)

    Power supply design is a serious business, especially for a picky board as Omega 2+ is.

    ccs_hello



  • OK I only found this post as I have a similar issue .. I will hook up a serial connection to see what I get and see if my LED on for about 20 seconds then off problem gets fixed :D (I hope so)



  • @ccs-hello

    USB-serial connected via (Three wire) Tx, Rx, and Gnd.

    The lm1117 based circuitry is created on a standard breadboard.
    Filtering caps, started with 10uf both sides.
    Increased output cap to 22uf and later 47uf.
    Input voltage: 9v 1A, 12v 2A.
    Using 24 AWG Dupont wires 20cm length to connect it all.

    I am aware the Omega is very picky about the power supply, this setup must be more than enough to power the Omega.

    To me it looked like the USB-serial converter triggered something enabling the AP for first setup.
    After i removed the converter to get past the EEPROM:Read from [factory] offset 0x0,length 0x400. part, all works like it should.

    I can now boot with or without the converter, AP working, Busybox, Connect to cloud etc.

    @Jae-Turner Using the serial connection will surely help you to see what is happening while booting.
    Make sure you use a good 3.3v supply capable of delivering the required/recommended power. I hope you get it working.
    If you do, please tell us here how you got it working.

    https://community.onion.io/topic/1082/help-omega2-not-working/32 here you can find people with similar issues and solutions.



  • re: power supply
    I would suspect the
    (A) 24 AWG (multi-stranded) wire (<-- length 20 cm in both positive and negative feed, totaling 40 cm) with Dupont connector
    (B) via Breadboard as the means for power feed.

    ccs_hello



  • @ccs-hello It is connected the same way as described in the Omega2 manual and which Onion recommends.

    Unfortunately, I can't test if this will solve the problem because mine is (fortunate for me) working now.
    Maybe other people with the same issue can try using shorter wires or even create a simple PCB with the lm1117, getting rid of the breadboard.

    Anyway, thanks @css-hello for helping out.



  • A failure/reboot at that point, which is just before the wifi typically performs a high power operation, almost always means a power problem.

    Note that sufficient power is not only about the regulator, filter capacitors, and wiring downstream of it but also about whatever is feeding the regulator, and especially how that responds to the sudden near-doubling of load when the wifi does certain things.

    I have a "2 amp" supply here which worked fine for other embedded wifi systems, but seems incapable of reliably running MT7688 boards. I have others rated less than that which work fine.

    It really matters more how something actually behaves, especially in its time-domain response to a pulse load, than what it says on a space-constrained label.



  • Alright, guys thanks for the fast feedback.

    I hope people with this problem will check their power supply first and get their Omega running.

    Happy Inventing


Log in to reply