Ruby gems that require building native extensions



  • I'm writing all my scripts in Ruby and it's working great so far, except I can't use any gem that requires to build native extensions such as sqlite3 or nokogiri.

    I can't see any easy way for now (installing gcc by recompiling OpenWrt, finding ruby-dev, libsqlite3-dev packages for OpenWrt...), so I'd be glad if anyone had an easier solution!

    It would be great to be able to run Sinatra apps on my Omega.

    Thanks!



  • I need to do the same for Python. I guess there will be some cross compiling involved.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.