wifi disconnect



  • Hello,

    i'm in trouble with wifi.

    i use omega2+
    I have setup access point also.
    My Omega connects to my internet box using WPA2.
    But after some time it loses the connexion and does not reconnect automatically.
    Then the only way to connect to the omega is using the access point address provided by the omega. pc connects to it and then i can use ssh to get to 192.168.3.1 .
    I do not know if it is due to the box or to the omega but i would like to investigate. I will use SSH.
    By the same time a Raspberry Pi is connect to the same box and does not feature this problem.
    What linux commands could i use to get info of the status the omega is when it is disconnected and does not recover.
    Generally: what is the system used to reconnect when a connexion drops (due to disturbance or whatever) and the omega reconnects ?(so i can check if it is working properly) What process is involved etc.

    Thanks for your help



  • First of all, for an investigation you and we need facts. So versions of your OS and some more info about your config would be great.

    I propose read request where users solved with success their WIFI problem. Here an example:
    http://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/30

    To debug you need the Terminal (linux & OSx) and commands as ping and traceroute to see if device is online and over which device you are connected. Windows users use ping and tracert instead.

    On a mobile device you install best a WIFI scanner and check the Chanel settings. If needed deactivate on omega AP mode and just use the fix connection over you Internet box. Important is that you use fix channel settings instead of auto. So you have control over the channels and you can avoid wifi interference with other devices.

    You should not compare pears with apples ... omega and raspberry are not in the same class of quality.

    @onion sorry to say that ... raspberrypi.org is a much bigger community and also playing better the FOSS rules.



  • @Luciano-S. said in wifi disconnect:

    If needed deactivate on omega AP mode and just use the fix connection over you Internet box. Important is that you use fix channel settings instead of auto. So you have control over the channels and you can avoid wifi interference with other devices.

    What does it mean exactly? How could I do this?



  • @György-Farkas
    I guess he's referring to the Ethernet-port expansion "https://onion.io/store/ethernet-expansion/". Adding this module is giving you a 10/100 M Ethernet port and the possibility to connect your Omega2 to your home switch.
    I don't know how this works but it cuts short all Omega2 charms. I mean the WIFI connectivity. For the cumulated price better get a Raspberry PI which has the Ethernet port plus 4 USB ports plus the WIFI connectivity plus a very stable and reliable OS.



  • @Papy-Muzo said in wifi disconnect:

    I guess he's referring to the Ethernet-port expansion "https://onion.io/store/ethernet-expansion/".

    Please stop to guess. I was referring to my experience i made with Omega in general. With the omega1 series i remember it was possible. When then the Hardware changes you better not should crucify the community members who answer you. And there are still the LEDE Images where offer a alternative driver (i propose to read a bit more members request/answers especially those as @luz and some who have more than 12 month of membership).

    Remembering you, that we also had disappointment somehow (hardware/missing info's) and specially with new once who just come complaining , if you not give a report of your situation (OS version, what you already tried and most important not offend in your first requests) you might will find some willing persons to answer you!

    alt text

    So, don't be silly and cut your last branch of support off :-)



  • @Luciano-S.
    I didn't know "guessing" will offend you... And, I do not need support. I need solutions !
    Ciao.



  • @Papy-Muzo it is not just that what i quoted ... i did read all your request ... and four are not a lot ... sorry

    (p.s. 5 in the meantime ... and just blabla)



  • @Luciano-S.
    Ragazzo, sei ubriaco!



  • @Papy-Muzo said in wifi disconnect:

    @Luciano-S.
    Ragazzo, sei ubriaco!

    Not really, I just answered you the same way as you answered in your second post!

    @Papy-Muzo said in Omega2, yet another dud.:

    Just some "bla-bla's" like yours above.

    As the owner of the request asked for commands to investigate his problem you should give him the chance to do do so and let him give feedback here.

    Now he has 3 Options:

    1. Using as it is and find out the disconnection (I'm almost sure it is just a power issue)

    2. The LEDE image.

    3. The Ethernet Dock, thx to point this out ... but let him decide if it suits to his needs.



  • hello,

    ping gives nothing as omega is not connected to the box. Nor does tracert, obviously.
    My config below.

    Looks like if i reboot the internet box omega does not reconnect back to the network automatically , un less i reboot it or take a manual action.
    I believe there is a deamon that takes care of reconnecting when the wifi network disappears. How to check its status/output ?

    Config:
    i use: omega 2+, hw: 0.1.10, sw: b160
    internet box |<== wifi link ==> Omega (192.168.0.12)
    |
    | <== wifi link ==> windows pc (..0.15)


    Ω-ware: 0.1.10 b160

    root@Omega-4BC1:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='33333333'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ApCliSsid='SFR-c3c0'
    wireless.@wifi-iface[0].ApCliPassWord='blablablabla'
    wireless.@wifi-iface[0].ssid='Omega-4BD1'
    wireless.@wifi-iface[0].ApCliEnable='1'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='SFR-c3c0'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='blablablabla'
    root@Omega-4BC1:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='ffff:ffff:ffff::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0.2'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'

    root@Omega-4BC1:~# wifisetup list
    {

        "results": [
    

    {

        "ssid": "SFR-c2c0",
        "encryption": "WPA2PSK",
        "password": "blablablabla"
    

    }
    ]
    }

    root@Omega-4BC1:~# cat /etc/config/wireless

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '333333333'
    option ApCliAuthMode 'WPA2PSK'
    option ApCliEncrypType 'AES'
    option ApCliSsid 'SFR-c3c0'
    option ApCliPassWord 'BLABLABLABLA'
    option ssid 'Omega-4BC1'
    option ApCliEnable '1'

    config wifi-config
    option ssid 'SFR-c2c0'
    option encryption 'WPA2PSK'
    option key 'BLABLABLABLA



  • @magouero said in wifi disconnect:

    root@Omega-4BC1:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='33333333'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ApCliSsid='SFR-c3c0'
    wireless.@wifi-iface[0].ApCliPassWord='blablablabla'
    wireless.@wifi-iface[0].ssid='Omega-4BD1'
    wireless.@wifi-iface[0].ApCliEnable='1'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='SFR-c3c0'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='blablablabla'

    root@Omega-4BC1:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='ffff:ffff:ffff::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0.2'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'

    root@Omega-4BC1:~# wifisetup list
    {

        "results": [
    

    {

        "ssid": "SFR-c2c0",
        "encryption": "WPA2PSK",
        "password": "blablablabla"
    

    }
    ]
    }

    root@Omega-4BC1:~# cat /etc/config/wireless

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '333333333'
    option ApCliAuthMode 'WPA2PSK'
    option ApCliEncrypType 'AES'
    option ApCliSsid 'SFR-c3c0'
    option ApCliPassWord 'BLABLABLABLA'
    option ssid 'Omega-4BC1'
    option ApCliEnable '1'

    config wifi-config
    option ssid 'SFR-c2c0'
    option encryption 'WPA2PSK'
    option key 'BLABLABLABLA

    I also have an Omega2+ with FW v0.1.10-b160 (although I have a strange Wifi problem) my Wifi connection is working well.

    The SSID of my internet gateway is DIGI-abcd vs instead of SFR-c2c0 (or SFR-c3c0 ???) so

    option ApCliSsid 'DIGI-abcd'
    option ssid 'DIGI-abcd'

    There is one more difference :

    network.wan.ifname='eth0'

    root@Omega-5BE1:~# cat /etc/config/network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option proto 'dhcp'
    

    If I were you, I would try to make a factory reset/restore and set the Wifi again by hand with wifisetup select option 2 (ssh of course, connecting to 192.168.3.1).

    Good luck!



  • @magouero said in wifi disconnect:

    Looks like if i reboot the internet box omega does not reconnect back to the network automatically , un less i reboot it or take a manual action.

    Confirmed.

    I read your first and last posts more carefully again and switched off - on my internet gateway.You are right - the Wifi client of my Omege2+ does not connect back automatically to its Wifi AP the configured network(s).
    I am not too happy.

    Is it a bug or a feature? that is the question...



  • @György-Farkas

    Köszönöm. :)
    As i am a bit paranoid i modified some fields . I made some mistakes. That is why you can notice differences like c2c0 / c2c0.

    Regarding eth0 i compared your result to "cat /etc/config/network" with mine.
    The only difference is:
    "config interface 'wan'
    option ifname 'eth0.2' => here you have eth0
    option proto 'dhcp'
    "
    Do you know what this " .2 " means ?

    edit> i think i found the origin: the box has a lease time of 86400s (24h).
    So i think that when it changes the lease the clients (like the onion e.g.) must do something to reconnect and actually do not.
    where is this process buried... no idea.
    Any specialist around ?



  • @magouero said in wifi disconnect:

    @György-Farkas

    Köszönöm. :)

    Szívesen. :)

    The only difference is:
    "config interface 'wan'
    option ifname 'eth0.2' => here you have eth0
    option proto 'dhcp'
    "
    Do you know what this " .2 " means ?

    I don't know too much.
    eth0 is a physical network interface (a hardware device), eth0.1, eth0.2, ... are virtual network interfaces (not an existent hardware device but are linked to one).

    root@Omega-5BE1:~# ifconfig
    apcli0 Link encap:Ethernet HWaddr 42:A3:6B:00:5B:E1
    ...

    br-wlan Link encap:Ethernet HWaddr 40:A3:6B:C0:5B:E3
    ...

    eth0 Link encap:Ethernet HWaddr 40:A3:6B:C0:5B:E3
    Interrupt:5
    ...
    eth0.1 Link encap:Ethernet HWaddr 40:A3:6B:C0:5B:E3
    ...

    lo Link encap:Local Loopback
    ...

    ra0 Link encap:Ethernet HWaddr 40:A3:6B:C0:5B:E1
    Interrupt:6

    Do you have an Ethernet Expansion? Did you modify any network / firewall config files?


    It seems the DHCP client is working well on my almost "default" Omega2+ (Wifi AP 192.168.3.1, client 192.168.100.x connected to my Internet gateway).



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.