Omega 2+ Wifi Password Bug



  • I just got an Omega 2+ and found that I was not able to connect to my wireless router. I've flashed the latest firmware omega2p-v0.2.0-b185.bin through a USB flash drive and the serial interface. After some playing it seems that the Omega cannot connect to a router with a ',' character in the password. I've tried it on my router and my phone hotspot, both using WPA2PSK. I've also tried '!' and '%' and a few other special characters and it works fine, but it seems if there's a ',' anywhere in the password, it doesn't connect and just outputs 'Interface apcli0 link up! (WPA2PSK AES)' over and over. (I'm assuming that's wireless card repeatedly attempting to connect to the AP) I also tried configuring through the web interface and the 'wifisetup' command and I get the same results. I have network connectivity now after removing the ',' from my router password, but I don't think ',' should prevent me from connecting.



  • Confirmed!

    config wifi-config
            option ssid 'AndroidAP'
            option encryption 'WPA2PSK'
            option key 'asdf,1234'
    

    restart wifimanager

    root@Omega-DA13:~# [14039.837791] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [14040.420919] br-wlan: port 2(ra0) entered disabled state
    ...
    [14047.678198] br-wlan: port 2(ra0) entered forwarding state
    [14050.896652] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    [14054.955257] AP-Client: disconnected by peer
    [14054.959601] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [14056.914443] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    [14060.939042] AP-Client: disconnected by peer
    [14060.943307] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [14062.909769] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    [14066.930953] AP-Client: disconnected by peer
    [14066.935220] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [14069.903615] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    [14073.929080] AP-Client: disconnected by peer
    [14073.933346] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [14075.521450] br-wlan: port 2(ra0) entered disabled state
    [14077.804980] EEPROM:Read from [factory] offset 0x0,length 0x400.
    ...
    [14080.384626] =====================================================
    [14080.390812] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 2
    [14080.399553] Min Dirty = 196
    [14080.402386] ExChannel = 0 , 0
    [14080.405391] BW        = 20
    [14080.433610] br-wlan: port 2(ra0) entered forwarding state
    [14080.439191] br-wlan: port 2(ra0) entered forwarding state
    [14082.437829] br-wlan: port 2(ra0) entered forwarding state
    

    /etc/config/wireless

    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ssid 'Omega-DA13'
            option ApCliSsid 'AndroidAP'
            option ApCliPassWord 'asdf,1234'
            option ApCliEnable '0'
    config wifi-config
            option ssid 'AndroidAP'
            option encryption 'WPA2PSK'
            option key 'asdf,1234'
    

    Summary:

    Tries to connect to AndroidAP with an "," in the password, but fails.

    ApCli gets disabled after it fails.

    Allowed password chars for WPA2-PSK:

    abcdefghijklmnopqrstuvwxyz
    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    1234567890
    $@^`,|%;.~()/{}:?[]=-+_#!

    Suggestion:

    1. Have you made a ticket yet? Seems to be a problem we have no influence to.

    2. Just don't put an "," in the password and let it be.



  • @Fabian-Nydegger-0 I've removed the "," from my passwords for the time being and submitted a ticket, hopefully it'll be resolved in a future release. Thanks.



Looks like your connection to Community was lost, please wait while we try to reconnect.