Wireless not working unless Ethernet cable plugged in



  • Hi,

    i am using ethernet and wifi station mode together. Unfortunately the wireless connection stops working if ethernet cable is unplugged.
    Please have look at my network and firewall settings:

    root@Omega-DB4B:~# vim /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd1d:48c4:7633::/48'

    config interface 'wlan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.3.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config interface 'wan'
    option ifname 'eth0'
    option proto 'static'
    option hostname 'OnionOmega'
    option ipaddr '192.168.16.234'
    option netmask '255.255.255.0'
    option gateway '192.168.16.254'
    option dns '192.168.16.254'

    config interface 'wwan'
    option ifname 'apcli0'
    option proto 'static'
    option hostname 'OnionOmega'
    option ipaddr '192.168.16.235'
    option netmask '255.255.255.0'
    option gateway '192.168.16.254'
    option dns '192.168.16.254'

    root@Omega-DB4B:~# vim /etc/config/firewall

    config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option disable_ipv6 '1'

    config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'wlan'

    config zone
    option name 'wan'
    list network 'wwan'
    list network 'wan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option masq '1'
    option mtu_fix '1'

    config forwarding
    option src 'lan'
    option dest 'wan'

    config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

    config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

    config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

    config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

    config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

    config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

    config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

    config include
    option path '/etc/firewall.user'

    config rule
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

    config rule
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'



  • This problem only occurs if the ethernet is plugged during the boot-up and is removed later. The wireless connection connection stops working at this moment.

    If the ethernet cable is plugged after boot-up and is then removed, the wireless connection remains totally correct.

    This seems to be a FIRMWARE-BUG.



  • @Carst-Dan said in Wireless not working unless Ethernet cable plugged in:

    This problem only occurs if the ethernet is plugged during the boot-up and is removed later. The wireless connection connection stops working at this moment.

    If the ethernet cable is plugged after boot-up and is then removed, the wireless connection remains totally correct.

    This seems to be a FIRMWARE-BUG.

    Hi, which firmware version are you using ? (just for information).



  • Updated to 0.3.2 b218 two hours ago (Omega 2+). Problem remains. Additionally static ip network setup fails now. Worked with the delivery version.



  • @Carst-Dan said in Wireless not working unless Ethernet cable plugged in:

    Updated to 0.3.2 b218 two hours ago (Omega 2+). Problem remains. Additionally static ip network setup fails now. Worked with the delivery version.

    Yes, static IP setup fail from old versions, I need to setup gateway manually for internet access, see this post:

    http://community.onion.io/topic/3107/setting-dns-with-static-ip-config

    I'm using firmware 0.3.2 b217 (Omega2+).


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.