Omega is unresponsive over WiFi network



  • I have been able to upgrade my Omega to firmware v0.0.8 b297. The Omega is successfully connected to my WiFi network. However, I cannot access the console from my computer. I'm on a Mac using Chrome, and when I try to access the Omega via its IP address, the request always times out.

    I am, however, able to access the console by connecting to the Omega's own network (Omega-2007) and visiting 192.168.3.1.

    Here's the output of the relevant config files.

    cat /etc/config/wireless
    
    config wifi-device 'radio0'
            option type 'mac80211'
            option hwmode '11g'
            option path 'platform/ar933x_wmac'
            option htmode 'HT20'
            option disabled '0'
            option channel '9'
            option txpower '30'
            option country 'US'
    
    config wifi-iface
            option device 'radio0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'none'
            option ssid 'Omega-2007'
    
    config wifi-iface
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option ssid 'BTHub3-Z4RJ'
            option encryption 'psk2'
            option disabled '0'
            option key 'xxxxxxxxxx' //password removed 
    

    And this one

    cat /etc/config/network
    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
    
    #config globals 'globals'
    #   option ula_prefix 'fd28:1f13:5b38::/48'
    
    #config interface 'lan'
    #   option ifname 'eth0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    
    #config interface 'wan'
    #   option ifname 'eth0'
    #   option proto 'dhcp'
    
    #config interface 'wan6'
    #   option ifname '@wan'
    #   option proto 'dhcpv6'
    
    #config switch
    #   option name 'switch0'
    #   option reset '1'
    #   option enable_vlan '1'
    
    #config switch_vlan
    #   option device 'switch0'
    #   option vlan '1'
    #   option ports '0 1 3'
    
    config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
    
    config interface 'wlan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
    
    
    #config interface 'wlan'
    #   option ifname 'wlan0-1 wlan0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    

    And the output of a wifi restart:

    wifi
    root@Omega-2007:/# [ 1475.980000] wlan0: deauthenticating from 64:a5:c3:6b:7a:f4 by local choice (Reason: 3=DEAUTH_LEAVING)
    [ 1477.200000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
    [ 1477.470000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1478.920000] wlan0: authenticate with 64:a5:c3:6b:7a:f4
    [ 1478.930000] wlan0: send auth to 64:a5:c3:6b:7a:f4 (try 1/3)
    [ 1478.940000] wlan0: authenticated
    [ 1478.960000] wlan0: associate with 64:a5:c3:6b:7a:f4 (try 1/3)
    [ 1478.960000] wlan0: RX AssocResp from 64:a5:c3:6b:7a:f4 (capab=0x1411 status=0 aid=8)
    [ 1478.970000] wlan0: associated
    [ 1478.970000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1479.000000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
    [ 1479.020000] wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by 64:a5:c3:6b:7a:f4
    

    Any ideas? :-)


  • administrators

    @Beejay-Morgan Can you run ifconfig and post the output?



  • ifconfig
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:16 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1621 (1.5 KiB)  TX bytes:1621 (1.5 KiB)
    
    wlan0     Link encap:Ethernet  HWaddr 40:A3:6B:C1:20:08  
              inet addr:192.168.1.16  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::42a3:6bff:fec1:2008/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:162 errors:0 dropped:0 overruns:0 frame:0
              TX packets:194 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:14509 (14.1 KiB)  TX bytes:25028 (24.4 KiB)
    
    wlan0-1   Link encap:Ethernet  HWaddr 42:A3:6B:C1:20:08  
              inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fe80::40a3:6bff:fec1:2008/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:7903 (7.7 KiB)
    

  • administrators

    @Beejay-Morgan The Omega is trying to test the the internet connection against one of the Onion servers during the WiFi setup process. It may take longer than expected. You can safely skip that step by pressing Ctrl-c after seeing

    [ 1478.970000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1479.000000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
    


  • Even pressing ctrl+c after the links have become ready doesn't fix it. The request to 192.168.1.16 still times out.

    Outgoing requests seem to work fine. The package manager can do its job, and pinging an outside server works fine. I just can't access the console from another computer through the non-ap interface.



  • It seems ssh times out as well.


  • administrators

    @Beejay-Morgan That's odd, the Omega seems to be able to connect to the internet at large but cannot be accessed from your local network. Maybe your network is restrictive about device-to-device communication?

    Can you try it out on another wifi network?



  • Sure, I'll try to remember to try it somewhere else. Incidentally, I can access my computer's Apache web server from any other device on the network.

    I am using an Apple Airport Extreme. Would the fact that some of my devices are using the 5GHz spectrum be an issue? Is there a compatibility issue there somewhere? I can't imagine that would make a difference.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.