AP WPA2 configuration fails through webinterface



  • I'm trying to setup WPA2 on the access point.
    In the "Wi-Fi Access Point Setup" I filled out all settings, selected configure AP and rebooted.

    Changes made to the ssid become effective but the wifi remains unsecured.

    in /etc/config/wireless I find

    config wifi-iface
    option device 'radio0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'none'
    option ssid 'my-omega-ssid'

    Tried with chome but there the webinterface shows no values at all on "Wi-Fi Access Point Setup" page, all fields including the enable flag are empty. I know wifi ap is working because I'm currently connected.

    Onion revision R1 , Firmware 0.1.1 (b308)
    Firefox 46.0.1
    Google Chrome 50.0.2661.102
    Windows 10



  • @Carl-Verbiest said in AP WPA2 configuration fails through webinterface:

    option encryption 'none'

    Did you try this to change in terminal (with nano/vi) and write option encryption 'wpa2' there instaed and save it?

    I believe there is something messed up with the user-rights for the httpd. So when you try to read the file with the Browser it can not access the file and it keeps blank.

    If you not have a very special installation i propose you to factory reset the Onion and actualize it again. I had similar difficulties with saving the encryption. In my case i could see the data and change it (in the web-gui), but after reboot it was reset again.



  • @Carl-Verbiest I too came across this while the console showed PSK2 the configuration file showed 'none' and if memory serves modified the config file by adding 'psk2', saved and reboot and the file came back with 'none'. Unfortunately it, somewhere along the line it was ok. Go figure. Sounds to me like a tiny bug in the way this is handled.



  • @Luciano-S. Thanks for the tip, I'll try that but I think it should work from the web interface as well.

    What I find strange is that a change in ssid works but a change in security doesn't.
    I changed both at the same time.

    I tried it and now the access point disappeared, , I hope a factory reset will get me back on the ap.



  • A factory reset gave me access again.
    I manually changed the wireless config to

    config wifi-iface
    option device 'radio0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '*******************'
    option ssid 'XXX-Omega-wxyz'

    and now it's working.



  • In my situation i could reuse the webgui again after factory reset.
    Did you try if it works for y ou now to? Change back to no pw and verify if it keeps the value after reboot.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.