"Could not connect to Onion Firmware Server!"



  • I am unable to update my firmware no matter how many times I try. It just cannot connect to the firmware server.

    *My internet connection is fine though.

    0_1467734028555_Screen Shot 2016-07-05 at 9.28.40 PM.png


  • administrators

    @pewpewlasers That's super odd!
    I've installed your exact firmware version on an Omega here at the office and it works as expected:

    root@Omega-267F:~# oupgrade -check
    > Device Firmware Version: 0.0.6 b266
    > Checking latest version online...
    > Repo Firmware Version: 0.1.3 b328
    > Comparing version numbers
    > New firmware version available, need to upgrade device firmware
    

    Can you please try again? If it still doesn't work, we'll go about manually updating the firmware.



  • @Lazar-Demin sorry for the late response. It still doesn't work not matter how many times I have tried. How do I upgrade manually?


  • administrators

    @pewpewlasers ok, let's do it manually then.
    Connect to your Omega via SSH or serial:

    cd /tmp
    wget http://repo.onion.io/omega/images/omega-v0.1.4-b330.bin
    

    When the download completes, run:

    sysupgrade omega-v0.1.4-b330.bin
    

    The Omega will start the update process and will reboot.
    Make sure to not reset or unplug it during the update process!

    Let me know how it goes!



  • @Lazar-Demin I had exactly the same issue with one omega which I did not upgraded for a while. It was firmware 0.0.4.

    wget and sysupgrade worked without problem.



  • It's been some time since I've played with my Omegas. I too was having this exact issue. Doing it manually using Lazar's steps solved this problem.



  • @Lazar-Demin Thank you for helping. I've tried this as well however. I get the following response:
    wget: unable to resolve host address 'repo.onion.io'



  • Mine downloads but will not run sysupgrade. It gives an error of "platform check image failed" Seeing that this thread started 10 months ago, what is the current firmware version to get?



  • these instructions have been somewhat updated since the new omega2/2+
    https://docs.onion.io/omega2-docs/manual-firmware-installation.html



  • I got the firmware to upgrade. Even after the upgrade it still will not use oupgrade. I also cannot seem to use the console. All it will give me is the setup page, which I have already done, although there seems to be no way to exit except to close the browser.



  • Sooooo, apparently running setup for the 10th time did the trick and console is now up.