opkg update



  • I just upgraded the firmware to the latest build (oupgrade -force) , but opkg update fails since then.
    This is what I get:

    root@Omega-28B0:/# opkg update
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/Packages.sig.
    Signature check passed.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/Packages.sig.
    Signature check failed.
    Remove wrong Signature file.
    

    Plus, I cannot connect to the console anymore



  • Hi @rahel, this problem exists because the firmware on the Omega are compiled by us here at Onion, so the signature generated during the compilation is different from the signature stored in the Opkg repo server. We will be launching our own repo servers in the coming weeks. For the time being, you just need to change your configuration to fix the issue:

    Open /etc/opkg.conf

    delete the line that reads option check_signature 1

    Try opkg update again and the problem should be fixed.



  • You could also comment out the line with # so that you can enable it later.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.