Omega's Wifi Network not showing up.



  • I set up my Omega at my house earlier today and now I am at work trying to connect to the Omega and it's wifi network is no longer showing up. I think it might have something to do with the fact that I am on a different wifi network now.

    Any ideas on what is going on?
    Additionally I was wondering if there is a way to factory reset the omega. I tried pressing and holding the button on the dock but that didn't seem to do the trick.



  • I tried this today. My Omega was running at my house, and I brought it into work to see if I could see the Omega wifi network. It does show up for me, so I'm not sure what is going on there.

    As for factory reset - I do not know a hardware way to do this, but if you have a terminal program ( if you are on a Mac I suggest Serial ), and connect via a USB cable, then you can type in the command:

    factory-reset -f

    Also if you connect via a terminal you can setup wifi that way, and it is very easy.

    I put together this video - I hope it helps.

    https://www.youtube.com/watch?v=F3H25qRR7Lo



  • Hi @Luis-Johannes-Schubert, if you can use serial terminal to access the Omega, you can use the wifisetup command to reconnect your Omega to a different network. Alternatively, you can also manually edit the wireless configuration file at /etc/config/wireless with your latest Wi-Fi information. After you've saved the file, you should also run the wifi command to restart the Wi-Fi for the new network configuration to take effect.

    Please let me know if this works!



  • @Patrick-Ryan Thank you for that recommendation. I downloaded the Serial App, but realized that I have the wrong kind of usb cable... mine only supplies power to the Omega and I am not able to connect to it. I just ordered one from amazon so that I can do that in the future.
    In the mean time I managed to make a second one of my omegas unusable.
    I now have two Omegas whose Wifi doesn't show up for me anymore.
    @Boken-Lin Do you have any recommendations for connecting to the omegas? I tried using an ethernet cable with the Ethernet Expansion but failed to connect to it.
    Would appreciate some help because I only have two omegas left that I can connect to :P :-1: .

    @administrators on a related note is there a work around to connecting omegas to a WPA-2 Enterprise Network?



  • @Luis-Johannes-Schubert Can you post the content of your /etc/config/network configuration file? We will need to modify it to allow DHCP server to work on the ethernet port. This way you can directly connect the Omega to your computer via ethernet.

    Also, WPA enterprise will require the wpad package instead of the one currently installed, which is a stripped down version called wpad-mini. @faulty-lee has found some information here at http://superuser.com/questions/756438/openwrt-wpa2-enterprise-radius-config-is-not-applied and https://wiki.openwrt.org/doc/howto/wireless.utilities#hostapd-mini_and_wpad-mini. You basically need to run the following commands

    opkg update
    opkg remove wpad-mini
    opkg install wpad
    

    Cheers!



  • @Boken-Lin

    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
     
     
    config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
     
    config interface 'wlan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
    

    This is the content of my config file on the omega that does not have show up on wifi. I have left out the commented out lines.



  • I just deleted the wireless iface for the network that i had initially used to set up one of my omegas and it seems to be working fine again.



  • @Luis-Johannes-Schubert Oh yeah, the Omega has just one WiFi interface, but through software, it is able to create two virtual interfaces to serve an AP as well as connecting to a home router. However, the Access Point virtual interface can only be turned on under these two conditions:

    1. If the interface connecting to the home router is connected to the home router, or
    2. If the interface that connects to the home router is disabled.

    This means that if the interface is configured to connect to the home router, but is unable to connect (either due to wrong password or DHCP timeout, etc), the AP interface won't be active either. In this case, you simply need to disable that interface for the AP interface to be active again.



  • @Boken-Lin Thanks for the explanation. I had used the GUI initially to set things up and wasn't aware of what was going on under the hood.
    I have now completely switched to using CLI and was able to figure out the issue.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.