Omega 2 and Arduino dock.





  • Hi Michael,

    Yes, software installation wasn't an issue, my problem was fixed after pulling the power cord and plugging back in. After doing a sysupgrade it seems the arduino and omega got out of sync or something, totally pulling the power fixed the issue.



  • @Michael-Xie48 Yes I have, that's when I got that error.



  • hello guys

    i have a similar problem.
    with the old firmware i was able to upload sketches on the arduino.
    then i made the upgrade and like cusackph i was surprised that everything i've set-up before was gone :-(

    i made opkg install arduino-dock
    then the Arduino IDE sees the board under the list of boards.

    i was thinking that i have the ability to upload sketches back as before BUT
    now i have an error i never had before on flashing (right after putting the password)

    i also tried various press on MCU_reset button after password or plugin power off and on again .. but nothing changes

    alt text

    any toughts ?



  • OK my bad.
    i installed arduino-dock instead of arduino-dock-2 ...
    doing opkg remove arduino-dock and then opkg install arduino-dock-2 makes the flashing work again.

    the wiki should really inform beginners there are TWO different arduino packages



  • and today this does not work ....

    Flashing application '/tmp/sketch.hex' ...

    ERROR, flash NOT successful
    Flash complete!
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.

    avrdude done. Thank you.



  • im starting to be fed-up ....
    it worked yesterday with the latest firmware ...
    now after i did a factory reset i can't manage to upload any sketch.
    neither via Arduino last IDE nor manually.

    this is what manuel install does with arduino-dock 1st version and arduino-dock 2nd version ...
    alt text



  • how can avr-dude be "broken" ?

    i do "opkg remove" of everything related with arduino (dock1, dock2, avr-dude ..)
    i reboot the system.
    then i reinstall each of these ( pikcing of course only one of the 2 docks cause they can't be used in the same time, anyway mine is the _2)
    i reboot the system just to be sure ...

    Arduino IDE recognizes the board via WIFI, i can even inout the board PASSWORD ...
    but then this damn problem occurs.

    i suspect it's the communication between the Omega and the ATmega that is going crazy.
    What should i do ? should i downgrade to the firmware that had CLOUD registering broken ?
    cause with that plugin i COULD ACTUALLY upload sketches.

    i beg anyone to help, i'm starting to be fed-up with this.



  • any clue ? (up)



  • @frederic-raducki
    sometime I found my problem related to wifi, and yes, once I put it down it works but when I put it down again it won't work, I have tried not to touch it once it made connection, still works.. I am about 3 metres from the router which is a good distance.



  • @David-Wickenden said in Omega 2 and Arduino dock.:

    @frederic-raducki
    sometime I found my problem related to wifi, and yes, once I put it down it works but when I put it down again it won't work, I have tried not to touch it once it made connection, still works.. I am about 3 metres from the router which is a good distance.

    sure, thank for the suggestion but as you can see in screenshots higher: even a manual procedure with avr-dude fails :-(



  • Sketch uses 5042 bytes (15%) of program storage space. Maximum is 32256 bytes.
    Global variables use 199 bytes (9%) of dynamic memory, leaving 1849 bytes for local variables. Maximum is 2048 bytes.

    Flashing application '/tmp/sketch.hex' ...

    ERROR, flash NOT successful
    Flash complete!
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.

    avrdude done. Thank you.

    No luck :(



  • @rutayan-patro said in Omega 2 and Arduino dock.:

    Sketch uses 5042 bytes (15%) of program storage space. Maximum is 32256 bytes.
    Global variables use 199 bytes (9%) of dynamic memory, leaving 1849 bytes for local variables. Maximum is 2048 bytes.

    Flashing application '/tmp/sketch.hex' ...

    ERROR, flash NOT successful
    Flash complete!
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.

    avrdude done. Thank you.

    No luck :(

    you have the same error as me right ?
    i ordered another omega2 on indieGogo .. i hope that wen i receive it i will be able to compare if my 2nd still has the same issue ...
    for now i just dont use the Omega and i purchased a RaspberryPi3 to learn meanwhile i have a fix for Avrdude



  • @frederic-raducki I think buying another Omega 2 is a bad idea. I've got a support ticket open over a month ago and have yet to receive a response. It's been "Being Processed" for 31 days now. Giving these guys more money seems like a bad idea until they prove they can sort this stuff out.



  • @frederic-raducki @rutayan-patro have you ever managed to get around this problem?

    I am using arduino-dock (version 1) on Omega2+ and whenever I try to flash the bootloader I get AVR device not responding

    I'm using avrdude: Version 6.1, compiled on Feb 3 2017 at 01:12:05

    root@Omega:~# sh /usr/bin/arduino-dock flash bootloader
    > Flashing bootloader...
    
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.
    
    
    avrdude done.  Thank you.
    
    
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.
    
    
    avrdude done.  Thank you.
    
    > Done
    


  • @Venet said in Omega 2 and Arduino dock.:

    I am using arduino-dock (version 1) on Omega2+ and whenever I try to flash the bootloader I get AVR device not responding
    ...

    root@Omega:~# sh /usr/bin/arduino-dock flash bootloader
    > Flashing bootloader...
    
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
             Double check connections and try again, ...
    

    Yes, because those connections are really missing on the first version of Arduino Dock.
    Arduino Dock 2 has got an ICSP / ISP programming interface.
    So you should build something similar circuit to burn a bootloader into the ATmega of a version 1 Dock with Omega2.



  • Thanks @György-Farkas

    I'm new to arduino, so does this mean that I cannot use the arduino-dock (v.1) with Omega2+?

    Is there any way to access GPIO pins of Omega2+ through arduino-dock?



  • @Venet
    Unfortunately I have never seen - in reality - the version 1 Arduino Dock yet.
    The Onion's schematic seems to be correct, except the representation of the reset button (SW2 RESET BTN).

    So - according to that schematic - if you want to use Arduino Dock v1 with Omega2 you should

    • isolate pin_2 of Omega2 labeled 11 (ie. GPIO_11 / BOOTSTRAP_4) from its socket's pin
    • connect pin_2 of Omega's socket labeled VDD25 (ie. 2.5 V supply) to 3.3 V

    (The "barbaric" solution: cut PCB trace(s) of socket's pin_2 and tie all VDD25 labeled points to 3.3 V with wires.)

    I think this is the minimal mandatory modification.
    Is this resolvable? Can you do this?


    On version 1 dock Omega and the ATmega MCU can communicate via a serial connection and / or via I2C only.
    So Arduino can not access Omega's GPIO pins directly.



  • Task 2
    connect pin_2 of Omega's socket labeled VDD25 (ie. 2.5 V supply) to 3.3 V

    is unnecessary. Omega2's own Net_Power pin (2.5V) pin internally is open-circuit.

    This pin's original purpose is to supply DC bias for Ethernet magnetics (transformer) center tap.
    For MT7688, it's not needed.

    ccs_hello



  • @ccs-hello
    You are talking about Omega's pin 25 (NET_POW) on the right hand side.
    I am talking about Omega's pin 2 (VDD25) on the left hand side.
    In my previous post I only tried to write the very first steps about "How to use the first version of Arduino Dock with Omega2".
    See also this schematic please. ;)


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.