Newbie: Added files Vanish; Pkg installs vanish



    1. The amber led constant;y blinks
    2. When adding files or installing packages all look good. When I restart the Omega all items added are gone. Why am I not able to save my files?


  • Witch hardware do you use Omega1 , 2 or 2+ ?
    Have you made an update from the Firmware recently ?
    Witch Version do you use ?
    etc ...



  • I have the Omega2+
    O-ware: 0.1.9 b150
    was the last update I performed

    Thanks



  • After reading some other posts it appears the orange flashing LED on the module indicates the system is not read or not completely booted.
    If this is the case then there must be an update I am missing. I will research the update needed and see if this will help,



  • Well, now split in two threads... a merge would be nice.
    https://community.onion.io/topic/1481/losing-data-after-power-off



  • I have resolved my issues by resetting and reloading everything from the start.
    Amber LED is now solid when it completes the boot cycle.
    Pkgs and files loaded are now persistent.

    Now onto some development ...

    Many Thanks...



  • I am having the same issue. The orange led never stops flashing. What did you do to resolve it? What firmware, etc.?



  • Hi @Marty-Mickelson

    Even if the LED keeps blinking, you should be able to access the board. Type this:

    cat /sys/class/leds/onion\:amber\:system/trigger
    

    You should get an output like this:

    none mmc0 timer [default-on] netdev transient gpio heartbeat morse oneshot
    

    But probably it's [timer] the option selected. If so, just type:

    echo default-on > /sys/class/leds/onion\:amber\:system/trigger
    

    And reboot. Afterwards, the LED should stop blinking once the booting is completed. You can check again with the first line of code that the change is permanent, you should get [default-on].



  • @Iker Using the first line you suggested, I get this result:

    root@Omega-B1A3:~# cat /sys/class/leds/onion\:amber\:system/trigger
    cat: can't open '/sys/class/leds/onion:amber:system/trigger': No such file or directory
    

    Am I misunderstanding what you suggested?



  • I should make it clear that what seems like the bigger issue is that nothing stays installed. I added php and added the basic index.php so I could view it. It worked but when I turned it off and back on, I couldn't get it again. It was gone.



  • I found that on my system, it's

    cat /sys/class/leds/omega2p\:amber\:system/trigger
    

    And I get this:

    root@Omega-B1A3:/sys/class/leds# cat omega2p\:amber\:system/trigger
    none [timer] default-on netdev transient mmc0 gpio heartbeat morse oneshot
    

    So, I used this:

    echo default-on > /sys/class/leds/omega2p\:amber\:system/trigger
    

    After that, the amber light stays lit... until I turn it off and back on. It blinks continually again and I see that my change didn't stick.

    root@Omega-B1A3:~# cat /sys/class/leds/omega2p\:amber\:system/trigger
    none [timer] default-on netdev transient mmc0 gpio heartbeat morse oneshot
    

    This seems like a problem with the flash memory... :(



  • Hi @Marty-Mickelson

    Which firmware are you using? It seems odd to me being a different path for the LED, I should check mine.

    Don't panic about the files not being persistent, it happened the same to me. Download latest* firmware following this:https://docs.onion.io/omega2-docs/manual-firmware-installation.html

    Update with the -n flag.

    *For the latest firmware neither omega2-ctrl nor fast-gpio are working, take that into account. If you want that, a mid-december version has that enable but I can't remember which.



  • Settings in /sys/* whatever will not persist by design.

    These are not true "files" on a traditional filesystem but rather file-like constructs that give access to memory variables in the internal running state via the traditional unix "everything is a file" paradigm. (Similarly /tmp is a ramdisk - comparable in effect, though quite different in implementation details)

    If you want to have a particular state of these on boot, you'll need to put script or program operations to set them into the startup files, or else recompile the bootloader/kernel or at least device tree blob to initialize them with the desired state.



  • @Marty-Mickelson the command on an Omega2 is:
    cat /sys/class/leds/omega2:amber:system/trigger

    Dave



  • Thanks all, I went through the process again and now it's saving the console and other files.
    I think the problem may have been in my patience. When installing, I would restart it if there was a really long period of no feedback. I let it work longer this time during all the steps and saw it continue doing more stuff. It might be that I just couldn't expect it to work as fast as I thought.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.