Wifisetup connection issue



  • Description
    I am having an issue with the beginning of setting up the omega 2. I try to connect it to my wifi network, but it never connects. I have tried to use the web UI, but it always just says it can not connect. I have also tried to use the wifisetup utility, but that also does not connect.

    Things I have Tried:

    • Factory reset (Did not help)
    • Updated to latest firmware, 0.1.9 b152 (Did not help)
    • Created a guest network with no authentication required (Did not help)

    Additional Information

    • My wifi network uses WPA2-PSK (AES)
    • I am using the expansion dock for the original Omega

    wifisetup utility attempt
    BusyBox v1.26.2 () built-in shell (ash)


    / __ ___ ()_ ___ / __ __ _ ___ ___ ____ _
    / // / _ / / _ / _ \ / // / ' / -) _ / _/
    _
    /////_//// _////_/_, /_,/
    W H A T W I L L Y O U I N V E N T ? /
    __/

    Ω-ware: 0.1.9 b152

    root@Omega-0000:~# wifisetup
    Onion Omega Wifi Setup

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: 1
    Scanning for wifi networks...

    Select Wifi network:

    1. other
    2. other
    3. <MY SSID>
    4. other
    5. other

    Selection: 3
    Network: <MY SSID>
    Authentication type: WPA2PSK
    Enter password: <PASSWORD>

    Restarting wifimanager for changes to take effect

    /etc/config/wireless

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliAuthMode 'WPA2PSK'
    option ApCliEncrypType 'AES'
    option ssid 'Omega-0000'
    option ApCliSsid '<MY SSID>'
    option ApCliPassWord '<PASSWORD>'
    option ApCliEnable '1'

    config wifi-config
    option ssid '<MY SSID>'
    option encryption 'WPA2PSK'
    option key '<PASSWORD>'

    I would be grateful for any help anyone can offer.

    Thanks!



  • That's interesting. My config file has the following under the config wifi-config section

    config wifi-config
    option ssid 'GetLost'
    option key1 'my password'
    option encryption 'WPA2PSK'
    option key 'my password'

    The only difference with mine to yours is that mine has key1 and key.



  • Thanks for the reply,
    I tried modifying my config to include key and key1, but that didn't make a difference either.
    It is a really strange issue and unfortunately I can't find any place that describes how all of the configs are supposed to look. So I can't tell what has gone awry.



  • I have some more information that may help.
    I ran wifimanager -v and it said wwan is not set up.
    Here is the output:
    root@Omega-95DD:~# wifimanager -v
    radio0 is up
    Reading configured networks in station mode...
    "MY_SSID"

    Scanning nearby networks...
    found"OTHER_SSID"
    "OTHER_
    SSID"
    ""
    "OTHER_SSID"
    "OTHER_SSID"
    "OTHER_SSID"
    "OTHER_SSID"
    "MY_SSID"
    "OTHER_SSID"
    "OTHER_SSID"
    ""
    "OTHER_SSID"
    "OTHER_SSID"
    "OTHER_SSID"
    "OTHER_
    SSID"
    ""

    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "MY_SSID"
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    Wifi manager finished

    Hopefully someone can help. I am pretty lost here...


  • administrators

    Make sure you are on the latest firmware.

    try edit /etc/config/wireless
    remove everything other than

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'
    
    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ssid 'Omega-<your_omega_id>'
    
    

    restart your Omega and do wifisetup again



  • Okay, tried that, but still no luck.

    Here is what /etc/config/wireless looks like now:

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ssid 'Omega-0000'
    option ApCliSsid 'MY_SSD'
    option ApCliPassWord 'MY_PASSWORD'
    option ApCliAuthMode 'WPA2PSK'
    option ApCliEnable '0'

    config wifi-config
    option ssid 'MY_SSID'
    option encryption 'WPA2PSK'
    option key 'MY_PASSWORD'



  • This post is deleted!


  • @Thomas-Tramley
    Is it possible that the Omega2 is struggling to pick up your wireless network signal as opposed to your PC (which would be right beside it I'm guessing).
    I'm only posing that question as my Network router is at the other end of my house though it does have 4 antenna's so there there is plenty of signal.


  • administrators

    @Thomas-Tramley said in Wifisetup connection issue:

    option ApCliEnable '0'

    Are you sure the WiFi password is entered correctly? Looks like your Omega tried to connect and failed so it turned client mode off.

    can you change option ApCliEnable '0' to option ApCliEnable '1'
    save the file and run the command wifi then post the out put here



  • @Zheng-Han that didn't seem to help. After I followed those instructions it still couldn't connect. I ran ifconfig immediately after and I could see apcli0, but it did not have an ip address assigned.

    I tried a couple other things:

    • As per @Chris-Parker's recommendation, I tried moving the Omega 2 closer to the router. I was only about 15 feet away before, but that still didn't make a difference.
    • I checked the logs on my router and noticed that it encountered a dhcp error any time I tried to connect with the omega 2
    • I also tried setting up a mobile hotspot on my phone, but that didn't work either. It wouldn't even connect. (For that I used WPA2)

    If you guys have any more ideas I would be more than happy to try almost anything.



  • Hi to all. A had the same problem, but change the router password and set only alpha numeric password (without expecual characters) and the connection work. I don't know how but I expend a Lot of time trying to connect. i made a lot of test on the router (CISCO Linksys Smart WIFI EA2700) change bandwidth, wifi type, channels and does'nt work. The last test was change the password and works.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.