omega2+ shutdown every time I turn my mobile AP on



  • I am currently facing some wifi connection problem so I use different WIFI AP to test.

    I found that whenever I turn on my iphone AP and scan wifi with omega2+, it will hang and shutdown(SSH disconnect and LED turns off).

    My iphone AP name has special letter (actually a chinese word).



  • @sunny-lau said in omega2+ shutdown every time I turn my mobile AP on:

    I am currently facing some wifi connection problem so I use different WIFI AP to test.

    I found that whenever I turn on my iphone AP and scan wifi with omega2+, it will hang and shutdown(SSH disconnect and LED turns off).

    My iphone AP name has special letter (actually a chinese word).

    Will it reboot by itself or just "shutdown" and stay disconnected?



  • Standard troubleshooting procedure:

    1. use a different AP (with all English SSID) to verify Omega2 behaves normally.
    2. Change your iphone's softAP's SSID to all English, and verify.

    This hopefully can narrow down to identify the culprit.

    ccs_hello



  • @Marcin-Debowski

    it just shutdown and stay disconnected



  • @ccs-hello

    AP naming with all English characters(another device) can connect normally, except that it cannot scan the wifi of my home and therefore I need to use a mobile AP.



  • Probably Omega2 cannot handle SSID that is in unicode or UTF-8.
    Cannot handle is a minor bug/inconvenience feature,
    while would cause itself to crash seems to me would be a major bug.



  • Yep, agree, looks like a major bug, leading to a kernel panic or something similar.
    If you want to check it further (and have no access to the console), make the syslog (or whatever is used) to log kernel logs and perhaps other data to some non-volatile place.
    Alternatively, just stream the log to the ssh terminal (tail -f logfile) and maybe you will see some kernel messages before it crashes.
    Sorry, I can not be more specific, I don't have any Omega up and running at this moment and I am not sure how the syslog is configured on the Omegas.



  • @sunny-lau
    Thank you so much for this post, it gave me a new idea.
    I also have an unresolved Wifi issue and now I think the reason of my problem might be similar.

    BTW when you turn on that Iphone AP and try to scan Wifi with your Omega2+ you would see this on the serial console

    [ ...] Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8771d944
    [ ...]
    [ ...] Rebooting in 3 seconds..

    and after that your Omega2+ goes into a frozen state.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.