Omega-2 is defined by the router as Unknown



  • My Omega-2 is defined by the router as Unknown. Still on my Omega Mac address is written, its last character is "D", but in the router it is written "E".
    0_1526813747892_1.png



  • @CAP-33 did you connect the Omega2 via Ethernet?

    Because Ethernet needs its own MAC-Adress and that used to be the WiFi-MAC (which is on the package) plus 2. But you say it's only +1, maybe this has changed with the new firmware/WiFi driver version?

    The "Unknown" just means your router does now know the MA-M/OUI-28 40 A3 6B Cx xx xx belongs to Onion Corp.

    Routers usually know some OUI's and associated names of larger companies and can display it, but apparently Onion is too young or not big enough for your router to know it :-)



  • @CAP-33 (I suppose) your firmware is v0.2.0-bxxx and your sticker is 'MAC:40A36BC1D90D'
    @Lazar-Demin wrote about the MAC address(es) here New OS Release!.

    ifconfig | grep HWaddr

    apcli0    Link encap:Ethernet  HWaddr 40:A3:6B:C1:D9:0E  
    br-wlan   Link encap:Ethernet  HWaddr 40:A3:6B:C1:D9:0D  
    eth0      Link encap:Ethernet  HWaddr 40:A3:6B:C1:D9:0F  
    ra0       Link encap:Ethernet  HWaddr 40:A3:6B:C1:D9:0D
    

    The Omega2's WiFi client (WiFi station) doesn't have hostname because it's not required.
    udhcpc is the DHCP client on Omega2 and the hostname is an option:
    udhcpc --help



  • @luz I connect the Omega2 via Wi-Fi



  • @György-Farkas said in Omega-2 is defined by the router as Unknown:
    (I suppose) your firmware is v0.2.0-bxxx and your sticker is 'MAC:40A36BC1D90D'
    You're right.
    I realized that the host name for the DHCP client Omega 2 is not necessary, and, as I understand it, it can be changed. But did not understand how to do it.



  • @CAP-33 I think this is a relatively simple way:

    • Edit the '/etc/config/network' file.
      Add the option hostname 'your_client_hostname' line to the config interface 'wwan' section.
    # Omega2 v0.2.0 b186
    
    root@Omega-5533:~# cat /etc/config/network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
    #        option ifname 'eth0.1'
    #        option ifname 'ra0'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'your_client_hostname'
            option proto 'dhcp'
    
    • reboot

    Good luck!



  • @György-Farkas Thanks, all worked well!



  • @CAP-33 Great :-)
    Here you are a more elegant (and easily scriptable) way.

    Run the below mentioned commands either on the Serial Console or connect with ssh your Omega's AP (192.168.3.1 by default):

    # Omega2 v0.2.0 b186
    
    root@Omega-5533:~# uci set network.wwan.hostname='your_client_hostname'
    root@Omega-5533:~# uci commit network
    
    # Check the result (this is not mandatory of course):
    root@Omega-5533:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    network.wwan.hostname='your_client_hostname'
    
    # release (with USR2) the lease
    root@Omega-5533:~# kill -USR2 `pidof udhcpc`
    
    # renew (with USR1) the lease
    root@Omega-5533:~# kill -USR1 `pidof udhcpc`
    
    

    Good luck!


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.