I have installed a package, it says that it has installed fine but then I can only find the library files (*.so.*) and no headers (.h) ?



  • @Edward-Cheadle said:

    It looks like I have alot to learn and feeling a bit out of my depth.
    Presumably the firmware revision should match that on my board ?

    Take your time, but yes, it may seem a bit daunting at first. And there will be bouts of frustration. Ask questions, the community will help where we can, but we also don't know everything... ;-) We all learn from each other's mistakes.

    If you are new to this, then it will be best to get to the point where you can do a successful build i.e. run make to completion without any errors, before you start to introduce your own specific changes to the source. That way you will know that any errors are of your own making and not errors with the build environment and you will know where to focus to investigate and solve them.

    Regarding the firmware revision, it doesn't have to match what you currently have, any recent one should work on the O2Pro, but it's probably best to stick at one level until you are confident with what you are doing. Comments on the fixes/changes in each can be found in the CHANGELOG.md



  • I would add that it is a very good idea to familiarise yourself with the serial console. If you're building your own firmware you are very likely to make some mistakes which will disable your Omega, maybe even brick it. If you are already familiar with the use of the serial console and the recovery methods, you'll find it a lot less stressful.

    https://docs.onion.io/omega2-docs/connecting-to-the-omega-terminal.html#connecting-to-the-omega-terminal-serial

    You learn a lot more from your mistakes than if everything works perfectly everytime, you just have to prepare yourself.



  • @Janus-Sanders @cas

    Hi I've been stuck all day trying to set the container size either by increasing the container size limit: https://bobcares.com/blog/docker-container-size/
    or using the --storage-opt size=40G option.

    I haven't had any success and am guessing that there must be a simple way to do this that I haven't found ?



  • @Janus-Sanders Looking at this post on Stack Overflow
    https://stackoverflow.com/questions/52848004/how-to-increase-docker-disk-image-size-in-ubuntu
    it appears that there is no way and no need to increase the container size. BTW I'm running Ubuntu 18.04 with extfs filesystem. Hope this makes sense ?



  • @crispyoz Thanks - I've got serial console working so I have some option if I brick it :)



  • @Edward-Cheadle said:

    it appears that there is no way and no need to increase the container size. BTW I'm running Ubuntu 18.04 with extfs filesystem. Hope this makes sense ?

    Yes, that's correct, the container will grow in size dynamically as you build the sources.
    What you need to do is to ensure that you have sufficient space in your docker environment to accommodate (at least) a 30 or 40GB container. Apologies if that was unclear.



  • @cas Thanks - How do I do that; should I have added some option when I installed Docker ?



  • @Edward-Cheadle
    Make sure that the filesystem on which your docker environment is installed and where the container(s) are housed has plenty (>= 40GB in this context) of free space.

    eg. If docker's home is /var/lib/docker make sure that /var (or / if you don't have /var in its own filesystem) has lots of free space.



  • @cas Thanks Cas - I set up a new 120GB SSD specifically for this 'machine' so apart from the fresh install of Ubuntu there is nothing else on the disk - i can see docker in var/lib - so with the container resizing I should be fine.

    I got a successful compile of the image on my second attempt.

    However, when I try to compile the example code from:

    https://github.com/OnionIoT/c-cross-compile-example.git

    I get the following error

    make: /root/source/staging_dir/toolchain-mipsel_24kc_gcc-5.4.0_musl-1.1.16/bin/mipsel-openwrt-linux-gcc: Command not found

    I note that the git directory I cloned from hasn't been touched for 2 years so this example is likely out of date. When I look in /root/source/staging_dir/toolchain-mipsel_24kc_gcc-5.4.0_musl-1.1.16/ there is no bin directory. I found a bin directory with the mipsel-openwrt-linux-gcc in /root/source/staging_dir/toolchain-mipsel_24kc_gcc-7.3.0_musl but I have no idea what to edit to ensure that this file is used - it doesn't appear to be the makefile ?



  • @cas I figured this out for myself - sorry I should have just re read all instructions again in the first place.

    I changed the lines:

    "# define the toolchain and target names
    TOOLCHAIN_NAME="toolchain-mipsel_24kc_gcc-5.4.0_musl-1.1.16"
    TARGET_NAME="target-mipsel_24kc_musl-1.1.16"

    in xCompile.sh

    to :

    "# define the toolchain and target names
    TOOLCHAIN_NAME="toolchain-mipsel_24kc_gcc-7.3.0_musl"
    TARGET_NAME="target-mipsel_24kc_musl"

    and the example C gipoRead compiled fine and runs on my board.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.