Really Bad Lag



  • Anyone else get really bad lag on their Omegas? Fresh reset on my 2+, installed mjpeg-streamer (nothing else), and now I SSH in, type a command and have to wait 5s or so for it to catch up. Also if I change the camera, it will take 15s or so for the picture to change. It was running better than this before with the only issue being a jerky picture after running for an hour or so. Any thoughts / suggestions?

    Thanks



  • @Nate said in Really Bad Lag:

    mjpeg-streamer

    here are a couple info pages i used when i experimented with mjpg-streamer.
    https://openwrt.org/docs/guide-user/hardware/video/webcam

    https://openwrt.org/packages/pkgdata/mjpg-streamer

    lag is an issue that seems to affect most small sbc type platforms. forums on robotics usually have lots of threads on latency issues. i used a nvidia tx1 2 years ago and i was surprised at the jitter and stalls then. the omega2+ i used had the overlay setup and a swap drive.
    might take a look at openwrt forum. this thread is archived now,
    https://forum.archive.openwrt.org/viewtopic.php?id=60201&p=1#p296534



  • @Nate the "top" command is your friend.



  • @crispyoz Nah the system isn't under any load CPU or memory wise. This is definitely network related in my opinion.

    @Douglas-Kryder Ok thank you sir! I'll give those a read and see what I can do. I really wanted to use a few Omega 2+s with the Mini Docks as some cheap network cameras around the house. If I can't get this resolved though I may have to switch to some rPi Zero Ws.


  • administrators

    @Nate are the Omegas connected to a WiFi network?
    If not and the WiFi client interface is active, it will scan for valid networks on a <10 second interval. This scanning kills the network throughput momentarily, forcing it to always be in catch-up mode.

    Sounds like this might be your issue from what you've described.

    To avoid this, just disable the wifi client interface:

    uci set wireless.sta.disabled='1'
    uci commit wireless
    wifi
    


  • @Lazar-Demin I tend to prefer to connect to the omegas through my router once they are connected to it, instead of through their own ap. In fact I just put up another thread asking what the correct way to disable the ap is because when I tried, the sta connection never would come back up once I disabled the ap one and Ihad to connect back via the ethernet expansion.

    I have a really good router but ended up buying little antennas to attach to the omegas. They have been working a lot better since then. The internal ones seem to be a bit lacking to me.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.