PuTTY Fatal Error when attempting to connect using SSH



  • I'm attempting to connect to my Omega2+ using SSH. I have a Windows 10 computer and PuTTY. I've set everything up according to the instructions here:
    https://docs.onion.io/omega2-maker-kit/connecting-to-the-omega-terminal.html

    I get the "login as:" prompt, type "root" and enter then get the PuTTY Fatal Error dialog
    "No supported authentication methods available (server sent: publickey)"
    Clicking "OK" closes PuTTY

    What does this mean and how do I fix it?

    I can connect using serial but would like to get SSH working.

    Also, when I tried using my browser to connect to the omega I get a blank page



  • @Elizabeth-Simon As you know your Omega and your host PC must be on the same WiFi network.

    • If your Omega and your PC are connected to the same WiFi Network (AP, router, Internet gateway, etc.)
      and - let's say - the Omega's (apcli0) IP address is 192.168.100.x use
      Host Name (or IP address) root@omega-ABCD.local (or root@192.168.100.x), Port 22, Connection Type: SSH
      The default password is: onioneer

    • 192.168.3.x
      Connect your PC to Omega's WiFi AP and use
      Host Name (or IP address) root@omega-ABCD.local (or root@192.168.3.1), Port 22, Connection Type: SSH
      The default password is: onioneer

    The right IP address always works. :)


    To use Omega's hostname (omega-ABCD.local) on Windows successfully you should install Apple’s Bonjour Service.
    Please read this post: cannot connect to omega-ABC.local



  • I have my Omega connected to my WiFi Network and by using the serial port access, I've found that the Omega's IP address is 192.168.3.1 but I get a network timeout when attempting to connect using the IP address.

    When I connect to omega-ABCD.local using Putty, I get the "login as:" prompt which tells me that I'm connected to something... The problem is that when I type "root" followed by enter, I get the fatal error and get kicked out.

    So I'm having less luck with the IP address which is really strange...

    I'm thinking now I need to dig out the older Omega that I set up before. Or maybe the older computer that I used to set it up...

    Oh, and this forum doesn't seem to be working right on Firefox. I have to use Microsoft Edge to type replies...



  • @Elizabeth-Simon if you are connected via the serial connection you don't use an IP you will use a serial connection option in putty. So in the main putty connection dialog, select serial instead of ssh and set the serial port you are using, this will depend on your hardware as to which com port you should use. In windows you may be able to look at the removable hardware to see which port the Omega is connected. Remember to set the baud rate to 115200, 8ns.

    If you have trouble finding your serial ports and you want an easy solution you can download a trial of ZOC (Emtec) it's a terminal/ssh app like putty and has a feature to detect your serial ports and if anything is connected to them (I've been using it since the days of OS/2).



  • @Elizabeth-Simon Sorry, I forgot to mention: to use keyboard interactive authentication in PuTTY you must enable the method.

    0_1578499314536_PuTTY_keyboard-interactive_auth.png



  • After some troubleshooting< I determined the following:

    Older Omega2+ (with older firmware) worked as expected. No problems connecting using SSH on PuTTY.

    I was able to connect to my new Omega2 using SSH on my older computer which had an older version of Putty.

    I uninstalled and removed all Putty files (not as easy as one would hope) then reinstalled and tried again with the same results.

    Finally, I noticed that I had the 32-bit version of Putty and installed the 64-bit version instead. That finally worked. So there is something with using the latest 32-bit putty on 64-bit windows that gives this fatal error with the latest version of Omega2+ firmware when doing SSH.

    At least it's working now so I can move on to the next step.



  • @Elizabeth-Simon said in PuTTY Fatal Error when attempting to connect using SSH:

    After some troubleshooting< I determined the following:

    Older Omega2+ (with older firmware) worked as expected. No problems connecting using SSH on PuTTY.

    I was able to connect to my new Omega2 using SSH on my older computer which had an older version of Putty.

    I uninstalled and removed all Putty files (not as easy as one would hope) then reinstalled and tried again with the same results.

    Finally, I noticed that I had the 32-bit version of Putty and installed the 64-bit version instead. That finally worked. So there is something with using the latest 32-bit putty on 64-bit windows that gives this fatal error with the latest version of Omega2+ firmware when doing SSH.

    At least it's working now so I can move on to the next step.

    So in the main putty connection dialog, select serial instead of ssh and set the serial port you are using, this will depend on your hardware as to which com port you should use. In windows you may be able to look at the removable hardware to see which port the Omega is connected. Remember to set the baud rate to 115200, 8ns. FedLoan Servicing


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.