OMEGA no longer working...



  • Hi,

    I have not had my Omega running for a few weeks. Powering up it does a number of blinks and then the amer light is premanent on - but I cannot "find" the unit.

    • I do not see the unit in my WiFi network - as I did before
    • I do not see the unit as an AP - as I did originally
    • I cannot factory reset using the two or three proceducres I found here
    • I cannot connect via USB/Serial (using CP210x_VCP_Windows) - putty stays black
    • I only have the mini dock, but no "big" dock (I am waiting for the battery dock which has never been shipped)
    • I do not have an ethernet dock

    **what to do? **

    thanks,
    Gordon


  • administrators

    @gosch How do you know that the factory reset does not work? Did you follow the instructions found on: https://wiki.onion.io/Documentation/Hardware/Omega-Hardware#the-hardware_reset-button_factory-restore

    Can you also post a photo of your setup?



  • Hi,

    I know that the factory reset does not work, because the unit does not go back into the status it had when I originally received it - easiest indication is that I do not see the onion AP!

    Here's my (very staight forward) setup...
    onion.jpg
    you can see the amber light is permantent on.

    Gordon



  • I also have a video of the power-up sequence.
    http://sendvid.com/imrk0sq3

    Gordon



  • On the video it is nicely to see that the pins are still visible ... you have to (the Omega powered off of course) press it firmly on the mini-dock, that the pins not are visible anymore. Otherwise you get wrong contacts and it will not work fine.

    Please do so and test again!



  • Hello,

    @Luciano S: thanks for the input. I have tried this in a number of configurations, but will do so again.

    @administrators: which pins do I need to shorten on the actual Onion board to get the RESET signal?

    Is there a description (or video) of a working startup sequence?

    thanks,
    Gordon



  • You just have to fix that your serial connection is working. Then you can see the boot up sequence as follows:
    Bootup Sequence from a Ω-ware: 0.0.8 b296 firmware

    *********************************************
    *   U-Boot 1.1.4  (Sep 14 2015, 08:21:31)   *
    *********************************************
    
    AP121 (AR9331) U-Boot for Onion Omega
    
    DRAM:   64 MB DDR2 16-bit
    id read ox100000ff
    FLASH: 16MCLOCKS: 400/400/200/20 MHz (CPU/RAM/AHB/SPI)
    
    LED on during eth initialization...
    
    Hit any key to stop autobooting:  0 
    
    Booting image at: 0x9F020000
    
       Image name:   OpenWrt r49097
       Image type:   MIPS Linux Kernel Image (lzma compressed)
       Data size:    1150088 Bytes = 1.1 MB
       Load address: 0x80060000
       Entry point:  0x80060000
    
    Uncompressing kernel image... OK!
    Starting kernel...
    
    [    0.000000] Linux version 3.18.29 (zh@ci-onion) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r49097) ) #1 Sat Apr 2 23:12:12 UTC 2016
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
    [    0.000000] SoC: Atheros AR9330 rev 1
    [    0.000000] Determined physical RAM map:
    [    0.000000]  memory: 04000000 @ 00000000 (usable)
    [    0.000000] Initrd not found or empty - disabling initrd
    [    0.000000] Zone ranges:
    [    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
    [    0.000000] Movable zone start for each node
    [    0.000000] Early memory node ranges
    [    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
    [    0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
    [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    [    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
    [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
    [    0.000000] Kernel command line:  board=ONION-OMEGA  console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
    [    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
    [    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
    [    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
    [    0.000000] Writing ErrCtl register=00000000
    [    0.000000] Readback ErrCtl register=00000000
    [    0.000000] Memory: 60880K/65536K available (2512K kernel code, 131K rwdata, 532K rodata, 272K init, 188K bss, 4656K reserved)
    [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    [    0.000000] NR_IRQS:83
    [    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
    [    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
    [    0.080000] pid_max: default: 32768 minimum: 301
    [    0.080000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.090000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.100000] NET: Registered protocol family 16
    [    0.100000] MIPS: machine is Onion Omega
    [    0.370000] Switched to clocksource MIPS
    [    0.370000] NET: Registered protocol family 2
    [    0.380000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.380000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.380000] TCP: Hash tables configured (established 1024 bind 1024)
    [    0.390000] TCP: reno registered
    [    0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [    0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [    0.410000] NET: Registered protocol family 1
    [    0.410000] futex hash table entries: 256 (order: -1, 3072 bytes)
    [    0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [    0.430000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [    0.440000] msgmni has been set to 118
    [    0.440000] io scheduler noop registered
    [    0.450000] io scheduler deadline registered (default)
    [    0.450000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
    [    0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a AR933X UART
    [    0.470000] console [ttyATH0] enabled
    [    0.470000] console [ttyATH0] enabled
    [    0.470000] bootconsole [early0] disabled
    [    0.470000] bootconsole [early0] disabled
    [    0.480000] m25p80 spi0.0: found w25q128, expected m25p80
    [    0.490000] m25p80 spi0.0: w25q128 (16384 Kbytes)
    [    0.490000] 5 tp-link partitions found on MTD device spi0.0
    [    0.500000] Creating 5 MTD partitions on "spi0.0":
    [    0.500000] 0x000000000000-0x000000020000 : "u-boot"
    [    0.510000] 0x000000020000-0x000000138e88 : "kernel"
    [    0.510000] 0x000000138e88-0x000000ff0000 : "rootfs"
    [    0.520000] mtd: device 2 (rootfs) set to be root filesystem
    [    0.520000] 1 squashfs-split partitions found on MTD device rootfs
    [    0.530000] 0x000000840000-0x000000ff0000 : "rootfs_data"
    [    0.540000] 0x000000ff0000-0x000001000000 : "art"
    [    0.540000] 0x000000020000-0x000000ff0000 : "firmware"
    [    0.580000] libphy: ag71xx_mdio: probed
    [    1.170000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
    [    1.180000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
    [    1.180000] TCP: cubic registered
    [    1.180000] NET: Registered protocol family 17
    [    1.190000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
    [    1.200000] 8021q: 802.1Q VLAN Support v1.8
    [    1.210000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
    [    1.220000] Freeing unused kernel memory: 272K (8037c000 - 803c0000)
    [    2.760000] init: Console is alive
    [    2.760000] init: - watchdog -
    [    5.890000] usbcore: registered new interface driver usbfs
    [    5.890000] usbcore: registered new interface driver hub
    [    5.900000] usbcore: registered new device driver usb
    [    5.950000] SCSI subsystem initialized
    [    5.970000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    5.970000] ehci-platform: EHCI generic platform driver
    [    5.980000] ehci-platform ehci-platform: EHCI Host Controller
    [    5.980000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
    [    5.990000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
    [    6.020000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
    [    6.020000] hub 1-0:1.0: USB hub found
    [    6.020000] hub 1-0:1.0: 1 port detected
    [    6.040000] usbcore: registered new interface driver usb-storage
    [    6.870000] init: - preinit -
    [    7.640000] random: procd urandom read with 12 bits of entropy available
    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
    [   10.840000] mount_root: loading kmods from internal overlay
    [   11.240000] jffs2: notice: (338) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    [   11.250000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
    [   11.260000] block: unable to load configuration (fstab: Entry not found)
    [   11.260000] block: attempting to load /tmp/jffs_cfg/etc/config/fstab
    [   11.270000] block: unable to load configuration (fstab: Entry not found)
    [   11.280000] block: attempting to load /etc/config/fstab
    [   11.290000] block: unable to load configuration (fstab: Entry not found)
    [   11.290000] block: no usable configuration
    [   11.380000] jffs2: notice: (335) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    [   11.560000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
    [   11.560000] block: unable to load configuration (fstab: Entry not found)
    [   11.570000] block: attempting to load /tmp/jffs_cfg/etc/config/fstab
    [   11.580000] block: unable to load configuration (fstab: Entry not found)
    [   11.580000] block: attempting to load /etc/config/fstab
    [   11.590000] block: unable to load configuration (fstab: Entry not found)
    [   11.590000] block: no usable configuration
    [   11.600000] mount_root: overlay filesystem has not been fully initialized yet
    [   11.610000] mount_root: switching to jffs2 overlay
    [   11.660000] procd: - early -
    [   11.660000] procd: - watchdog -
    [   12.460000] procd: - ubus -
    Command failed: Not found
    [   13.480000] procd: - init -
    Please press Enter to activate this console.
    [   16.320000] NET: Registered protocol family 10
    [   16.340000] ntfs: driver 2.1.31 [Flags: R/O MODULE].
    [   16.410000] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [   16.440000] i2c /dev entries driver
    [   16.450000] Custom GPIO-based I2C driver version 0.1.1
    [   16.450000] i2c-gpio i2c-gpio.0: using pins 21 (SDA) and 20 (SCL)
    [   16.490000] Linux video capture interface: v2.00
    [   16.520000] hidraw: raw HID events driver (C) Jiri Kosina
    [   16.610000] Bluetooth: Core ver 2.19
    [   16.610000] NET: Registered protocol family 31
    [   16.610000] Bluetooth: HCI device and connection manager initialized
    [   16.620000] Bluetooth: HCI socket layer initialized
    [   16.630000] Bluetooth: L2CAP socket layer initialized
    [   16.630000] Bluetooth: SCO socket layer initialized
    [   16.640000] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   16.640000] Bluetooth: BNEP filters: protocol multicast
    [   16.650000] Bluetooth: BNEP socket layer initialized
    [   16.660000] usbcore: registered new interface driver btusb
    [   16.670000] usbcore: registered new interface driver cdc_acm
    [   16.670000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
    [   16.680000] Loading modules backported from Linux version v4.4-rc5-1913-gc8fdf68
    [   16.690000] Backport generated by backports.git backports-20151218-0-g2f58d9d
    [   16.700000] Bluetooth: HCI UART driver ver 2.2
    [   16.700000] Bluetooth: HCI H4 protocol initialized
    [   16.710000] Bluetooth: HCI BCSP protocol initialized
    [   16.720000] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [   16.720000] Bluetooth: HIDP socket layer initialized
    [   16.730000] ip_tables: (C) 2000-2006 Netfilter Core Team
    [   16.750000] nf_conntrack version 0.5.0 (955 buckets, 3820 max)
    [   16.790000] Bluetooth: RFCOMM TTY layer initialized
    [   16.790000] Bluetooth: RFCOMM socket layer initialized
    [   16.800000] Bluetooth: RFCOMM ver 1.11
    [   16.820000] usbcore: registered new interface driver ums-alauda
    [   16.830000] usbcore: registered new interface driver ums-cypress
    [   16.840000] usbcore: registered new interface driver ums-datafab
    [   16.840000] usbcore: registered new interface driver ums-freecom
    [   16.850000] usbcore: registered new interface driver ums-isd200
    [   16.860000] usbcore: registered new interface driver ums-jumpshot
    [   16.870000] usbcore: registered new interface driver ums-karma
    [   16.880000] usbcore: registered new interface driver ums-sddr09
    [   16.890000] usbcore: registered new interface driver ums-sddr55
    [   16.890000] usbcore: registered new interface driver ums-usbat
    [   16.910000] usbcore: registered new interface driver usbhid
    [   16.910000] usbhid: USB HID core driver
    [   16.920000] usbcore: registered new interface driver usblp
    [   16.930000] usbcore: registered new interface driver usbserial
    [   16.940000] usbcore: registered new interface driver usbserial_generic
    [   16.940000] usbserial: USB Serial support registered for generic
    [   16.960000] usbcore: registered new interface driver uvcvideo
    [   16.970000] USB Video Class driver (1.1.1)
    [   16.980000] Driver for 1-wire Dallas network protocol.
    [   17.010000] xt_time: kernel timezone is -0000
    [   17.070000] usbcore: registered new interface driver ch341
    [   17.070000] usbserial: USB Serial support registered for ch341-uart
    [   17.080000] usbcore: registered new interface driver cp210x
    [   17.090000] usbserial: USB Serial support registered for cp210x
    [   17.090000] usbcore: registered new interface driver ftdi_sio
    [   17.100000] usbserial: USB Serial support registered for FTDI USB Serial Device
    [   17.210000] usbcore: registered new interface driver pl2303
    [   17.210000] usbserial: USB Serial support registered for pl2303
    [   17.220000] PPP generic driver version 2.4.2
    [   17.230000] NET: Registered protocol family 24
    [   17.250000] usbcore: registered new interface driver snd-usb-audio
    [   17.350000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
    [   34.710000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   34.850000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   53.460000] random: nonblocking pool is initialized
    
    
    
    BusyBox v1.23.2 (2016-04-02 23:02:29 UTC) built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.0.8 b296
     -----------------------------------------------------
    root@Omega-269D:/# 
    
    

  • administrators

    @gosch Yep, @Luciano-S is correct, you need to firmly press in the Omega into the Mini Dock so the pins are not visible:
    Omega+Mini Dock

    You can check the Omega pin-out diagram for specifics of which pin is the reset pin: https://wiki.onion.io/Documentation/Hardware/Pinout-Diagram
    Note that the reset is Active High.

    I suspect that since your Omega was not fully plugged into the dock, there was no voltage applied to the reset pin and it was never carried out.
    If you're connected to the Omega via the serial terminal, you should see


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.