Root password not working?



  • Hello there,

    I need to access the Omega from its command line, and since it's not connected to the Internet, I kept the default "onioneer" password. While it works from the GUI, the connection is refused from a standard Terminal on the host computer. Is this password different?

    Also, I noticed the "-" character, as well as others accessible through "alt" key, are not passed to the Web-based Terminal. Is there a way to solve this bug?

    thanks to all,



  • @Patrick-Nou said in Root password not working?:

    I need to access the Omega from its command line, and since it's not connected to the Internet, I kept the default "onioneer" password. While it works from the GUI, the connection is refused from a standard Terminal on the host computer. Is this password different?

    Not really, refused means no rights to connect over ssh. Pleas check in internet how to configure it for your OS first.

    Also, I noticed the "-" character, as well as others accessible through "alt" key, are not passed to the Web-based Terminal. Is there a way to solve this bug?

    This is indeed a problem of the 3th party software it is used on Omega. The workaround is ssh as you tried. Fix this first on your OS with the refused problem.

    How about connecting as described in onion.io/getstarted ? So you could resolve the Internet problem and update your omega.



  • @Luciano-S. I don't really understand. The Omega is now connected to Internet on a common router (Though this router doesn't allow connections from the Internet to the Omega), and I try to connect using its DHCP-assigned IP address, just as I do in Firefox to reach the GUI.

    I have no issues with SSH access from this computer to any other device.

    The Omega still refuses the default password. Is user root allowed for SSH access?



  • @Patrick-Nou said in Root password not working?:

    @Luciano-S. I don't really understand.

    What you really not understand?

    The Omega is now connected to Internet on a common router (Though this router doesn't allow connections from the Internet to the Omega), and I try to connect using its DHCP-assigned IP address, just as I do in Firefox to reach the GUI.

    Did you read this > https://wiki.onion.io/Tutorials/Connecting-to-Omega-via-SSH ?

    On the omega is a firewall, if you are not in the same ip range as the Omega you might get this message of being refused.

    I have no issues with SSH access from this computer to any other device.

    The Omega still refuses the default password. Is user root allowed for SSH access?

    It wouldn't be used root in the Tutorial, if root not would be allowed to connect.



  • @Luciano-S. I am on the same IP range as the Omega, as are all other LAN-connected devices. However, SSH access works only when the computer is connected directly to the Omega, but not when both are connected to the same router.

    As you point out, this may be on purpose, but annoying nevertheless. Shouldn't connections request from LAN be always trusted by default? How do I set the Omega for normal access through other LAN computers?



  • @Patrick-Nou said in Root password not working?:

    As you point out, this may be on purpose, but annoying nevertheless. Shouldn't connections request from LAN be always trusted by default? How do I set the Omega for normal access through other LAN computers?

    I guess it is just a matter of configuration. If you use your Omega as AP (access point) you are isolated of your home network. But you can also activate wireless and connect with the omega to your home wireless, then a connection from other Computers should be possible ?!

    Btw, security should not annoy !


  • administrators

    @Patrick-Nou Ok, did I understand this correctly:

    • Your Omega is connected to your home wifi network
    • The Terminal App on the Console works fine
    • You cannot use SSH from a terminal on your laptop to access the Omega?

    If that's the case, can you paste an example of the command you use to connect to the Omega via SSH and the output of the command?

    If I misunderstood the issue, let me know! :)


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.