The original firewall configuration is correct. The problem is the

config interface 'usb' option ifname 'wwan0' option proto 'dhcp'

After removing this from /etc/config/network, I can get internet on the mobile device after connecting to the Omega.