We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Card Reading Progressing!! But need some help...

  • Hey there everyone!

    So lots of progress has been made on our card reader today. To keep things short and sweet, the end goal is to get the relay board to turn on when an approved ID is passed through the card reader. Then after a short time, the relay should turn off and the script should basically for all intents and purposes, restart the script from the beginning. WE BASICALLY HAVE ALL THAT WORKING! šŸ˜„ But sadly I have now lost input when I swipe my card now after putting all the individual functions together that worked independently when only doing their assigned task.

    I have a sneaking suspicion that it's something very obvious and it's going right over my head, but I have spent an hour pouring over my code and can't seem to find the hole yet. So here I am opening it up to the community! Would greatly appreciate all the help!

    Below I have all my code and screen shots of when I run the program and swipe my card a whole bunch and of the line it gets hung up on when I end it with ^C


Looks like your connection to Community was lost, please wait while we try to reconnect.