We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

I Might Be Back .....

  • Just put router into WPA-TIRK from None. Now not getting Omega to do it's thing like before with None. Can't do Firmware Update in Console. Wheel keeps spinning. What am supposed to have in Wi-Fi Access Point Setup in Console and should AP mode be enabled? This is when I have router in WPA-TIRK.

  • I think Omega2+ should be renamed Erratic2+. Every time I fired it up, I never know what to expect. I'm 79 and this experiment is the biggest time waster. My time is valuable. I'm done. I give Onion a month to fix 90% of the problems or I'm going to talk to Kickstarter or Indiegogo. Onion: You need to hire 100 good guys and get it done.

  • Don,
    If you can turn off your wifi security and get the omega connected to the internet, I would recommend trying to do a manual firmware flash using the latest firmware update. It has cleared up a lot of the weird issues I was having. I did the firmware update, then a factory reset, and my unit has been working really well so far.
    I get the frustration but just in the past two weeks the documentation has been greatly expanded, we're getting new firmware which is fixing issues, and the devs are getting more involved on the forums. It's a new unit, have patience! It's the nature of a kickstarter šŸ™‚

  • @cusackph Thanks for being positive. I'll give your suggestion a go in a few days. I think one problem causes another. It's really frustrating to start the Console and see the gear turning and turning and nothing, And then I look with something else and then go back to Console, all of it comes up in a second. What could I have done to "fix" it? And I see the wireless connection just break with no apparent reason. And then I re-connect, but that doesn't do any good unless I start all over. And then I see something strange I never have seen before. And why does it quit with router encryption. And then all the info I filled out in the Console disappears. The AP Setup in the Console will show one thing and then another. The worst is not knowing the meaning of WHY this is happening. Like a big plot against me. šŸ˜–

  • I totally get that. My suggestion is to just take things one step at a time. I'd say first, leave your wifi open and get the latest version of your firmware installed using the instructions I linked. Don't try to do it through the console, SSH in and do it that way.
    After that, figure out why your unit won't connect to your wifi connection. I think I remember seeing that you were using TKIP for security, which may be the problem. Could you switch it to AES without any problems? Like, are there any devices you own that need TKIP? I use AES and have everything from my laptop to old Kindle connected with no problems.
    Regarding the web console, it's definitely still a bit buggy. Try using Edge on your windows 10 box. I have an apple laptop and most things in the console don't work at all in Safari so I use Firefox.

    What dock/expansions do you have?

  • I decided to write a step by step of what I see trying to bring up the Omera2+. The latest firmware is now used: 0.1.8(b145). Downloaded and installed via PuTTY, not the Console. Followed: Manual Firmware Installation in Omega2 Documentation.

    Omega2+ and Power Dock Notes
    Router not Secure, Open

    1. Switch off, power connected, charge LEDs flashing.
    2. Switch on, blue LED on, amber LED solid, then flashing.
    3. After minute amber LED solid.
    4. See Omega-9ED7 Secured, comes up very slow and not connected in PC tray.
    5. Finally click on Connect.
    6. Now see Omega-9ED7 Connected, secured.
    7. Open PuTTY, see Linux prompt, login root, password onioneer, Firmware says 0.1.8(b145)
    8. Open Chrome,
    9. Console opens, but have to login. Sometimes entries are already filled in
      root, onioneer
    10. Click on Settings.
    11. See, my Wi-Fi network.
    12. Click on General Settings.
    13. See Omega Name Omega-9ED7 and my Timezone OK.
    14. Nothing in Security Settings.
    15. Click on Wi-Fi Settings.
    16. See NETGEAR 3 times, and 2 unknown icons with checkmarks. Enable Wi-Fi checked.
    17. Click on Wi-Fi AP Settings.
    18. See Omega-9ED7, WPA2, onioneer, in correct locations.
    19. Didn't click Configure AP. Many times I see root in SSID location and onioneer in Password. I don think this is correct. I put in in Omega-9ED7 and 12345678.
    20. Click on Firmware Upgrade.
    21. Firmware says 0.1.8(b145), but Latest Firmware says 0.1.7(b139), No Upgrade required.
    22. Wi-Fi still connected as in Step 6. This would disconnect. Much better now.
    23. Did not try any Tools in Console.
    24. Did shutdown by closing Console and switching Omega off.

    It seems there is a bad relationship between login and password not filled out automatically, root and other entries in Wi-Fi Access Point Setup incorrect, and Wi-Fi disconnecting. However, improved over 0.1.7(b139). Don't know results when router is returned to secure. I think timing between processes in the source code is part of many problems. Plus operator error. šŸ˜ž

  • Still having pretty good luck with Omega and Omega2+. Wireless needs to be tweaked a bit but it works great. I got Ethernet to work with just a few fiddles. I even put the Omega2+ and the GPS dongle into a window and eventually got solid GPS data from 13 satellites. GPIO seems broken with the current build. At least when following the examples. Granted being a computer and Linux and network guy helps with all of this. But it does work.

  • Don,
    Making progress! A couple things:

    1. It's good that your PC doesn't automatically connect to the Omega2's access point. You don't want your PC switching network connections constantly every time you turn your unit on. Once you get your Omega set up on your home wifi network with security on, you really won't even need to worry about it. Which leads me to...
    2. Have you tried switching to AES encryption on your home network? If none of your devices need TKIP it'd probably be better to just set your router to AES. The Omega2 should work just fine then and I doubt any of your other devices will flinch. Again, only if you don't have anything that has to have TKIP. Once you get the Omega2 connected to your AES-security home wifi, you can SSH into it without having to connect your pc the Omega2's AP, so you won't even need to worry about #1 here.
    3. It sounds like Chrome may be saving some passwords in the wrong fields for you. This isn't an Omega2 problem; in Chrome under Settings, then Advanced settings, click 'Manage passwords' and remove anything saved that has to do with the Omega2, that should prevent it from filling passwords in on those fields you mentioned. Save the login for the Console again if you want to.

    If I were you I'd worry about getting the wifi stuff sorted out. Once you have the Omega securely connected to your home wifi you can SSH in and take care of a ton of stuff via the CLI. The console still isn't working 100% for me either, but I can at least connect to my unit reliably 100% of the time now.

  • I just changed router to WPA2-AES. And I'll look at Chrome next. You're right, I might have said Yes to saving passwords. I hate that question in non-Linux OS's! cusackph, I'll get back, you have been most helpful. It would be great to just add the updates for a while and not to wonder what misery I'll have today! Thanks,

    Well, no joy again. Changed router to WPA2 AES. Now amber won't stop flashing after it's solid on! Went back to Open. Still flashing! The same erratic condition of not seeing root or login starting Console, not seeing my local Wi-Fi IP from router, wrong stuff in looking at AP setup, and Omega-9ED7 disconnecting is still happening. What I noticed, even with amber always flashing, I can still use PuTTY to get into Linux. And can still get into Console. The correct condition I think is seeing root and onioneer when starting Console, seeing the IP from router in Settings, correct I think of Omega-9ED7, WPA2, password of 123456768, and IP address of 192,168.3.1
    Nothing has really changed for the better with the 01.18(b145) firmware. at least for me. Too bad fsck doesn't work in this brand of Linux. Maybe, it would help.
    Back into the woodwork! Think I'll rebuild my XTAL SET.

  • Don,
    Shoot! It looked like you were good to go.
    The Omega's amber light should have nothing to do with your wifi security settings. If the rest of your devices are good with WPA2-AES, keep it that way. It's better no matter what
    Try this: Unplug and replug the power to your Omega 2. Let the unit sit for ~10 minutes without doing anything just to be safe. Then, connect to its AP from your desktop and SSH in. Then let it sit for 10 minutes and run a command (ls is easy enough). what happens?

  • It's been a few hours, I can bring it up, no forever blinking. This has happened before. A couple of times I powered with a bench supply and saw current going from 200 ma to 0 and 2 seconds back to 200. This happened over and over. Let it sit for a while, it went to normal. Anyway, if I leave it on and not touch anything, it behaves. All the parameters have to be right. Now, router still open. PuTTY usually never fails.

    Which one? I tried the 2nd so far. The 2 others are None and WEP. Think that's when continuous blinking started. I could try again. Can you tell me what you show on your various screens? Where you located? I'm in LA, USA

    I put back WPA2-PSK[AES]. Did a cold re-start. Amber started blinking, but will not stop. Stumped!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.