We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Resolved] Console shows "Index of /console/" only. Seems like it reset completely, but didnt complete.

  • That is my big question, as I left them on overnight and went to bed. I had secured them by changing passwords and my internal wifi is secure as well. I am hoping this isn't normal or reoccurring based on being on and online for an extended period of time. I hope this was a one-off.

    More playing for me tonight, just to get used to linux and try and pick up some programming (no experience on the programming points). I have some 16GB SD Cards arriving tomorrow, and will be working on extending and installing the node red stuff on both. One is going to be a security web cam and the other is a play device. I really wanna figure out how to get the info from the GPS chip formatted to fit and display on the OLED. Ran in circles last night with it.

  • @Costas-Costas said in [Resolved] Console shows "Index of /console/" only. Seems like it reset completely, but didnt complete.:

    @Luciano-S any idea what's happening to the Omega's to cause this?

    Faulty chips perhaps?

    Mine Omega2+ is still on transit. I tell you when i get the same then đŸ˜‰

  • I am going to leave these as they are when I get home, get them up and running and let them sit overnight again and see what happens.

    The one had been online and working (internal wifi only) for a few days until I upgraded to the latest firmware that fixed the onion cloud registration. It was working fine.

    Will test out overnight and see.

  • I have the same on one of my 2+, that index page. I had just updated it and installed the console. Set something in settings and tried to reboot. (My two 2+ have no blinking led initially, now they blink all the time).
    Some minutes later when I wanted to open the console there was only that index page.

  • @Anders-Ă–ster Try what I did by downgrading the firmware, then doing the upgrade again after you have it back online. I had to use the Serial com port access to do it. Not being a power user like others around, and having no experience with Linux or programming, it probably took me longer than others would have.

    but downgrading the firmware and then upgrading it worked for me on both of my devices.

  • I did the sysupgrade this morning using the same firmware file s you did. I also installed the consol manually and logged in and made some settings. Then I shut it down and now in the evening I boot the 2+ and check the console. I only get the index page. I'm using the power dock and shut down the 2+ with it's switch.

  • I ran into the same problem with my Omega2+. After some tinkering, I was able to fix it by running (via ssh or usb tty):

    /overlay/upper/etc/init.d/console restart

    I did not have to downgrade the firmware.

  • @Scott-Williams Gonna have to keep that in mind. This is my first foray into this kind of device and programming. I got the Omega2+ on a whim cause it sounded cool. I had no idea I was going to have to be a old school sysadmin to be able to effectively use it.

  • @Brad-Buskey I'm right here with you. I booted this thing on for the first time this morning. I have extensive Linux experience on servers and workstations, but the layout of the Omega2 is a different beast as it's not Debian or Red Hat based. Now that it's setup, it seems pretty cool, but the setup was way more intense than I was expecting. In fairness, the Raspberry Pi and Arduino have been in the market for several years and you have to expect some things like this on an initial launch.

  • @Scott-Williams which fw version are you on? I don't have init.d under /overlay/upper/etc

  • @Anders-Ă–ster 0.1.9 (b149)

    If you don't have it there, perhaps you didn't install the console initially through the setup? You can also install it with:

    opkg update
    opkg install onion-console-base

  • Ok, I think I always installed it manually like that.

  • @Brad-Buskey said in [Resolved] Console shows "Index of /console/" only. Seems like it reset completely, but didnt complete.:

    I had no idea I was going to have to be a old school sysadmin to be able to effectively use it.

    If you where paying attention to the Kickstarter Video they mentioned to do things as Tony Stark. They just forgot to communicate that we have to be expert as he đŸ˜‰

  • I had a glimmer of hope after using /etc/init.d/console restart. It brought the console back to normal but after a restart, it was back to just showing Index of /console/.

    It seems like the memory has issues keeping the files.

  • @Brad-Buskey After using your downgrade steps, I got this message:

    root@Omega-B1A3:~# sysupgrade omega2p-v0.1.8-b148
    Image metadata not found
    Invalid image type.
    Image check 'platform_check_image' failed.

    Hopefully there will be an upgrade that fixes this...

  • @Marty-Mickelson Try a different image file. there are plenty to choose from in the repo.

  • @Brad-Buskey Hm, so I tried using b150 and it seemed to work. I was able to go to the console page and start through the setup wizard again. It had issues with the wifi step. It showed my wifi networks and I chose the same one I've been using. It said configuring wifi for a really long time so I decided to restart it. I SSH'd to it and ran the install again. This time the upgrade failed writing to the firmware. The lights turned off and wifi doesn't work. When I turn it on, the lights blink for a few seconds, then go dark. I think I bricked it.

    I'll look for how to manually fix it if it's possible. For now, I'm going to go drown my sorrows.

  • I ran into the wifi issue as well, after restoring from a mess I created. I ended up connecting via ssh, running wifisetup and setting it up that way. when you go through the web set up it will detect it is already connected and you can skip the wifi part and move on to the next part.

  • @Brad-Buskey did you have to connect through the usb if the wifi didn't work?

  • no, it showed up on my wifi list on my PC. but you can do that through the Serial connection if you have a doc that supports that (Expansion Dock or Mini Dock).

Looks like your connection to Community was lost, please wait while we try to reconnect.