We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Domoticz on Omega2+ with Z-Wave dongle

  • As a user of Domoticz since several month I have my primary controller for home automation installed on a Synology NAS.

    I have two sticks to control my sensors and switches, a ZW090 Z-Wave stick and a RFXCOM RFXtrx433E.

    Since Domoticz is supported on LEDE and Omega2+ is a derivation of LEDE I tried to make it operationnal.

    Followed steps :

    1. Be sure to have latest firmware
      oupgrade -c
      1.1 If not, then upgrade firmware
    2. Be sure to have latest packages list
      opkg update
    3. Install curl because I need it in some of my Domoticz shell
      opkg install curl
    4. Get access to genuine LEDE repo by editing /etc/opkg/distfeeds.conf as documented in Onion Omega2 documentattion [https://docs.onion.io/omega2-docs/using-opkg.html]
    5. reboot and update package list
      opkg update
    6. Install Domoticz
      opkg install domoticz
    7. reboot

    Domoticz starts and is accessible via http://<your ip address>:8080

    But I now faced three issues :

    • Usage of curl with https:// site gives error (77). No error with sites without SSL (http://)

    • When plugging ZW090 usb Z-wave stick on Powerdock usb connector on a running Omega2+ system powered on battery, it crashes and I have to reboot it.
      When ZW090 is plugged before system starts it seems to works and devive /dev/ttyACM0 is created (on the same battery powered system).

    • OpenZwave driver error when trying to add ZW090 controller to Domoticz
      Plugged Aeon Labs Aeotec Z-Wave Z-Stick (ZW090). Seems to be recognized by Omega2+ by adding /dev/ttyACM0 but can't add it in Domoticz Hardware. Log says "Openzwave driver failed!". But I can't figure out where to look for the origin of this issue (missing module in OS, missing package in opkg or trouble with Domoticz LEDE package on Omega2+ modified LEDE OS)

    Any suggestions ?

  • @Hugues-Mercusot
    The curl service gives you the errors (48 or 77) because of the different versions of curl and libcurl. (e.g curl 7.54.1 and libcurl 7.52.1). You may update the libcurl version by issuing the following command:

    opkg install curl libcurl

    I hope this will help. however, we cannot provide you with any further details on Z-wave.
    Stay tuned.

  • re: 2nd case ("live-plug" the USB when Omega2+ is live and running)

    This is due to sudden current inrush causing Omega2+'s operation voltage drop below threshold. There were a few threads talking about the symptom. A good electronic engineer/designer can help you on that.

    re: 3rd case (ZW090 driver)
    There are two part of device driver. Bottom-half is the CDC-ACM driver which is a USB-serial driver (typically 9600 bps or 40000 bps.) Upper-half parses the Z-Wave protocol into the low-level serial protocol.


  • Thank you very much to Pavel for the curl issue. I had to re-install curl and libcurl from LEDE repo and not Onion repo to get 7.54.1 (from Onion I got 7.52.1), but that,s not solved the issue another package was missing "ca-bundle".
    After opkg install curl libcurl ca-bundle all is fine for curl.

    Regarding to the current issue, thanks to ccs_hello. I guess you're right with the curret inrush explanation, but the issue is present only when Omega2+ is on battery, when alimentation is from micro-usb all seems to be ok. The same when i reboot the Omega2+ on battery with the USB stick already plugged. Then it's not a "show stopper" issue because this stick that made gateway between the "z-wave network" will be always plugged in. Just weird to see the different reactions of Omega2+

    Finally, thanks again to css_hello, I understand that the USB-serial driver is "built-in"Omega2+ firmware because the device ttyACM0 is created when stick is plugged in, but the upper-half of the driver (the z-wave part) is supposed to be complied against Domoticz. Perhaps a incompatibility with packages compiled against Domoticz and some others compiled against Omega2+. May be I had to try to recomplie the Openzwave driver on Omega2+.

  • @Hugues-Mercusot
    In order to use the curl you have to install the following:
    ca-certificates and ca-bundle
    The error happened because ca-certificates is used to allow SSL-based applications to check for the autchencity of SSL connections and ca-bundle is the file that contains root and intermediate certificates.

Looks like your connection to Community was lost, please wait while we try to reconnect.